summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2005-02-01 03:22:05 +0000
committerLuca Barbato <lu_zero@gentoo.org>2005-02-01 03:22:05 +0000
commit032f436e4f994a8dd82842603fa643b216d4d4d1 (patch)
tree510868cd7dc831c9e82130627329445afa3490fd /app-emulation/bochs
parentNew Maintainer->Check changelog (diff)
downloadgentoo-2-032f436e4f994a8dd82842603fa643b216d4d4d1.tar.gz
gentoo-2-032f436e4f994a8dd82842603fa643b216d4d4d1.tar.bz2
gentoo-2-032f436e4f994a8dd82842603fa643b216d4d4d1.zip
Typo fix
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-emulation/bochs')
-rw-r--r--app-emulation/bochs/ChangeLog7
-rw-r--r--app-emulation/bochs/bochs-2.1.1.ebuild4
-rw-r--r--app-emulation/bochs/files/bochs-2.1.1-regparm-typo.patch11
3 files changed, 20 insertions, 2 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index 15db9b86e505..8a5fe7f30397 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/bochs
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.37 2005/01/09 10:44:35 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.38 2005/02/01 03:22:05 lu_zero Exp $
+
+ 01 Feb 2005; Luca Barbato <lu_zero@gentoo.org>
+ +files/bochs-2.1.1-regparm-typo.patch, bochs-2.1.1.ebuild:
+ Fix a tipo in the fpu code, solves bug #58827, thanks to Christian Adaker
+ <christianadaker@hotmail.com>
09 Jan 2005; Sven Wegener <swegener@gentoo.org> bochs-2.1.1.ebuild,
bochs-2.1.ebuild:
diff --git a/app-emulation/bochs/bochs-2.1.1.ebuild b/app-emulation/bochs/bochs-2.1.1.ebuild
index ff9907095527..28e0ce29517f 100644
--- a/app-emulation/bochs/bochs-2.1.1.ebuild
+++ b/app-emulation/bochs/bochs-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.1.ebuild,v 1.18 2005/01/09 10:44:35 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.1.ebuild,v 1.19 2005/02/01 03:22:05 lu_zero Exp $
inherit eutils wxwidgets
@@ -33,6 +33,8 @@ src_unpack() {
-e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in || \
die "sed Makefile.in failed"
# epatch ${FILESDIR}/${P}-gcc3.patch || die
+ #Quick fix for a typo
+ epatch ${FILESDIR}/${P}-regparm-typo.patch ||die
}
src_compile() {
diff --git a/app-emulation/bochs/files/bochs-2.1.1-regparm-typo.patch b/app-emulation/bochs/files/bochs-2.1.1-regparm-typo.patch
new file mode 100644
index 000000000000..d70eab91b8b6
--- /dev/null
+++ b/app-emulation/bochs/files/bochs-2.1.1-regparm-typo.patch
@@ -0,0 +1,11 @@
+--- bochs-2.1.1.orig/fpu/reg_ld_str.c 2004-02-11 23:28:52.000000000 +0100
++++ bochs-2.1.1/fpu/reg_ld_str.c 2005-02-01 03:56:42.581554616 +0100
+@@ -315,7 +315,7 @@
+
+
+ /* Get a short from user memory */
+-int BX_CPP_AttrRegparmN(1)
++int BX_CPP_AttrRegparmN(2)
+ FPU_load_int16(bx_address _s, FPU_REG *loaded_data)
+ {
+ s16 s, negative;