summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-10-10 20:12:44 +0000
committerMamoru Komachi <usata@gentoo.org>2003-10-10 20:12:44 +0000
commita72d2de0957d672f1903ace341bdebd8bfdc321c (patch)
tree3b524167ea36decc415dec2f92e4e1930dad1b03 /app-emacs/wanderlust/wanderlust-2.10.1-r1.ebuild
parentMigrated from app-emacs/wl to app-emacs/wanderlust. Removed intermediate CVS ... (diff)
downloadgentoo-2-a72d2de0957d672f1903ace341bdebd8bfdc321c.tar.gz
gentoo-2-a72d2de0957d672f1903ace341bdebd8bfdc321c.tar.bz2
gentoo-2-a72d2de0957d672f1903ace341bdebd8bfdc321c.zip
Migrated from app-emacs/wl to app-emacs/wanderlust. Removed intermediate CVS snapshots.
Diffstat (limited to 'app-emacs/wanderlust/wanderlust-2.10.1-r1.ebuild')
-rw-r--r--app-emacs/wanderlust/wanderlust-2.10.1-r1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/app-emacs/wanderlust/wanderlust-2.10.1-r1.ebuild b/app-emacs/wanderlust/wanderlust-2.10.1-r1.ebuild
new file mode 100644
index 000000000000..9b08ad8054f4
--- /dev/null
+++ b/app-emacs/wanderlust/wanderlust-2.10.1-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/wanderlust/wanderlust-2.10.1-r1.ebuild,v 1.1 2003/10/10 20:12:39 usata Exp $
+
+inherit elisp
+
+MY_P="${P/wanderlust/wl}"
+
+IUSE="ssl"
+
+DESCRIPTION="Wanderlust is a mail/news reader supporting IMAP4rev1 for emacsen"
+HOMEPAGE="http://www.gohome.org/wl/"
+SRC_URI="ftp://ftp.gohome.org/wl/stable/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 alpha sparc ppc"
+
+DEPEND="virtual/emacs
+ >=app-emacs/apel-10.6
+ virtual/flim
+ virtual/semi
+ !app-emacs/wanderlust-cvs"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ if [ -n "`use ssl`" ] ; then
+ cd ${S}
+ echo "(setq wl-install-utils t)" >> WL-CFG
+ fi
+}
+
+src_compile() {
+ make || die
+ make info || die
+}
+
+src_install() {
+ make \
+ LISPDIR=${D}/usr/share/emacs/site-lisp \
+ PIXMAPDIR=${D}/usr/share/wl/icons \
+ install || die
+
+ elisp-site-file-install ${FILESDIR}/70wl-gentoo.el || die
+
+ dodir /usr/share/wl/samples
+
+ insinto /usr/share/wl/samples/ja
+ doins samples/ja/*
+ insinto /usr/share/wl/samples/en
+ doins samples/en/*
+
+ doinfo doc/wl-ja.info doc/wl.info
+ dodoc BUGS* ChangeLog INSTALL* README*
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see /usr/share/doc/${P}/INSTALL.gz."
+ einfo "And Sample configuration files exist on /usr/share/wl/samples."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}