summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-04-03 22:47:07 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-04-03 22:47:07 +0000
commit3d9aef197b3ec3a956c0389e4b9ca12a7e2c1fb6 (patch)
treeef28e3038e018fbd72ea3cd37ee03d53d56425d7 /app-emacs/ognus
parentCorrected ChangeLog (diff)
downloadgentoo-2-3d9aef197b3ec3a956c0389e4b9ca12a7e2c1fb6.tar.gz
gentoo-2-3d9aef197b3ec3a956c0389e4b9ca12a7e2c1fb6.tar.bz2
gentoo-2-3d9aef197b3ec3a956c0389e4b9ca12a7e2c1fb6.zip
initial import of Oort Gnus
Diffstat (limited to 'app-emacs/ognus')
-rw-r--r--app-emacs/ognus/ChangeLog11
-rw-r--r--app-emacs/ognus/files/70ognus-gentoo.el5
-rw-r--r--app-emacs/ognus/files/digest-ognus-0.171
-rw-r--r--app-emacs/ognus/ognus-0.17.ebuild57
4 files changed, 74 insertions, 0 deletions
diff --git a/app-emacs/ognus/ChangeLog b/app-emacs/ognus/ChangeLog
new file mode 100644
index 000000000000..730429ad45d2
--- /dev/null
+++ b/app-emacs/ognus/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/ognus
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ognus/ChangeLog,v 1.1 2003/04/03 22:47:07 mkennedy Exp $
+
+*ognus-0.17 (03 Apr 2003)
+
+ 03 Apr 2003; Matthew Kennedy <mkennedy@gentoo.org> ognus-0.17.ebuild,
+ files/70ognus-gentoo.el:
+ initial import. ebuild contributed by Marshall T. Vandegrift
+ <vandem2@rpi.edu>. bug #18240
+
diff --git a/app-emacs/ognus/files/70ognus-gentoo.el b/app-emacs/ognus/files/70ognus-gentoo.el
new file mode 100644
index 000000000000..fb702cea21f0
--- /dev/null
+++ b/app-emacs/ognus/files/70ognus-gentoo.el
@@ -0,0 +1,5 @@
+
+;;; ognus site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(require 'gnus)
diff --git a/app-emacs/ognus/files/digest-ognus-0.17 b/app-emacs/ognus/files/digest-ognus-0.17
new file mode 100644
index 000000000000..c5f66dbb9ff0
--- /dev/null
+++ b/app-emacs/ognus/files/digest-ognus-0.17
@@ -0,0 +1 @@
+MD5 5f853eeacd1e12a67b5e15249c399345 ognus-0.17.tar.gz 2202855
diff --git a/app-emacs/ognus/ognus-0.17.ebuild b/app-emacs/ognus/ognus-0.17.ebuild
new file mode 100644
index 000000000000..1cb636d1b5c2
--- /dev/null
+++ b/app-emacs/ognus/ognus-0.17.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ognus/ognus-0.17.ebuild,v 1.1 2003/04/03 22:47:07 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Current alpha branch of the Gnus news- and mail-reader"
+HOMEPAGE="http://www.gnus.org/"
+SRC_URI="http://quimby.gnus.org/gnus/dist/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=/usr/share \
+ --infodir=/usr/share/info \
+ --with-emacs \
+ --with-lispdir=/usr/share/emacs/site-lisp/ognus \
+ --with-etcdir=/usr/share/emacs/etc \
+ --with-url=/usr/share/emacs/site-lisp/w3 \
+ --with-w3=/usr/share/emacs/site-lisp/w3
+ emake || die
+}
+
+src_install() {
+ make install \
+ prefix=${D}/usr \
+ datadir=${D}/usr/share \
+ infodir=${D}/usr/share/info \
+ lispdir=${D}/usr/share/emacs/site-lisp/ognus \
+ etcdir=${D}/usr/share/emacs/etc \
+ || die
+
+ elisp-site-file-install ${FILESDIR}/70ognus-gentoo.el
+
+ dodoc ChangeLog GNUS-NEWS README todo
+
+ # fix info documentation
+ find ${D}/usr/share/info -type f -exec mv {} {}.info \;
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}