summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-05-11 14:36:08 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-05-11 14:36:08 +0000
commitfab0de70622c3253c66d053a557107f7699b7481 (patch)
treec1b41f4c2ba615177681e138aa52aa656024f8ce /app-emacs/navi2ch
parentAdd ~sparc for testing. (diff)
downloadgentoo-2-fab0de70622c3253c66d053a557107f7699b7481.tar.gz
gentoo-2-fab0de70622c3253c66d053a557107f7699b7481.tar.bz2
gentoo-2-fab0de70622c3253c66d053a557107f7699b7481.zip
Version bumped.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs/navi2ch')
-rw-r--r--app-emacs/navi2ch/ChangeLog9
-rw-r--r--app-emacs/navi2ch/navi2ch-1.8.3.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/app-emacs/navi2ch/ChangeLog b/app-emacs/navi2ch/ChangeLog
index 9650ad78b5c2..ca646531e150 100644
--- a/app-emacs/navi2ch/ChangeLog
+++ b/app-emacs/navi2ch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/navi2ch
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/navi2ch/ChangeLog,v 1.51 2009/03/01 23:52:46 matsuu Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/navi2ch/ChangeLog,v 1.52 2009/05/11 14:36:08 matsuu Exp $
+
+*navi2ch-1.8.3 (11 May 2009)
+
+ 11 May 2009; MATSUU Takuto <matsuu@gentoo.org> +navi2ch-1.8.3.ebuild:
+ Version bumped.
*navi2ch-1.8.2 (01 Mar 2009)
diff --git a/app-emacs/navi2ch/navi2ch-1.8.3.ebuild b/app-emacs/navi2ch/navi2ch-1.8.3.ebuild
new file mode 100644
index 000000000000..23813f60d415
--- /dev/null
+++ b/app-emacs/navi2ch/navi2ch-1.8.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/navi2ch/navi2ch-1.8.3.ebuild,v 1.1 2009/05/11 14:36:08 matsuu Exp $
+
+inherit elisp
+
+DESCRIPTION="A navigator for 2ch"
+HOMEPAGE="http://navi2ch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/navi2ch/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+SITEFILE=50${PN}-gentoo.el
+
+src_compile() {
+ econf \
+ --with-lispdir=${SITELISP}/${PN} \
+ --with-icondir=${SITEETC}/${PN} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ elisp-install ${PN} contrib/*.el || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ dodoc ChangeLog* NEWS README TODO
+ newdoc contrib/README README.contrib
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog
+ elog "Please add to your ~/.emacs"
+ elog "If you use mona-font,"
+ elog "\t(setq navi2ch-mona-enable t)"
+ elog "If you use izonmoji-mode,"
+ elog "\t(require 'izonmoji-mode)"
+ elog "\t(add-hook 'navi2ch-bm-mode-hook 'izonmoji-mode-on)"
+ elog "\t(add-hook 'navi2ch-article-mode-hook 'izonmoji-mode-on)"
+ elog "\t(add-hook 'navi2ch-popup-article-mode-hook 'izonmoji-mode-on)"
+ elog
+}