summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-02-23 21:33:38 +0000
committerUlrich Müller <ulm@gentoo.org>2009-02-23 21:33:38 +0000
commit31e647f07cf802a518717d1a623a8b7437ba5418 (patch)
tree795edbb8a7b5b0136fa65e0352f05852d5054862 /app-emacs/imaxima
parentMarked ~ppc. (diff)
downloadgentoo-2-31e647f07cf802a518717d1a623a8b7437ba5418.tar.gz
gentoo-2-31e647f07cf802a518717d1a623a8b7437ba5418.tar.bz2
gentoo-2-31e647f07cf802a518717d1a623a8b7437ba5418.zip
Version bump. Add examples USE flag.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-emacs/imaxima')
-rw-r--r--app-emacs/imaxima/ChangeLog10
-rw-r--r--app-emacs/imaxima/files/50imaxima-gentoo.el1
-rw-r--r--app-emacs/imaxima/imaxima-1.0_rc2.ebuild41
-rw-r--r--app-emacs/imaxima/metadata.xml14
4 files changed, 57 insertions, 9 deletions
diff --git a/app-emacs/imaxima/ChangeLog b/app-emacs/imaxima/ChangeLog
index f18b5aabf521..f7171a0cac26 100644
--- a/app-emacs/imaxima/ChangeLog
+++ b/app-emacs/imaxima/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/imaxima
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/imaxima/ChangeLog,v 1.19 2008/09/04 07:48:16 ulm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/imaxima/ChangeLog,v 1.20 2009/02/23 21:33:38 ulm Exp $
+
+*imaxima-1.0_rc2 (23 Feb 2009)
+
+ 23 Feb 2009; Ulrich Mueller <ulm@gentoo.org> files/50imaxima-gentoo.el,
+ +imaxima-1.0_rc2.ebuild:
+ Version bump. Add examples USE flag.
04 Sep 2008; Ulrich Mueller <ulm@gentoo.org> imaxima-0.99.ebuild:
Fix texlive dependency, thanks aballier.
diff --git a/app-emacs/imaxima/files/50imaxima-gentoo.el b/app-emacs/imaxima/files/50imaxima-gentoo.el
index 51a58c163c21..6a9420d91479 100644
--- a/app-emacs/imaxima/files/50imaxima-gentoo.el
+++ b/app-emacs/imaxima/files/50imaxima-gentoo.el
@@ -3,3 +3,4 @@
(add-to-list 'load-path "@SITELISP@")
(autoload 'imaxima "imaxima" "Image support for Maxima." t)
+(autoload 'imath-mode "imath" "Interactive Math minor mode." t)
diff --git a/app-emacs/imaxima/imaxima-1.0_rc2.ebuild b/app-emacs/imaxima/imaxima-1.0_rc2.ebuild
new file mode 100644
index 000000000000..7cf8bc6a76ed
--- /dev/null
+++ b/app-emacs/imaxima/imaxima-1.0_rc2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/imaxima/imaxima-1.0_rc2.ebuild,v 1.1 2009/02/23 21:33:38 ulm Exp $
+
+inherit elisp
+
+MY_P="${PN}-imath-${PV/_}"
+DESCRIPTION="Imaxima enables graphical output in Maxima sessions with emacs"
+HOMEPAGE="http://members3.jcom.home.ne.jp/imaxima/Site/Welcome.html"
+SRC_URI="http://members3.jcom.home.ne.jp/imaxima/Site/Download_and_Install_files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="virtual/latex-base
+ virtual/ghostscript
+ || ( dev-tex/mh dev-tex/breqn =dev-texlive/texlive-mathextra-2007* )
+ <sci-mathematics/maxima-5.15.0"
+
+SITEFILE="50${PN}-gentoo.el"
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf --with-lispdir="${SITELISP}/${PN}" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc ChangeLog NEWS README || die
+
+ if use examples; then
+ docinto imath-example
+ dodoc imath-example/*.txt || die
+ dohtml -r imath-example/. || die
+ fi
+}
diff --git a/app-emacs/imaxima/metadata.xml b/app-emacs/imaxima/metadata.xml
index d8f59e84ea6b..b2c87461ee65 100644
--- a/app-emacs/imaxima/metadata.xml
+++ b/app-emacs/imaxima/metadata.xml
@@ -4,12 +4,12 @@
<herd>sci-mathematics</herd>
<herd>emacs</herd>
<longdescription lang="en">
-Imaxima.el provides support for interacting with the computer
-algebra system Maxima in an Emacs buffer. Imaxima processes the
-output from Maxima with TeX and inserts the resulting image in the
-buffer. The command imaxima provides a simple comint derived CLI mode. The
-command imaxima-latex prepares a LaTeX version of the Maxima
-buffer. Imaxima can also be hooked in to the Emacs mode included with
-Maxima, which provides more key bindings and other conveniences.
+ Imaxima provides support for interacting with the computer algebra system
+ Maxima in an Emacs buffer. Imaxima processes the output from Maxima with TeX
+ and inserts the resulting image in the buffer. The command imaxima provides
+ a simple comint derived CLI mode. The command imaxima-latex prepares a LaTeX
+ version of the Maxima buffer. Imaxima can also be hooked in to the Emacs
+ mode included with Maxima, which provides more key bindings and other
+ conveniences.
</longdescription>
</pkgmetadata>