summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/httpd
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/httpd')
-rw-r--r--app-emacs/httpd/ChangeLog11
-rw-r--r--app-emacs/httpd/files/50httpd-gentoo.el5
-rw-r--r--app-emacs/httpd/files/digest-httpd-0.51
-rw-r--r--app-emacs/httpd/httpd-0.5.ebuild38
4 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/httpd/ChangeLog b/app-emacs/httpd/ChangeLog
new file mode 100644
index 000000000000..1034c0efcf00
--- /dev/null
+++ b/app-emacs/httpd/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/httpd
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/httpd/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+*httpd-0.5 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ httpd-0.5.ebuild, files/50httpd-gentoo.el,
+ files/digest-httpd-0.5 :
+
+ Initial import.
diff --git a/app-emacs/httpd/files/50httpd-gentoo.el b/app-emacs/httpd/files/50httpd-gentoo.el
new file mode 100644
index 000000000000..4527ecc17f5b
--- /dev/null
+++ b/app-emacs/httpd/files/50httpd-gentoo.el
@@ -0,0 +1,5 @@
+
+;;; httpd site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+
diff --git a/app-emacs/httpd/files/digest-httpd-0.5 b/app-emacs/httpd/files/digest-httpd-0.5
new file mode 100644
index 000000000000..14975414cf37
--- /dev/null
+++ b/app-emacs/httpd/files/digest-httpd-0.5
@@ -0,0 +1 @@
+MD5 fd1c8fb038dbbd449ce2f8bf75ed9fb1 httpd-0.5.tar.bz2 4290
diff --git a/app-emacs/httpd/httpd-0.5.ebuild b/app-emacs/httpd/httpd-0.5.ebuild
new file mode 100644
index 000000000000..376378b28cb7
--- /dev/null
+++ b/app-emacs/httpd/httpd-0.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/httpd/httpd-0.5.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="A HTTP server embedded in the Emacs"
+HOMEPAGE="http://www.chez.com/emarsden/downloads/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50httpd-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/httpd.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}