summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-10-26 22:00:53 +0000
committerUlrich Müller <ulm@gentoo.org>2009-10-26 22:00:53 +0000
commitc687c04c581fa94f7c268e1d18b7c29c6c704867 (patch)
tree807574713771e2d7e761a4ec882aa13792833fdb /app-emacs/gnus
parentx11-drivers/xf86-video-intel: bump to 2.9.1, drop 2.9.0-r1 (diff)
downloadgentoo-2-c687c04c581fa94f7c268e1d18b7c29c6c704867.tar.gz
gentoo-2-c687c04c581fa94f7c268e1d18b7c29c6c704867.tar.bz2
gentoo-2-c687c04c581fa94f7c268e1d18b7c29c6c704867.zip
Replace some functionp calls for compatibility with Emacs 23, bug 290575.
(Portage version: 2.2_rc46/cvs/Linux i686)
Diffstat (limited to 'app-emacs/gnus')
-rw-r--r--app-emacs/gnus/ChangeLog8
-rw-r--r--app-emacs/gnus/files/gnus-5.10.10-functionp.patch44
-rw-r--r--app-emacs/gnus/gnus-5.10.10-r1.ebuild44
3 files changed, 95 insertions, 1 deletions
diff --git a/app-emacs/gnus/ChangeLog b/app-emacs/gnus/ChangeLog
index 38363e747c28..32f1c19c082a 100644
--- a/app-emacs/gnus/ChangeLog
+++ b/app-emacs/gnus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/gnus
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnus/ChangeLog,v 1.35 2009/02/19 22:53:43 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnus/ChangeLog,v 1.36 2009/10/26 22:00:52 ulm Exp $
+
+*gnus-5.10.10-r1 (26 Oct 2009)
+
+ 26 Oct 2009; Ulrich Mueller <ulm@gentoo.org> +gnus-5.10.10-r1.ebuild,
+ +files/gnus-5.10.10-functionp.patch:
+ Replace some functionp calls for compatibility with Emacs 23, bug 290575.
19 Feb 2009; Christian Faulhammer <fauli@gentoo.org> -gnus-5.10.8.ebuild:
clean up
diff --git a/app-emacs/gnus/files/gnus-5.10.10-functionp.patch b/app-emacs/gnus/files/gnus-5.10.10-functionp.patch
new file mode 100644
index 000000000000..080bfe823b59
--- /dev/null
+++ b/app-emacs/gnus/files/gnus-5.10.10-functionp.patch
@@ -0,0 +1,44 @@
+http://bugs.gentoo.org/290575
+Backported from Emacs 23
+
+--- gnus-5.10.10-orig/lisp/gnus-win.el
++++ gnus-5.10.10/lisp/gnus-win.el
+@@ -308,7 +308,7 @@
+ ;; The SPLIT might be something that is to be evaled to
+ ;; return a new SPLIT.
+ (while (and (not (assq (car split) gnus-window-to-buffer))
+- (functionp (car split)))
++ (fboundp (car split)))
+ (setq split (eval split)))
+ (let* ((type (car split))
+ (subs (cddr split))
+@@ -371,7 +371,7 @@
+ (while subs
+ (setq sub (append (pop subs) nil))
+ (while (and (not (assq (car sub) gnus-window-to-buffer))
+- (functionp (car sub)))
++ (fboundp (car sub)))
+ (setq sub (eval sub)))
+ (when sub
+ (push sub comp-subs)
+@@ -511,7 +511,7 @@
+ ;; The SPLIT might be something that is to be evaled to
+ ;; return a new SPLIT.
+ (while (and (not (assq (car split) gnus-window-to-buffer))
+- (functionp (car split)))
++ (fboundp (car split)))
+ (setq split (eval split)))
+
+ (setq type (elt split 0))
+--- gnus-5.10.10-orig/lisp/mail-source.el
++++ gnus-5.10.10/lisp/mail-source.el
+@@ -482,8 +482,7 @@
+ ((stringp value)
+ value)
+ ;; Function
+- ((and (listp value)
+- (functionp (car value)))
++ ((and (listp value) (symbolp (car value)) (fboundp (car value)))
+ (eval value))
+ ;; Just return the value.
+ (t
diff --git a/app-emacs/gnus/gnus-5.10.10-r1.ebuild b/app-emacs/gnus/gnus-5.10.10-r1.ebuild
new file mode 100644
index 000000000000..aa4b8640aea9
--- /dev/null
+++ b/app-emacs/gnus/gnus-5.10.10-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnus/gnus-5.10.10-r1.ebuild,v 1.1 2009/10/26 22:00:52 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="The Gnus newsreader and mail-reader"
+HOMEPAGE="http://gnus.org/"
+SRC_URI="http://quimby.gnus.org/gnus/dist/${P}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!app-emacs/gnus-cvs
+ !app-emacs/ngnus"
+
+ELISP_PATCHES="${P}-functionp.patch"
+SITEFILE="70${PN}-gentoo.el"
+
+src_compile() {
+ econf \
+ --with-emacs --without-w3 --without-url \
+ --with-lispdir=${SITELISP}/${PN} \
+ --with-etcdir=${SITEETC}
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall \
+ lispdir="${D}${SITELISP}/${PN}" \
+ etcdir="${D}${SITEETC}" \
+ || die "einstall failed"
+
+ # fix info documentation
+ for i in "${D}"/usr/share/info/*; do
+ mv "${i}" "${i}".info || die "mv info failed"
+ done
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ dodoc ChangeLog GNUS-NEWS README todo || die "dodoc failed"
+}