summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2010-04-05 19:25:39 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2010-04-05 19:25:39 +0000
commitc5fce39cc4423c116e1ee3525675d1aa76e9b805 (patch)
tree97c7c0771a81e74917ca22d8258169e647621cdc /app-editors
parentStable on amd64 wrt bug #301400 (diff)
downloadgentoo-2-c5fce39cc4423c116e1ee3525675d1aa76e9b805.tar.gz
gentoo-2-c5fce39cc4423c116e1ee3525675d1aa76e9b805.tar.bz2
gentoo-2-c5fce39cc4423c116e1ee3525675d1aa76e9b805.zip
Add LDFLAGS to makefile.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/scite/ChangeLog5
-rw-r--r--app-editors/scite/scite-2.03.ebuild7
2 files changed, 10 insertions, 2 deletions
diff --git a/app-editors/scite/ChangeLog b/app-editors/scite/ChangeLog
index e7020901594c..0e88e15f8403 100644
--- a/app-editors/scite/ChangeLog
+++ b/app-editors/scite/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/scite
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.89 2010/02/27 11:53:15 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.90 2010/04/05 19:25:39 nelchael Exp $
+
+ 05 Apr 2010; Krzysztof Pawlik <nelchael@gentoo.org> scite-2.03.ebuild:
+ Add LDFLAGS to makefile.
*scite-2.03 (27 Feb 2010)
diff --git a/app-editors/scite/scite-2.03.ebuild b/app-editors/scite/scite-2.03.ebuild
index 61d1ae6b1863..05c781afa40c 100644
--- a/app-editors/scite/scite-2.03.ebuild
+++ b/app-editors/scite/scite-2.03.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-2.03.ebuild,v 1.1 2010/02/27 11:53:15 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-2.03.ebuild,v 1.2 2010/04/05 19:25:39 nelchael Exp $
inherit toolchain-funcs eutils
@@ -32,6 +32,11 @@ src_unpack() {
-e "s#-Os##" \
|| die "error patching makefile"
+ cd "${WORKDIR}/scite/gtk"
+ sed -i makefile \
+ -e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
+ || die "error patching makefile"
+
cd "${S}"
sed -i makefile \
-e 's#usr/local#usr#g' \