summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2006-06-25 21:46:40 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2006-06-25 21:46:40 +0000
commitb964d5bfb39874ee68fd4dd829e0be43eb500328 (patch)
tree0aa6f5e9895280d02f1efedd4dda0d93e449e5a2 /app-editors
parentStable on hppa. (diff)
downloadgentoo-2-b964d5bfb39874ee68fd4dd829e0be43eb500328.tar.gz
gentoo-2-b964d5bfb39874ee68fd4dd829e0be43eb500328.tar.bz2
gentoo-2-b964d5bfb39874ee68fd4dd829e0be43eb500328.zip
Version bump: marked ~amd64, updated patch, ebuild cleanup, bug #137952.
(Portage version: 2.1.1_pre1)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/leo/ChangeLog10
-rw-r--r--app-editors/leo/files/digest-leo-4.4.1_beta23
-rw-r--r--app-editors/leo/files/leoGlobals-4.4.1_beta2.patch26
-rw-r--r--app-editors/leo/leo-4.4.1_beta2.ebuild45
4 files changed, 82 insertions, 2 deletions
diff --git a/app-editors/leo/ChangeLog b/app-editors/leo/ChangeLog
index 6970c1647738..11a3b0b68e8b 100644
--- a/app-editors/leo/ChangeLog
+++ b/app-editors/leo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/leo
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/ChangeLog,v 1.6 2005/09/16 03:06:41 mr_bones_ Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/ChangeLog,v 1.7 2006/06/25 21:46:40 lucass Exp $
+
+*leo-4.4.1_beta2 (25 Jun 2006)
+
+ 25 Jun 2006; Lukasz Strzygowski <lucass@gentoo.org>
+ +files/leoGlobals-4.4.1_beta2.patch, +leo-4.4.1_beta2.ebuild:
+ Version bump: marked ~amd64, updated patch, ebuild cleanup, bug #137952.
16 Sep 2005; Michael Sterrett <mr_bones_@gentoo.org> leo-4.2.ebuild:
needs app-arch/unzip; tidy
diff --git a/app-editors/leo/files/digest-leo-4.4.1_beta2 b/app-editors/leo/files/digest-leo-4.4.1_beta2
new file mode 100644
index 000000000000..ca57f769e2f4
--- /dev/null
+++ b/app-editors/leo/files/digest-leo-4.4.1_beta2
@@ -0,0 +1,3 @@
+MD5 f38b66264922951d342e00bcc3100782 leo-4-4-1-beta-2.zip 5160976
+RMD160 a6254f4b247984794ee1f5961b1b62c7f53112c0 leo-4-4-1-beta-2.zip 5160976
+SHA256 aa4041802f5ee255cf2cb40ffbeda316af7be6ddc115baff4dd34e5482a6085d leo-4-4-1-beta-2.zip 5160976
diff --git a/app-editors/leo/files/leoGlobals-4.4.1_beta2.patch b/app-editors/leo/files/leoGlobals-4.4.1_beta2.patch
new file mode 100644
index 000000000000..ad16196bcbbd
--- /dev/null
+++ b/app-editors/leo/files/leoGlobals-4.4.1_beta2.patch
@@ -0,0 +1,26 @@
+--- src/leoGlobals.py.old 2006-06-25 22:50:52.000000000 +0200
++++ src/leoGlobals.py 2006-06-25 23:03:23.000000000 +0200
+@@ -118,20 +118,9 @@
+
+ encoding = g.startupEncoding()
+
+- try:
+- theDir = sys.leo_config_directory
+- except AttributeError:
+- theDir = g.os_path_join(g.app.loadDir,"..","config")
+-
+- if theDir:
+- theDir = g.os_path_abspath(theDir)
+-
+- if (
+- not theDir or
+- not g.os_path_exists(theDir,encoding) or
+- not g.os_path_isdir(theDir,encoding)
+- ):
+- theDir = None
++ theDir = os.path.expanduser("~/.leo")
++ if not os.path.exists(theDir):
++ os.mkdir(theDir)
+
+ return theDir
+ #@nonl
diff --git a/app-editors/leo/leo-4.4.1_beta2.ebuild b/app-editors/leo/leo-4.4.1_beta2.ebuild
new file mode 100644
index 000000000000..8751153bc2e0
--- /dev/null
+++ b/app-editors/leo/leo-4.4.1_beta2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.4.1_beta2.ebuild,v 1.1 2006/06/25 21:46:40 lucass Exp $
+
+inherit eutils python
+
+MY_P="${PN}-4-4-1-beta-2"
+DESCRIPTION="Leo is an outlining editor and literate programming tool."
+HOMEPAGE="http://leo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/leo/${MY_P}.zip"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/python
+ dev-lang/tk"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/leoGlobals-${PV}.patch"
+}
+
+src_install() {
+ dodir /usr/share/doc/
+ mv doc "${D}/usr/share/doc/${PF}"
+ rm PKG-INFO MANIFEST install manifest.in uninstall
+
+ python_version
+ destdir="/usr/$(get_libdir)/python${PYVER}/site-packages/leo"
+ dodir "${destdir}"
+ cp -r * "${D}/${destdir}" || die "cp failed"
+
+ echo "#!/bin/bash" > leo
+ echo "exec ${python} ${destdir}/src/leo.py \"\$1\"" >> leo
+ exeinto /usr/bin
+ doexe leo || die "doexe failed"
+}