summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2006-06-07 15:14:00 +0000
committerPatrick McLean <chutzpah@gentoo.org>2006-06-07 15:14:00 +0000
commitad8d6fbcffc36c04c1d9cf40f33881036945630b (patch)
tree03b5152dc824d278e18a5350d748568a35ee2260 /app-editors
parentNew package for future usedeps of spamassassin wrt bug #134541 (diff)
downloadgentoo-2-ad8d6fbcffc36c04c1d9cf40f33881036945630b.tar.gz
gentoo-2-ad8d6fbcffc36c04c1d9cf40f33881036945630b.tar.bz2
gentoo-2-ad8d6fbcffc36c04c1d9cf40f33881036945630b.zip
Compile fix, patch to make sure a variable is defined before it is used. (bug #129299)
(Portage version: 2.1_rc4-r2)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vile/ChangeLog7
-rw-r--r--app-editors/vile/files/vile-9.5-define-LEAD-before-use.patch19
-rw-r--r--app-editors/vile/vile-9.5.ebuild11
3 files changed, 34 insertions, 3 deletions
diff --git a/app-editors/vile/ChangeLog b/app-editors/vile/ChangeLog
index 69e21b117f39..b5f31e12bc0e 100644
--- a/app-editors/vile/ChangeLog
+++ b/app-editors/vile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/vile
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/ChangeLog,v 1.23 2006/05/12 01:39:25 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/ChangeLog,v 1.24 2006/06/07 15:14:00 chutzpah Exp $
+
+ 07 Jun 2006; Patrick McLean <chutzpah@gentoo.org>
+ +files/vile-9.5-define-LEAD-before-use.patch, vile-9.5.ebuild:
+ Compile fix, patch to make sure a variable is defined before it is used.
+ (bug #129299)
11 May 2006; Thomas Cort <tcort@gentoo.org> vile-9.4d.ebuild:
Stable on amd64.
diff --git a/app-editors/vile/files/vile-9.5-define-LEAD-before-use.patch b/app-editors/vile/files/vile-9.5-define-LEAD-before-use.patch
new file mode 100644
index 000000000000..50422b4560e8
--- /dev/null
+++ b/app-editors/vile/files/vile-9.5-define-LEAD-before-use.patch
@@ -0,0 +1,19 @@
+--- vile-9.5/filters/sql-filt.l.orig 2006-05-16 14:35:46.000000000 -0400
++++ vile-9.5/filters/sql-filt.l 2006-05-16 14:36:01.000000000 -0400
+@@ -29,7 +29,6 @@
+ static char *String_attr;
+
+ static int next_line; /* state after one-line SQL*Plus */
+-static int saved_state = LEAD;
+
+ /******************************************************************************/
+
+@@ -55,6 +54,8 @@
+
+ %%
+
++static int saved_state = LEAD;
++
+ <LEAD>{IDENT} { char *text = lowercase_of(yytext);
+ char *attr = ci_keyword_attr(text);
+ DPRINTF(("{%s->%s}", text, NONNULL(attr)));
diff --git a/app-editors/vile/vile-9.5.ebuild b/app-editors/vile/vile-9.5.ebuild
index a44c8fc2e7bf..5620693dcc50 100644
--- a/app-editors/vile/vile-9.5.ebuild
+++ b/app-editors/vile/vile-9.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/vile-9.5.ebuild,v 1.1 2005/12/15 20:04:07 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/vile-9.5.ebuild,v 1.2 2006/06/07 15:14:00 chutzpah Exp $
inherit eutils
@@ -19,6 +19,13 @@ DEPEND="${RDEPEND}
sys-devel/flex"
PROVIDE="virtual/editor"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}/${P}-define-LEAD-before-use.patch"
+}
+
src_compile() {
econf \
--with-ncurses \