summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-06 11:28:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-06 11:28:04 +0000
commit6c026213cd11fad2d1ac31e3f3f1ff5b3aa6be8d (patch)
treed300b7b33fb6e348134499ff3914c1b0cb242442 /app-editors
parentversion bump, #322063 (diff)
downloadgentoo-2-6c026213cd11fad2d1ac31e3f3f1ff5b3aa6be8d.tar.gz
gentoo-2-6c026213cd11fad2d1ac31e3f3f1ff5b3aa6be8d.tar.bz2
gentoo-2-6c026213cd11fad2d1ac31e3f3f1ff5b3aa6be8d.zip
Fix sandbox violation wrt #296891 by Kevin Pyle. Force Python 2.x wrt #311177.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/scribes/ChangeLog15
-rw-r--r--app-editors/scribes/files/scribes-0.3.3.3-sandbox.patch16
-rw-r--r--app-editors/scribes/metadata.xml2
-rw-r--r--app-editors/scribes/scribes-0.3.3.3.ebuild38
4 files changed, 44 insertions, 27 deletions
diff --git a/app-editors/scribes/ChangeLog b/app-editors/scribes/ChangeLog
index 3bbbbd52de0e..55b896e940a3 100644
--- a/app-editors/scribes/ChangeLog
+++ b/app-editors/scribes/ChangeLog
@@ -1,15 +1,16 @@
# ChangeLog for app-editors/scribes
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scribes/ChangeLog,v 1.5 2008/11/24 13:33:11 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scribes/ChangeLog,v 1.6 2010/06/06 11:28:04 ssuominen Exp $
- 24 Nov 2008; <ssuominen@gentoo.org> metadata.xml:
- Remove my old e-mail drac at gentoo.org from metadata.xml and leave this
- package for the desktop-misc herd.
+ 06 Jun 2010; Samuli Suominen <ssuominen@gentoo.org>
+ scribes-0.3.3.3.ebuild, +files/scribes-0.3.3.3-sandbox.patch:
+ Fix sandbox violation wrt #296891 by Kevin Pyle. Force Python 2.x wrt
+ #311177.
29 May 2008; Ali Polatel <hawking@gentoo.org> scribes-0.3.3.3.ebuild:
python_mod_optimize is ROOT aware.
- 23 Jan 2008; Samuli Suominen <drac@gentoo.org> scribes-0.3.3.3.ebuild:
+ 23 Jan 2008; Samuli Suominen <ssuominen@gentoo.org> scribes-0.3.3.3.ebuild:
Pass --disable-scrollkeeper in pkg_setup.
21 Jan 2008; Christian Faulhammer <opfer@gentoo.org>
@@ -18,6 +19,6 @@
*scribes-0.3.3.3 (13 Jan 2008)
- 13 Jan 2008; Samuli Suominen <drac@gentoo.org> +scribes-0.3.3.3.ebuild:
+ 13 Jan 2008; Samuli Suominen <ssuominen@gentoo.org> +scribes-0.3.3.3.ebuild:
Initial commit for bug 106964, thanks to Mystilleef.
diff --git a/app-editors/scribes/files/scribes-0.3.3.3-sandbox.patch b/app-editors/scribes/files/scribes-0.3.3.3-sandbox.patch
new file mode 100644
index 000000000000..95737be67e27
--- /dev/null
+++ b/app-editors/scribes/files/scribes-0.3.3.3-sandbox.patch
@@ -0,0 +1,16 @@
+http://bugs.gentoo.org/296891
+
+--- SCRIBES/Makefile.am
++++ SCRIBES/Makefile.am
+@@ -15,11 +15,6 @@
+ rm -f $(python_files) $(python_files).tmp
+ $(edit) $(python_in_files) > $(python_files).tmp
+ mv $(python_files).tmp $(python_files)
+- if [ -d $(scribesdir) ]; then \
+- echo "removing " $(scribesdir) ;\
+- rm -rf $(scribesdir) ;\
+- echo "removed " $(scribesdir) ;\
+- fi
+
+ scribes_PYTHON = \
+ info.py \
diff --git a/app-editors/scribes/metadata.xml b/app-editors/scribes/metadata.xml
index 731225048652..540f810e069d 100644
--- a/app-editors/scribes/metadata.xml
+++ b/app-editors/scribes/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>desktop-misc</herd>
+ <herd>desktop-misc</herd>
</pkgmetadata>
diff --git a/app-editors/scribes/scribes-0.3.3.3.ebuild b/app-editors/scribes/scribes-0.3.3.3.ebuild
index 11477450a2a6..ffa56350c938 100644
--- a/app-editors/scribes/scribes-0.3.3.3.ebuild
+++ b/app-editors/scribes/scribes-0.3.3.3.ebuild
@@ -1,10 +1,13 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scribes/scribes-0.3.3.3.ebuild,v 1.4 2008/05/29 15:37:32 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scribes/scribes-0.3.3.3.ebuild,v 1.5 2010/06/06 11:28:04 ssuominen Exp $
-NEED_PYTHON=2.5
+EAPI=3
-inherit gnome2 multilib python
+PYTHON_DEPEND="2:2.6"
+GCONF_DEBUG=no
+
+inherit autotools eutils gnome2 python
DESCRIPTION="a text editor that is simple, slim and sleek, yet powerful."
HOMEPAGE="http://scribes.sourceforge.net"
@@ -31,24 +34,21 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog CONTRIBUTORS NEWS README TODO TRANSLATORS"
pkg_setup() {
- G2CONF="${G2CONF} --disable-scrollkeeper"
+ python_set_active_version 2
+ G2CONF="--disable-scrollkeeper"
}
-src_unpack() {
- gnome2_src_unpack
- find . -iname *.py[co] -exec rm -f {} \;
- rm -f compile.py py-compile
- touch compile.py py-compile
- fperms +x compile.py py-compile
-}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sandbox.patch
+ eautoreconf
+
+ ln -nfs $(type -P true) py-compile || die
+ python_convert_shebangs -r 2 .
-pkg_postinst() {
- gnome2_pkg_postinst
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/SCRIBES
+ gnome2_src_prepare
}
-pkg_postrm() {
- gnome2_pkg_postrm
- python_mod_cleanup
+src_install() {
+ gnome2_src_install
+ find "${ED}" -name "*.py[co]" -exec rm -f {} +
}