summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-30 20:15:35 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-30 20:15:35 +0000
commit2f6e5df6f8143b5b518f7af0ea50c56656cb846a (patch)
tree8227592b7786bdb9c8df5ff45f8ff66fe1fd41f7 /app-editors
parentQA: Respect CC (bug 243668) (diff)
downloadgentoo-2-2f6e5df6f8143b5b518f7af0ea50c56656cb846a.tar.gz
gentoo-2-2f6e5df6f8143b5b518f7af0ea50c56656cb846a.tar.bz2
gentoo-2-2f6e5df6f8143b5b518f7af0ea50c56656cb846a.zip
Straight to stable revbump for EAPI2, needed by releng
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64, RepoMan options: --force)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/ChangeLog7
-rw-r--r--app-editors/nano/nano-2.1.7-r1.ebuild84
2 files changed, 90 insertions, 1 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index 47ed0a6615d3..992f710fb66b 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/nano
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.225 2008/12/28 20:17:17 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.226 2008/12/30 20:15:35 angelos Exp $
+
+*nano-2.1.7-r1 (30 Dec 2008)
+
+ 30 Dec 2008; Christoph Mende <angelos@gentoo.org> +nano-2.1.7-r1.ebuild:
+ Straight to stable revbump for EAPI2, needed by releng
28 Dec 2008; Guy Martin <gmsoft@gentoo.org> nano-2.1.7.ebuild:
hppa stable, #252601
diff --git a/app-editors/nano/nano-2.1.7-r1.ebuild b/app-editors/nano/nano-2.1.7-r1.ebuild
new file mode 100644
index 000000000000..05f878648ad0
--- /dev/null
+++ b/app-editors/nano/nano-2.1.7-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.7-r1.ebuild,v 1.1 2008/12/30 20:15:35 angelos Exp $
+
+EAPI=2
+inherit eutils
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="svn://svn.savannah.gnu.org/nano/trunk/nano"
+ inherit subversion
+else
+ MY_P=${PN}-${PV/_}
+ SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+fi
+
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="http://www.nano-editor.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+IUSE="debug justify minimal ncurses nls slang spell unicode"
+
+DEPEND=">=sys-libs/ncurses-5.2[unicode?]
+ nls? ( sys-devel/gettext )
+ !ncurses? ( slang? ( sys-libs/slang ) )"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+ cd "${S}"
+ if [[ ! -e configure ]] ; then
+ ./autogen.sh || die "autogen failed"
+ fi
+}
+
+src_configure() {
+ local myconf=""
+ use ncurses \
+ && myconf="--without-slang" \
+ || myconf="${myconf} $(use_with slang)"
+
+ econf \
+ --bindir=/bin \
+ $(use_enable !minimal color) \
+ $(use_enable !minimal multibuffer) \
+ $(use_enable !minimal nanorc) \
+ --disable-wrapping-as-root \
+ $(use_enable spell speller) \
+ $(use_enable justify) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable unicode utf8) \
+ $(use_enable minimal tiny) \
+ ${myconf} \
+ || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
+ dohtml *.html
+ insinto /etc
+ newins doc/nanorc.sample nanorc
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+
+ insinto /usr/share/nano
+ local f
+ for f in "${FILESDIR}"/*.nanorc ; do
+ [[ -e ${D}/usr/share/nano/${f##*/} ]] && continue
+ doins "${f}" || die
+ echo "# include \"/usr/share/nano/${f##*/}\"" >> "${D}"/etc/nanorc
+ done
+}
+
+pkg_postinst() {
+ elog "More helpful info about nano, visit the GDP page:"
+ elog "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
+}