summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-02-26 06:08:10 +0000
committerBen de Groot <yngwin@gentoo.org>2015-02-26 06:08:10 +0000
commit03aa824c1a8828f0779368cbdebc127b8c128122 (patch)
tree663af29b70cb2e79c82c5c639b66d9a32b532722 /app-editors
parentinitial commit (diff)
downloadgentoo-2-03aa824c1a8828f0779368cbdebc127b8c128122.tar.gz
gentoo-2-03aa824c1a8828f0779368cbdebc127b8c128122.tar.bz2
gentoo-2-03aa824c1a8828f0779368cbdebc127b8c128122.zip
initial commit
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x4FDF9CFD2FAC514E!)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/neovim/ChangeLog9
-rw-r--r--app-editors/neovim/Manifest4
-rw-r--r--app-editors/neovim/files/nvimrc168
-rw-r--r--app-editors/neovim/metadata.xml5
-rw-r--r--app-editors/neovim/neovim-0.0.0_pre20150225.ebuild60
5 files changed, 246 insertions, 0 deletions
diff --git a/app-editors/neovim/ChangeLog b/app-editors/neovim/ChangeLog
new file mode 100644
index 000000000000..54097bc81d98
--- /dev/null
+++ b/app-editors/neovim/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-editors/neovim
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/neovim/ChangeLog,v 1.1 2015/02/26 06:08:10 yngwin Exp $
+
+*neovim-0.0.0_pre20150225 (26 Feb 2015)
+
+ 26 Feb 2015; Ben de Groot <yngwin@gentoo.org> +files/nvimrc, +metadata.xml,
+ +neovim-0.0.0_pre20150225.ebuild:
+ initial commit
diff --git a/app-editors/neovim/Manifest b/app-editors/neovim/Manifest
new file mode 100644
index 000000000000..c0506ae78fa2
--- /dev/null
+++ b/app-editors/neovim/Manifest
@@ -0,0 +1,4 @@
+AUX nvimrc 5578 SHA256 11a2244d41d66fec2c123c4312314a668504a3683cddec6e2ed9fa79e7068b0f SHA512 a9c02891345f7a96f034358e23becfe0a72f07e429a610187c0d3fc93dae032ce6ef90eb077dcfafaecf50f86bde081a7de164ca678f6abfb034a5164ac6b683 WHIRLPOOL 06c51dbebc54e4c36a8c4b6f01b5a6a924424752e2bd8617d7a33d287ffeef9b734c4b3c69d7b20d6c072241ee028d6f402b2a2e6be92e9ee216e542853bb008
+DIST neovim-0.0.0_pre20150225.tar.xz 4768060 SHA256 c2b9e1d60d5006022938c0cef0a25178a8fc3aefe469dc555b9396f8240dd82b SHA512 7854aabd9384bf5c90cec2f478aa9b2f173f03d7f3a1f8645e3331a7f20cade58cf68e13a117785905564d09f5b6029d22aa9ea7263f739385135becfbd50ced WHIRLPOOL d0cf544d18d925fb809f1a4dcfc1622733a7079313d8c4462efd3c371ebb5db27a4c442a0913b122c0d2ed5e1c37dca605bbfc99ed4dd920a2b006eba0d98930
+EBUILD neovim-0.0.0_pre20150225.ebuild 1487 SHA256 28c5a9bae29073a5ba2fed764fe645b131def7fae668e5bfc6f4d9773075ac1b SHA512 5dfc980ffbd524fc8f3afd96b0254a40107fe25041474dc2c135ebe7f3a2250844ef1a753110f2f3a84f9d7aa0c738d768f885e4805c2f341a41b6181a48e08c WHIRLPOOL b7a150850989337d37d8e82108e509301de4ff6cfe421b840e6fa3cc71baf2ff931a3d41f5b5be035b4e47df8b343a995e6182d81fadf50c4d3cfc1e1170fab9
+MISC metadata.xml 158 SHA256 b9e9e6173ac2fecac079dffc496d43b12a409020c130f9047c9347a37fb0211f SHA512 d5770b1cace5f8c421de6b37f73c1129c632e9dc7ba07ba9ad5d0d315b11b03c0cc0a8321d050e8e1e7d8bda0317fa65eeb1cb058f693ac0abc962567b0f6956 WHIRLPOOL 8083c4380f7c2862b19e67a3f8dcd2a1cb2beb65270f7ca38daa060483130e2d491830eb847f30dc29b0ca65c12de8863aa679c600fdfca1e26b7e01a6078c14
diff --git a/app-editors/neovim/files/nvimrc b/app-editors/neovim/files/nvimrc
new file mode 100644
index 000000000000..a0ff2af20997
--- /dev/null
+++ b/app-editors/neovim/files/nvimrc
@@ -0,0 +1,168 @@
+" Default Gentoo configuration file for neovim
+" Based on the default vimrc shipped by Gentoo with app-editors/vim-core
+" $Header: /var/cvsroot/gentoo-x86/app-editors/neovim/files/nvimrc,v 1.1 2015/02/26 06:08:10 yngwin Exp $
+
+" You can override any of these settings on a global basis via the
+" "/etc/vim/nvimrc.local" file, and on a per-user basis via "~/.nvimrc".
+" You may need to create these.
+
+" {{{ General settings
+" The following are some sensible defaults for Vim for most users.
+set bs=2 " Allow backspacing over everything in insert mode
+set ai " Always set auto-indenting on
+set history=50 " keep 50 lines of command history
+set ruler " Show the cursor position all the time
+set formatoptions+=j " Delete comment character when joining commented lines
+
+" Don't use Ex mode, use Q for formatting
+map Q gq
+
+" When doing tab completion, give the following files lower priority. You may
+" wish to set 'wildignore' to completely ignore files, and 'wildmenu' to enable
+" enhanced tab completion. These can be done in the user vimrc file.
+set suffixes+=.info,.aux,.log,.dvi,.bbl,.out,.o,.lo
+
+" When displaying line numbers, don't use an annoyingly wide number column. This
+" doesn't enable line numbers -- :set number will do that. The value given is a
+" minimum width to use for the number column, not a fixed size.
+set numberwidth=3
+
+" Use sensible whitespace indicators
+set listchars=tab:>\ ,trail:-,extends:>,precedes:<,nbsp:+
+" }}}
+
+" {{{ Modeline settings
+" We don't allow modelines by default. See bug #14088 and bug #73715.
+" If you're not concerned about these, you can enable them on a per-user
+" basis by adding "set modeline" to your ~/.vimrc file.
+set nomodeline
+" }}}
+
+" {{{ Locale settings
+" If we have a BOM, always honour that rather than trying to guess.
+if &fileencodings !~? "ucs-bom"
+ set fileencodings^=ucs-bom
+endif
+
+" Always check for UTF-8 when trying to determine encodings.
+if &fileencodings !~? "utf-8"
+ " If we have to add this, the default encoding is not Unicode.
+ let g:added_fenc_utf8 = 1
+ set fileencodings+=utf-8
+endif
+" }}}
+
+" {{{ Syntax highlighting settings
+" Switch syntax highlighting on, when the terminal has colors
+" Also switch on highlighting the last used search pattern.
+if &t_Co > 2 || has("gui_running")
+ syntax on
+ set hlsearch
+endif
+" }}}
+
+" {{{ Terminal fixes
+if &term ==? "xterm"
+ set t_Sb=^[4%dm
+ set t_Sf=^[3%dm
+ set ttymouse=xterm2
+endif
+
+if &term ==? "gnome" && has("eval")
+ " Set useful keys that vim doesn't discover via termcap but are in the
+ " builtin xterm termcap. See bug #122562. We use exec to avoid having to
+ " include raw escapes in the file.
+ exec "set <C-Left>=\eO5D"
+ exec "set <C-Right>=\eO5C"
+endif
+" }}}
+
+" {{{ Filetype plugin settings
+" Enable plugin-provided filetype settings, but only if the ftplugin
+" directory exists (which it won't on livecds, for example).
+if isdirectory(expand("$VIMRUNTIME/ftplugin"))
+ filetype plugin on
+
+ " Uncomment the next line (or copy to your ~/.vimrc) for plugin-provided
+ " indent settings. Some people don't like these, so we won't turn them on by
+ " default.
+ " filetype indent on
+endif
+" }}}
+
+" {{{ Fix &shell, see bug #101665.
+if "" == &shell
+ if executable("/bin/bash")
+ set shell=/bin/bash
+ elseif executable("/bin/sh")
+ set shell=/bin/sh
+ endif
+endif
+"}}}
+
+" {{{ Our default /bin/sh is bash, not ksh, so syntax highlighting for .sh
+" files should default to bash. See :help sh-syntax and bug #101819.
+if has("eval")
+ let is_bash=1
+endif
+" }}}
+
+" {{{ Autocommands
+if has("autocmd")
+
+augroup gentoo
+ au!
+
+ " Gentoo-specific settings for ebuilds. These are the federally-mandated
+ " required tab settings. See the following for more information:
+ " http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml
+ " Note that the rules below are very minimal and don't cover everything.
+ " Better to emerge app-vim/gentoo-syntax, which provides full syntax,
+ " filetype and indent settings for all things Gentoo.
+ au BufRead,BufNewFile *.e{build,class} let is_bash=1|setfiletype sh
+ au BufRead,BufNewFile *.e{build,class} set ts=4 sw=4 noexpandtab
+
+ " In text files, limit the width of text to 78 characters, but be careful
+ " that we don't override the user's setting.
+ autocmd BufNewFile,BufRead *.txt
+ \ if &tw == 0 && ! exists("g:leave_my_textwidth_alone") |
+ \ setlocal textwidth=78 |
+ \ endif
+
+ " When editing a file, always jump to the last cursor position
+ autocmd BufReadPost *
+ \ if ! exists("g:leave_my_cursor_position_alone") |
+ \ if line("'\"") > 0 && line ("'\"") <= line("$") |
+ \ exe "normal g'\"" |
+ \ endif |
+ \ endif
+
+ " When editing a crontab file, set backupcopy to yes rather than auto. See
+ " :help crontab and bug #53437.
+ autocmd FileType crontab set backupcopy=yes
+
+ " If we previously detected that the default encoding is not UTF-8
+ " (g:added_fenc_utf8), assume that a file with only ASCII characters (or no
+ " characters at all) isn't a Unicode file, but is in the default encoding.
+ " Except of course if a byte-order mark is in effect.
+ autocmd BufReadPost *
+ \ if exists("g:added_fenc_utf8") && &fileencoding == "utf-8" &&
+ \ ! &bomb && search('[\x80-\xFF]','nw') == 0 && &modifiable |
+ \ set fileencoding= |
+ \ endif
+
+augroup END
+
+" Strip trailing spaces on write
+autocmd BufWritePre * :%s/\s\+$//e
+
+endif " has("autocmd")
+" }}}
+
+" {{{ vimrc.local
+if filereadable("/etc/vim/nvimrc.local")
+ source /etc/vim/nvimrc.local
+endif
+" }}}
+
+" vim: set fenc=utf-8 tw=80 sw=2 sts=2 et foldmethod=marker :
diff --git a/app-editors/neovim/metadata.xml b/app-editors/neovim/metadata.xml
new file mode 100644
index 000000000000..71d319114053
--- /dev/null
+++ b/app-editors/neovim/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>
diff --git a/app-editors/neovim/neovim-0.0.0_pre20150225.ebuild b/app-editors/neovim/neovim-0.0.0_pre20150225.ebuild
new file mode 100644
index 000000000000..17b9a2eb97d5
--- /dev/null
+++ b/app-editors/neovim/neovim-0.0.0_pre20150225.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/neovim/neovim-0.0.0_pre20150225.ebuild,v 1.1 2015/02/26 06:08:10 yngwin Exp $
+
+EAPI=5
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Vim's rebirth for the 21st century"
+HOMEPAGE="https://github.com/neovim/neovim"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/neovim/neovim.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://dev.gentoo.org/~yngwin/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0 vim"
+SLOT="0"
+IUSE="perl python"
+
+CDEPEND="dev-lang/luajit:2
+ >=dev-libs/libtermkey-0.17
+ >=dev-libs/unibilium-1.1.1
+ >=dev-libs/libuv-1.2.0
+ >=dev-libs/msgpack-0.6.0_pre20150220
+ dev-lua/lpeg
+ dev-lua/messagepack"
+DEPEND="${CDEPEND}
+ virtual/libiconv
+ virtual/libintl"
+RDEPEND="${CDEPEND}
+ perl? ( dev-lang/perl )
+ python? ( dev-python/neovim-python-client )"
+
+src_prepare() {
+ # do not link statically
+ sed -e '/^set(LIBUNIBILIUM/s|ON|OFF|' -e '/^set(LIBTERMKEY/s|ON|OFF|' \
+ -i CMakeLists.txt
+ # use our system vim dir
+ sed -e '/^# define SYS_VIMRC_FILE/s|$VIM|'"${EPREFIX}"'/etc/vim|' \
+ -i src/nvim/os_unix_defs.h || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ export USE_BUNDLED_DEPS=OFF
+ append-cflags "-Wno-error"
+ append-cppflags "-DNDEBUG -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1"
+ local mycmakeargs=( -DCMAKE_BUILD_TYPE=Release )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ # install a default configuration file
+ insinto /etc/vim
+ doins "${FILESDIR}"/nvimrc
+}