summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-09-08 13:08:21 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-09-08 13:08:21 +0000
commita8d012f96b84cfef9a74953fdf3ca83be98cc315 (patch)
tree457e09e08b3b2714dc55558af526a5089fbcdf7f /app-editors/teco/teco-1.00-r2.ebuild
parentminor updates (diff)
downloadgentoo-2-a8d012f96b84cfef9a74953fdf3ca83be98cc315.tar.gz
gentoo-2-a8d012f96b84cfef9a74953fdf3ca83be98cc315.tar.bz2
gentoo-2-a8d012f96b84cfef9a74953fdf3ca83be98cc315.zip
minor updates
Diffstat (limited to 'app-editors/teco/teco-1.00-r2.ebuild')
-rw-r--r--app-editors/teco/teco-1.00-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-editors/teco/teco-1.00-r2.ebuild b/app-editors/teco/teco-1.00-r2.ebuild
new file mode 100644
index 000000000000..89c19f181ab2
--- /dev/null
+++ b/app-editors/teco/teco-1.00-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/teco-1.00-r2.ebuild,v 1.1 2003/09/08 13:08:17 taviso Exp $
+
+inherit ccc
+
+DESCRIPTION="Classic TECO editor, Predecessor to EMACS."
+HOMEPAGE="http://www.ibiblio.org/pub/linux/apps/editors/tty/ http://www.ibiblio.org/pub/academic/computer-science/history/pdp-11/teco"
+SRC_URI="http://www.ibiblio.org/pub/linux/apps/editors/tty/teco.tar.gz
+ doc? ( mirror://gentoo/tecolore.txt.gz
+ mirror://gentoo/tech.txt.gz
+ mirror://gentoo/teco.doc.gz
+ mirror://gentoo/tecoprog.doc.gz )"
+LICENSE="freedist"
+
+SLOT="0"
+KEYWORDS="alpha x86"
+IUSE="doc"
+
+DEPEND="virtual/glibc
+ sys-libs/libtermcap-compat
+ >=sys-apps/sed-4"
+RDEPEND="virtual/glibc
+ sys-libs/libtermcap-compat"
+PROVIDE="virtual/editor"
+
+S=${WORKDIR}
+
+src_compile() {
+ # Remove hardcoded compiler and CFLAGS
+ sed -i 's/CFLAGS = -O//' Makefile
+ replace-cc-hardcode
+
+ emake || die "compilation failed"
+
+ echo
+ size te; ls -l te
+ echo
+}
+
+src_install() {
+ dobin te
+ dodoc sample.tecorc sample.tecorc2 READ.ME MANIFEST
+ use doc && dodoc tecolore.txt tech.txt teco.doc tecoprog.doc
+ doman te.1
+}
+
+pkg_postinst() {
+ einfo "The TECO binary is called te."
+ einfo "Sample configurations and documentation is available in /usr/share/doc/"
+}