summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2011-05-07 21:57:49 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2011-05-07 21:57:49 +0000
commit6cef8b477478a71ad58fdafa4550044bd8bbd4aa (patch)
tree2435d0b481e2e2e687fe5098c3d52377b23dc75e /app-editors/scite/scite-2.25.ebuild
parentVersion bump, remove old. (diff)
downloadgentoo-2-6cef8b477478a71ad58fdafa4550044bd8bbd4aa.tar.gz
gentoo-2-6cef8b477478a71ad58fdafa4550044bd8bbd4aa.tar.bz2
gentoo-2-6cef8b477478a71ad58fdafa4550044bd8bbd4aa.zip
Version bump.
(Portage version: 2.1.9.47/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/scite/scite-2.25.ebuild')
-rw-r--r--app-editors/scite/scite-2.25.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/app-editors/scite/scite-2.25.ebuild b/app-editors/scite/scite-2.25.ebuild
new file mode 100644
index 000000000000..ef29c3d273ad
--- /dev/null
+++ b/app-editors/scite/scite-2.25.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-2.25.ebuild,v 1.1 2011/05/07 21:57:49 nelchael Exp $
+
+EAPI="1"
+
+inherit toolchain-funcs eutils
+
+MY_PV=${PV//./}
+DESCRIPTION="A very powerful editor for programmers"
+HOMEPAGE="http://www.scintilla.org/SciTE.html"
+SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
+
+LICENSE="Scintilla"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="lua"
+
+RDEPEND="x11-libs/gtk+:2
+ lua? ( >=dev-lang/lua-5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}/gtk"
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}/scintilla/gtk"
+ sed -i makefile \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e "s#-Os##" \
+ || die "error patching makefile"
+
+ cd "${WORKDIR}/scite/gtk"
+ sed -i makefile \
+ -e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
+ || die "error patching makefile"
+
+ cd "${S}"
+ sed -i makefile \
+ -e 's#usr/local#usr#g' \
+ -e 's#/gnome/apps/Applications#/applications#' \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e 's#${D}##' \
+ -e 's#-g root#-g 0#' \
+ -e "s#-Os##" \
+ || die "error patching makefile"
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}/${PN}-2.12-install.patch"
+ epatch "${FILESDIR}/${PN}-2.12-no-lua.patch"
+}
+
+src_compile() {
+ make -C ../../scintilla/gtk || die "prep make failed"
+ if use lua; then
+ emake || die "make failed"
+ else
+ emake NO_LUA=1 || die "make failed"
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/{pixmaps,applications}
+
+ make prefix="${D}/usr" install || die
+
+ # we have to keep this because otherwise it'll break upgrading
+ mv "${D}/usr/bin/SciTE" "${D}/usr/bin/scite"
+ dosym /usr/bin/scite /usr/bin/SciTE
+
+ # replace .desktop file with our own working version
+ insinto /usr/share/applications
+ rm -f "${D}/usr/share/applications/SciTE.desktop"
+ doins "${FILESDIR}/scite.desktop"
+
+ doman ../doc/scite.1
+ dodoc ../README
+}