summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-02-10 21:11:35 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-02-10 21:11:35 +0000
commit76b018aa3723cc2a5f23aeae384f5f9a9995c9d5 (patch)
tree7dbedca2bed0110360436a12bafc0942ed3f31f3 /app-editors/gedit
parentx86 stable, bug #209000 (diff)
downloadgentoo-2-76b018aa3723cc2a5f23aeae384f5f9a9995c9d5.tar.gz
gentoo-2-76b018aa3723cc2a5f23aeae384f5f9a9995c9d5.tar.bz2
gentoo-2-76b018aa3723cc2a5f23aeae384f5f9a9995c9d5.zip
* fix installation of precompiled python objects (bug #207667)
* fix parallel install (bug #205217) (Portage version: 2.1.4.1)
Diffstat (limited to 'app-editors/gedit')
-rw-r--r--app-editors/gedit/ChangeLog9
-rw-r--r--app-editors/gedit/files/gedit-2.20.4-parallel-install.patch13
-rw-r--r--app-editors/gedit/gedit-2.20.4-r1.ebuild83
3 files changed, 104 insertions, 1 deletions
diff --git a/app-editors/gedit/ChangeLog b/app-editors/gedit/ChangeLog
index 97d33ec39f1e..e8030569137e 100644
--- a/app-editors/gedit/ChangeLog
+++ b/app-editors/gedit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/gedit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.228 2008/02/04 04:00:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.229 2008/02/10 21:11:34 eva Exp $
+
+*gedit-2.20.4-r1 (10 Feb 2008)
+
+ 10 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/gedit-2.20.4-parallel-install.patch, +gedit-2.20.4-r1.ebuild:
+ fix installation of precompiled python objects (bug #207667)
+ fix parallel install (bug #205217)
04 Feb 2008; Jeroen Roovers <jer@gentoo.org> gedit-2.20.4.ebuild:
Stable for HPPA (bug #208366).
diff --git a/app-editors/gedit/files/gedit-2.20.4-parallel-install.patch b/app-editors/gedit/files/gedit-2.20.4-parallel-install.patch
new file mode 100644
index 000000000000..2616efacefbd
--- /dev/null
+++ b/app-editors/gedit/files/gedit-2.20.4-parallel-install.patch
@@ -0,0 +1,13 @@
+Index: gedit/Makefile.am
+===================================================================
+--- gedit/Makefile.am (revision 6106)
++++ gedit/Makefile.am (arbetskopia)
+@@ -206,7 +206,7 @@
+ dist-hook:
+ cd $(distdir); rm -f $(BUILT_SOURCES)
+
+-install-exec-local:
++install-exec-hook:
+ rm -f $(DESTDIR)$(bindir)/gnome-text-editor
+ ln -s gedit $(DESTDIR)$(bindir)/gnome-text-editor
+
diff --git a/app-editors/gedit/gedit-2.20.4-r1.ebuild b/app-editors/gedit/gedit-2.20.4-r1.ebuild
new file mode 100644
index 000000000000..7b4826c038c3
--- /dev/null
+++ b/app-editors/gedit/gedit-2.20.4-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.20.4-r1.ebuild,v 1.1 2008/02/10 21:11:34 eva Exp $
+
+inherit gnome2 python eutils autotools
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc python spell xattr"
+
+RDEPEND=">=gnome-base/gconf-2
+ xattr? ( sys-apps/attr )
+ >=dev-libs/glib-2.13.5
+ >=x11-libs/gtk+-2.11.6
+ =x11-libs/gtksourceview-2*
+ >=gnome-base/libgnomeui-2.16
+ >=gnome-base/libglade-2.5.1
+ >=gnome-base/libgnomeprintui-2.12.1
+ >=gnome-base/gnome-vfs-2.16
+ spell? (
+ >=app-text/enchant-1.2
+ app-text/iso-codes
+ )
+ python? (
+ >=dev-python/pygobject-2.11.5
+ >=dev-python/pygtk-2.9.7
+ >=dev-python/pygtksourceview-2
+ )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=app-text/scrollkeeper-0.3.11
+ >=dev-util/intltool-0.35
+ >=app-text/gnome-doc-utils-0.3.2"
+
+DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
+
+if [[ "${ARCH}" == "PPC" ]] ; then
+ # HACK HACK HACK: someone fix this garbage
+ MAKEOPTS="${MAKEOPTS} -j1"
+fi
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable python) $(use_enable spell) $(use_enable xattr attr)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Remove symbols that are not meant to be part of the docs, and
+ # break compilation if USE="doc -python" (bug #158638).
+ if use !python && use doc; then
+ epatch "${FILESDIR}"/${PN}-2.16.2-no_python_module_docs.patch
+ fi
+
+ # chown on fbsd doesn't have --reference. Bug #183691
+ epatch "${FILESDIR}"/${PN}-2.18.1-fbsd.patch
+
+ # Make libattr optional; bug #191989
+ epatch "${FILESDIR}"/${PN}-2.20.3-libattr.patch
+
+ # fix parallel make install, bug #205038
+ epatch "${FILESDIR}"/${PN}-2.20.4-parallel-install.patch
+
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/gedit-2/plugins
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/gedit-2/plugins
+}