summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-18 22:06:57 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-18 22:06:57 +0000
commitc7e3853439f8012d3e41cbcbd8b1a47349f31294 (patch)
tree2b0893bd013bf3bf7e25b44da20f45d15b172084 /app-editors/emacs
parentinitial portage version of this excellent webcam app (diff)
downloadgentoo-2-c7e3853439f8012d3e41cbcbd8b1a47349f31294.tar.gz
gentoo-2-c7e3853439f8012d3e41cbcbd8b1a47349f31294.tar.bz2
gentoo-2-c7e3853439f8012d3e41cbcbd8b1a47349f31294.zip
minor fixes and cleanups
Diffstat (limited to 'app-editors/emacs')
-rw-r--r--app-editors/emacs/emacs-21.1-r1.ebuild74
-rw-r--r--app-editors/emacs/files/digest-emacs-21.1-r11
2 files changed, 75 insertions, 0 deletions
diff --git a/app-editors/emacs/emacs-21.1-r1.ebuild b/app-editors/emacs/emacs-21.1-r1.ebuild
new file mode 100644
index 000000000000..f4b71a08ca05
--- /dev/null
+++ b/app-editors/emacs/emacs-21.1-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Mikael Hallendal <micke@hallendal.net>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.1-r1.ebuild,v 1.1 2002/01/18 22:06:57 hallski Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An incredibly powerful, extensible text editor"
+SRC_URI="ftp://ftp.codefactory.se/pub/gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/emacs"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ sys-libs/gdbm
+ X? ( virtual/x11
+ >=media-libs/libungif-4.1.0
+ >=media-libs/jpeg-6b-r2
+ >=media-libs/tiff-3.5.5-r3
+ >=media-libs/libpng-1.0.9 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ nls? ( >=sys-devel/gettext-0.10.35 )"
+
+PROVIDE="virtual/emacs"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ] ; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ if [ "`use X`" ] ; then
+ myconf="${myconf} \
+ --with-x \
+ --with-xpm \
+ --with-jpeg \
+ --with-tiff \
+ --with-gif \
+ --with-png"
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ if [ "`use motif`" ] ; then
+ myconf="${myconf} --with-x-toolkit=motif"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ libexecdir=${D}/usr/lib \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ cd ${D}/usr/share/info
+ rm dir
+
+ for i in *
+ do
+ mv ${i%.info} $i.info
+ done
+
+ dodoc BUGS ChangeLog README
+}
diff --git a/app-editors/emacs/files/digest-emacs-21.1-r1 b/app-editors/emacs/files/digest-emacs-21.1-r1
new file mode 100644
index 000000000000..2f8f8c363c89
--- /dev/null
+++ b/app-editors/emacs/files/digest-emacs-21.1-r1
@@ -0,0 +1 @@
+MD5 3e0de8cf3ffe92e04c748842f7c64e62 emacs-21.1.tar.gz 20324352