summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2011-08-13 12:29:34 +0000
committerAkinori Hattori <hattya@gentoo.org>2011-08-13 12:29:34 +0000
commitbf85034e19d88bebe19a15d0de42ec41d6db53bb (patch)
tree30ef3fdbdc3dace2a344a5d57a3bd83a924b4a9d /app-editors/ee
parentVersion bump. (diff)
downloadgentoo-2-bf85034e19d88bebe19a15d0de42ec41d6db53bb.tar.gz
gentoo-2-bf85034e19d88bebe19a15d0de42ec41d6db53bb.tar.bz2
gentoo-2-bf85034e19d88bebe19a15d0de42ec41d6db53bb.zip
update to EAPI 4.
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'app-editors/ee')
-rw-r--r--app-editors/ee/ChangeLog6
-rw-r--r--app-editors/ee/ee-1.4.6.ebuild21
-rw-r--r--app-editors/ee/ee-1.4.7.ebuild52
-rw-r--r--app-editors/ee/ee-1.5.2.ebuild21
-rw-r--r--app-editors/ee/files/ee-init-location.diff2
5 files changed, 16 insertions, 86 deletions
diff --git a/app-editors/ee/ChangeLog b/app-editors/ee/ChangeLog
index a1d9f6ec29c3..02f6aa542215 100644
--- a/app-editors/ee/ChangeLog
+++ b/app-editors/ee/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/ee
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ee/ChangeLog,v 1.3 2011/05/07 21:12:14 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ee/ChangeLog,v 1.4 2011/08/13 12:29:33 hattya Exp $
+
+ 13 Aug 2011; Akinori Hattori <hattya@gentoo.org> ee-1.4.6.ebuild,
+ -ee-1.4.7.ebuild, ee-1.5.2.ebuild, files/ee-init-location.diff:
+ update to EAPI 4.
07 May 2011; Ulrich Mueller <ulm@gentoo.org> ee-1.4.6.ebuild,
ee-1.4.7.ebuild, ee-1.5.2.ebuild:
diff --git a/app-editors/ee/ee-1.4.6.ebuild b/app-editors/ee/ee-1.4.6.ebuild
index 52fd7c6b8387..9ed3201b5e7a 100644
--- a/app-editors/ee/ee-1.4.6.ebuild
+++ b/app-editors/ee/ee-1.4.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ee/ee-1.4.6.ebuild,v 1.2 2011/05/07 21:12:15 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ee/ee-1.4.6.ebuild,v 1.3 2011/08/13 12:29:33 hattya Exp $
-EAPI="3"
+EAPI="4"
inherit toolchain-funcs
@@ -15,37 +15,26 @@ SLOT="0"
KEYWORDS="~amd64 ia64 ~mips ppc ppc64 sparc x86"
IUSE=""
-DEPEND=">=sys-libs/ncurses-5.0"
-RDEPEND="${DEPEND}
- !app-editors/ersatz-emacs"
-
+RDEPEND="!app-editors/ersatz-emacs"
S="${WORKDIR}/easyedit-${PV}"
src_prepare() {
-
sed -i \
-e "s/\tcc /\t\\\\\$(CC) /" \
-e "/other_cflag/s/ *-s//" \
create.make
-
}
src_configure() {
-
emake localmake
-
}
src_compile() {
-
- emake -f make.local CC="$(tc-getCC)" || die
-
+ emake -f make.local CC="$(tc-getCC)"
}
src_install() {
-
dobin ee
doman ee.1
- dodoc README.ee Changes ee.i18n.guide ee.msg
-
+ dodoc Changes README.ee ee.i18n.guide ee.msg
}
diff --git a/app-editors/ee/ee-1.4.7.ebuild b/app-editors/ee/ee-1.4.7.ebuild
deleted file mode 100644
index 2871ff5222d4..000000000000
--- a/app-editors/ee/ee-1.4.7.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ee/ee-1.4.7.ebuild,v 1.2 2011/05/07 21:12:15 ulm Exp $
-
-EAPI="3"
-
-inherit toolchain-funcs
-
-DESCRIPTION="An easy to use text editor. Intended to be usable with little or no instruction."
-HOMEPAGE="http://mahon.cwx.net/"
-SRC_URI="http://mahon.cwx.net/sources/${P}.src.tgz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-
-DEPEND=">=sys-libs/ncurses-5.0"
-RDEPEND="${DEPEND}
- !app-editors/ersatz-emacs"
-
-S="${WORKDIR}/easyedit-${PV}"
-
-src_prepare() {
-
- sed -i \
- -e "s/\tcc /\t\\\\\$(CC) /" \
- -e "/other_cflag/s/ *-s//" \
- create.make
-
-}
-
-src_configure() {
-
- emake localmake
- sed -i -e '/^all/s/ee/curses/' make.local
-
-}
-
-src_compile() {
-
- emake -f make.local CC="$(tc-getCC)" || die
-
-}
-
-src_install() {
-
- dobin ee
- doman ee.1
- dodoc README.ee Changes ee.i18n.guide ee.msg
-
-}
diff --git a/app-editors/ee/ee-1.5.2.ebuild b/app-editors/ee/ee-1.5.2.ebuild
index e30a86b2868d..af4e0845f4f8 100644
--- a/app-editors/ee/ee-1.5.2.ebuild
+++ b/app-editors/ee/ee-1.5.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ee/ee-1.5.2.ebuild,v 1.2 2011/05/07 21:12:14 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ee/ee-1.5.2.ebuild,v 1.3 2011/08/13 12:29:33 hattya Exp $
-EAPI="3"
+EAPI="4"
inherit eutils toolchain-funcs
@@ -16,39 +16,30 @@ KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~amd64-
IUSE=""
RDEPEND="!app-editors/ersatz-emacs"
-
S="${WORKDIR}/easyedit-${PV}"
src_prepare() {
-
epatch "${FILESDIR}"/${PN}-*.diff
sed -i \
-e "s/make -/\$(MAKE) -/g" \
-e "/^buildee/s/$/ localmake/" \
- Makefile \
- || die
+ Makefile
sed -i \
-e "s/\tcc /\t\\\\\$(CC) /" \
-e "/CFLAGS =/s/\" >/ \\\\\$(LDFLAGS)\" >/" \
-e "/other_cflag/s/ *-s//" \
- create.make \
- || die
-
+ create.make
}
src_compile() {
-
- emake CC="$(tc-getCC)" || die
-
+ emake CC="$(tc-getCC)"
}
src_install() {
-
dobin ee
doman ee.1
dodoc Changes README.ee ee.i18n.guide ee.msg
- dodir /usr/share/${PN}
-
+ keepdir /usr/share/${PN}
}
diff --git a/app-editors/ee/files/ee-init-location.diff b/app-editors/ee/files/ee-init-location.diff
index c623bcdba807..9d6179a03a59 100644
--- a/app-editors/ee/files/ee-init-location.diff
+++ b/app-editors/ee/files/ee-init-location.diff
@@ -1,4 +1,3 @@
-diff -ur easyedit-1.5.2.orig/ee.1 easyedit-1.5.2/ee.1
--- easyedit-1.5.2.orig/ee.1
+++ easyedit-1.5.2/ee.1
@@ -406,7 +406,7 @@
@@ -28,7 +27,6 @@ diff -ur easyedit-1.5.2.orig/ee.1 easyedit-1.5.2/ee.1
.br
.I $HOME/.init.ee
.br
-diff -ur easyedit-1.5.2.orig/ee.c easyedit-1.5.2/ee.c
--- easyedit-1.5.2.orig/ee.c
+++ easyedit-1.5.2/ee.c
@@ -4124,7 +4124,7 @@