summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-12-07 13:04:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-12-07 13:04:20 +0000
commitc087a95e65b03ec22f90dcbf6e22603113d7adfd (patch)
treedd1bbc7d4e4a780524ba5fb67e524dab80e655e6 /app-editors/cooledit
parentUse mirror://berlios (bug #218657). (diff)
downloadgentoo-2-c087a95e65b03ec22f90dcbf6e22603113d7adfd.tar.gz
gentoo-2-c087a95e65b03ec22f90dcbf6e22603113d7adfd.tar.bz2
gentoo-2-c087a95e65b03ec22f90dcbf6e22603113d7adfd.zip
Fix compilation with LDFLAGS -Wl,--as-needed and implicit declarations because of missing string.h and stdlib.h wrt #246879.
(Portage version: 2.1.6_rc3/cvs/Linux 2.6.27.7 i686)
Diffstat (limited to 'app-editors/cooledit')
-rw-r--r--app-editors/cooledit/ChangeLog9
-rw-r--r--app-editors/cooledit/cooledit-3.17.17.ebuild20
-rw-r--r--app-editors/cooledit/files/cooledit-3.17.17-asneeded.patch11
-rw-r--r--app-editors/cooledit/files/cooledit-3.17.17-implicit_declarations.patch34
4 files changed, 66 insertions, 8 deletions
diff --git a/app-editors/cooledit/ChangeLog b/app-editors/cooledit/ChangeLog
index 8cdc327c833b..e191733bd30d 100644
--- a/app-editors/cooledit/ChangeLog
+++ b/app-editors/cooledit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/cooledit
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/cooledit/ChangeLog,v 1.25 2008/03/26 02:03:46 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/cooledit/ChangeLog,v 1.26 2008/12/07 13:04:19 ssuominen Exp $
+
+ 07 Dec 2008; <ssuominen@gentoo.org>
+ +files/cooledit-3.17.17-asneeded.patch,
+ +files/cooledit-3.17.17-implicit_declarations.patch,
+ cooledit-3.17.17.ebuild:
+ Fix compilation with LDFLAGS -Wl,--as-needed and implicit declarations
+ because of missing string.h and stdlib.h wrt #246879.
26 Mar 2008; Brent Baude <ranger@gentoo.org> cooledit-3.17.17.ebuild:
stable ppc, bug 214573
diff --git a/app-editors/cooledit/cooledit-3.17.17.ebuild b/app-editors/cooledit/cooledit-3.17.17.ebuild
index e09424d35eb4..f30cc6589728 100644
--- a/app-editors/cooledit/cooledit-3.17.17.ebuild
+++ b/app-editors/cooledit/cooledit-3.17.17.ebuild
@@ -1,35 +1,41 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/cooledit/cooledit-3.17.17.ebuild,v 1.6 2008/03/26 02:03:46 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/cooledit/cooledit-3.17.17.ebuild,v 1.7 2008/12/07 13:04:19 ssuominen Exp $
-inherit eutils
+inherit autotools eutils
DESCRIPTION="Cooledit is a full featured multiple window text editor"
HOMEPAGE="http://freshmeat.net/projects/cooledit/"
SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/apps/editors/X/cooledit/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
-IUSE="nls spell"
+IUSE="nls"
RDEPEND="x11-libs/libX11
+ x11-libs/libXdmcp
+ x11-libs/libXau
app-text/ispell"
DEPEND="${RDEPEND}
x11-libs/libXpm"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/cooledit-3.17.17-gcc4.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc4.patch \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-implicit_declarations.patch
+ eautoreconf
}
src_compile() {
# Fix for bug 40152 (04 Feb 2004 agriffis)
addwrite /dev/ptym/clone:/dev/ptmx
econf $(use_enable nls)
- emake || die "emake failed"
+ emake || die "emake failed."
}
src_install() {
- make install DESTDIR=${D} || die "install failed"
+ emake DESTDIR="${D}" install || die "emake install failed."
}
diff --git a/app-editors/cooledit/files/cooledit-3.17.17-asneeded.patch b/app-editors/cooledit/files/cooledit-3.17.17-asneeded.patch
new file mode 100644
index 000000000000..4cd6331fcd49
--- /dev/null
+++ b/app-editors/cooledit/files/cooledit-3.17.17-asneeded.patch
@@ -0,0 +1,11 @@
+diff -ur cooledit-3.17.17.orig/widget/Makefile.am cooledit-3.17.17/widget/Makefile.am
+--- cooledit-3.17.17.orig/widget/Makefile.am 2005-04-04 23:47:45.000000000 +0300
++++ cooledit-3.17.17/widget/Makefile.am 2008-12-07 14:47:18.000000000 +0200
+@@ -20,6 +20,7 @@
+ look-cool.c look-gtk.c look-next.c
+
+ libCw_la_LDFLAGS = -version-info 1:0:0
++libCw_la_LIBADD = @X_LIBS@ -lX11 @X_EXTRA_LIBS@ @LIBINTL@
+
+ DEFS = @X_CFLAGS@ -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/share/cooledit\" @DEFS@
+
diff --git a/app-editors/cooledit/files/cooledit-3.17.17-implicit_declarations.patch b/app-editors/cooledit/files/cooledit-3.17.17-implicit_declarations.patch
new file mode 100644
index 000000000000..322c36fde936
--- /dev/null
+++ b/app-editors/cooledit/files/cooledit-3.17.17-implicit_declarations.patch
@@ -0,0 +1,34 @@
+diff -ur cooledit-3.17.17.orig/editor/postscript.c cooledit-3.17.17/editor/postscript.c
+--- cooledit-3.17.17.orig/editor/postscript.c 2005-04-04 23:47:45.000000000 +0300
++++ cooledit-3.17.17/editor/postscript.c 2008-12-07 14:55:25.000000000 +0200
+@@ -1,5 +1,7 @@
+ #include <config.h>
++#include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #ifdef HAVE_SYS_STAT_H
+ #include <sys/stat.h>
+ #endif
+diff -ur cooledit-3.17.17.orig/widget/aafont.c cooledit-3.17.17/widget/aafont.c
+--- cooledit-3.17.17.orig/widget/aafont.c 2005-04-04 23:47:45.000000000 +0300
++++ cooledit-3.17.17/widget/aafont.c 2008-12-07 14:54:23.000000000 +0200
+@@ -20,6 +20,7 @@
+ #include <config.h>
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #include <X11/Xlib.h>
+ #include <X11/Xutil.h>
+ #include "aafont.h"
+diff -ur cooledit-3.17.17.orig/widget/mad.c cooledit-3.17.17/widget/mad.c
+--- cooledit-3.17.17.orig/widget/mad.c 2005-04-04 23:47:45.000000000 +0300
++++ cooledit-3.17.17/widget/mad.c 2008-12-07 14:54:30.000000000 +0200
+@@ -22,6 +22,8 @@
+ /* Generation MAD. It is based on the debauch package. */
+ /********************************************************************/
+
++#include <stdlib.h>
++#include <string.h>
+ #include "mad.h"
+
+ #undef malloc