summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-08-18 09:52:37 +0000
committerMike Frysinger <vapier@gentoo.org>2009-08-18 09:52:37 +0000
commit30ab3f93bdfda286f17d2e5a6b0bf957e92df7ab (patch)
tree84041153712217a05eff8a523ff435838de68cb5 /app-doc
parentInitial package by Denilson and Eugene Kapun and lumato and me #114102. (diff)
downloadgentoo-2-30ab3f93bdfda286f17d2e5a6b0bf957e92df7ab.tar.gz
gentoo-2-30ab3f93bdfda286f17d2e5a6b0bf957e92df7ab.tar.bz2
gentoo-2-30ab3f93bdfda286f17d2e5a6b0bf957e92df7ab.zip
Version bump.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/halibut/ChangeLog9
-rw-r--r--app-doc/halibut/halibut-1.0.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/app-doc/halibut/ChangeLog b/app-doc/halibut/ChangeLog
index 5157f4f1ac2d..7e73deae831a 100644
--- a/app-doc/halibut/ChangeLog
+++ b/app-doc/halibut/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-doc/halibut
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/halibut/ChangeLog,v 1.6 2007/03/12 20:42:46 leonardop Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/halibut/ChangeLog,v 1.7 2009/08/18 09:52:37 vapier Exp $
+
+*halibut-1.0 (18 Aug 2009)
+
+ 18 Aug 2009; Mike Frysinger <vapier@gentoo.org> +halibut-1.0.ebuild:
+ Version bump.
12 Mar 2007; Leonardo Boshell <leonardop@gentoo.org> metadata.xml:
Re-assigning to the sgml herd, after text-markup split.
diff --git a/app-doc/halibut/halibut-1.0.ebuild b/app-doc/halibut/halibut-1.0.ebuild
new file mode 100644
index 000000000000..9008d34baf57
--- /dev/null
+++ b/app-doc/halibut/halibut-1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/halibut/halibut-1.0.ebuild,v 1.1 2009/08/18 09:52:37 vapier Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="yet another free document preparation system"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/halibut/"
+SRC_URI="http://www.chiark.greenend.org.uk/~sgtatham/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_compile() {
+ tc-export CC
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LFLAGS="${LDFLAGS}" \
+ emake \
+ BUILDDIR="${S}/build" \
+ VERSION="${PV}" \
+ || die "make failed"
+
+ emake -C doc || die "make in doc failed"
+}
+
+src_install() {
+ dobin build/halibut || die
+ doman doc/halibut.1 || die
+ dodoc doc/halibut.txt
+ dohtml doc/*.html
+}