summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-10-07 23:08:03 +0000
committerAlex Alexander <wired@gentoo.org>2010-10-07 23:08:03 +0000
commit7e54eda31b9a6e5ec1242903f8eb4734ba8a783f (patch)
tree785182fe579d3c3c71eb1b3465b3c542b88eea85 /app-doc/doxygen
parentrm (diff)
downloadgentoo-2-7e54eda31b9a6e5ec1242903f8eb4734ba8a783f.tar.gz
gentoo-2-7e54eda31b9a6e5ec1242903f8eb4734ba8a783f.tar.bz2
gentoo-2-7e54eda31b9a6e5ec1242903f8eb4734ba8a783f.zip
only call eqmake4 if use qt4, bug #340092
(Portage version: 2.2_rc89/cvs/Linux x86_64)
Diffstat (limited to 'app-doc/doxygen')
-rw-r--r--app-doc/doxygen/ChangeLog5
-rw-r--r--app-doc/doxygen/doxygen-1.5.8-r1.ebuild11
2 files changed, 9 insertions, 7 deletions
diff --git a/app-doc/doxygen/ChangeLog b/app-doc/doxygen/ChangeLog
index f8ff9a957548..c075d3e2f52d 100644
--- a/app-doc/doxygen/ChangeLog
+++ b/app-doc/doxygen/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-doc/doxygen
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.181 2010/10/04 06:10:38 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.182 2010/10/07 23:08:03 wired Exp $
+
+ 07 Oct 2010; Alex Alexander <wired@gentoo.org> doxygen-1.5.8-r1.ebuild:
+ only call eqmake4 if use qt4, bug #340092
04 Oct 2010; Steve Arnold <nerdboy@gentoo.org> doxygen-1.5.8-r1.ebuild:
Needed additional updates to pick up the qt4 qmake config correctly.
diff --git a/app-doc/doxygen/doxygen-1.5.8-r1.ebuild b/app-doc/doxygen/doxygen-1.5.8-r1.ebuild
index fa53f8a892fd..038da13be091 100644
--- a/app-doc/doxygen/doxygen-1.5.8-r1.ebuild
+++ b/app-doc/doxygen/doxygen-1.5.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.8-r1.ebuild,v 1.9 2010/10/04 06:10:38 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.8-r1.ebuild,v 1.10 2010/10/07 23:08:03 wired Exp $
EAPI=2
@@ -98,14 +98,13 @@ src_configure() {
export LD_LIBRARY_PATH="${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}"
./configure ${my_conf} $(use_with qt4 doxywizard) \
|| die 'configure with qt4 failed'
+ # this appears to work as a fix for the final ignoring LDFLAGS issue...
+ pushd "${S}"/addon/doxywizard
+ eqmake4 "CONFIG+=nostrip" doxywizard.pro -o Makefile.doxywizard
+ popd
else
./configure ${my_conf} || die 'configure failed'
fi
-
- # this appears to work as a fix for the final ignoring LDFLAGS issue...
- pushd "${S}"/addon/doxywizard
- eqmake4 "CONFIG+=nostrip" doxywizard.pro -o Makefile.doxywizard
- popd
}
src_compile() {