summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-12-31 21:28:01 +0000
committerRick Farina <zerochaos@gentoo.org>2012-12-31 21:28:01 +0000
commitf7fff616f209edb52298764e6f00ee3cc8b96e8f (patch)
tree9798e40b8b38183803c11130ca1cf7ade88dcb54 /app-crypt
parentversion bump (diff)
downloadgentoo-2-f7fff616f209edb52298764e6f00ee3cc8b96e8f.tar.gz
gentoo-2-f7fff616f209edb52298764e6f00ee3cc8b96e8f.tar.bz2
gentoo-2-f7fff616f209edb52298764e6f00ee3cc8b96e8f.zip
version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/oclhashcat-lite-bin/ChangeLog8
-rw-r--r--app-crypt/oclhashcat-lite-bin/oclhashcat-lite-bin-0.13.ebuild105
2 files changed, 112 insertions, 1 deletions
diff --git a/app-crypt/oclhashcat-lite-bin/ChangeLog b/app-crypt/oclhashcat-lite-bin/ChangeLog
index d0a0e0a01d62..9297609a2626 100644
--- a/app-crypt/oclhashcat-lite-bin/ChangeLog
+++ b/app-crypt/oclhashcat-lite-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/oclhashcat-lite-bin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/oclhashcat-lite-bin/ChangeLog,v 1.3 2012/07/04 17:41:29 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/oclhashcat-lite-bin/ChangeLog,v 1.4 2012/12/31 21:28:01 zerochaos Exp $
+
+*oclhashcat-lite-bin-0.13 (31 Dec 2012)
+
+ 31 Dec 2012; Rick Farina <zerochaos@gentoo.org>
+ +oclhashcat-lite-bin-0.13.ebuild:
+ version bump
04 Jul 2012; Rick Farina <zerochaos@gentoo.org>
oclhashcat-lite-bin-0.10.ebuild:
diff --git a/app-crypt/oclhashcat-lite-bin/oclhashcat-lite-bin-0.13.ebuild b/app-crypt/oclhashcat-lite-bin/oclhashcat-lite-bin-0.13.ebuild
new file mode 100644
index 000000000000..27a5bc591c37
--- /dev/null
+++ b/app-crypt/oclhashcat-lite-bin/oclhashcat-lite-bin-0.13.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/oclhashcat-lite-bin/oclhashcat-lite-bin-0.13.ebuild,v 1.1 2012/12/31 21:28:01 zerochaos Exp $
+
+EAPI=4
+
+inherit eutils pax-utils
+
+DESCRIPTION="An opencl hash cracker"
+HOMEPAGE="http://hashcat.net/oclhashcat-lite/"
+MY_P="oclHashcat-lite-${PV}"
+SRC_URI="http://hashcat.net/files/${MY_P}.7z"
+
+#license applies to this version per http://hashcat.net/forum/thread-1348.html
+LICENSE="hashcat"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+IUSE_VIDEO_CARDS="video_cards_fglrx
+ video_cards_nvidia"
+
+IUSE="${IUSE_VIDEO_CARDS}"
+
+RDEPEND="sys-libs/zlib
+ video_cards_nvidia? ( >=x11-drivers/nvidia-drivers-304.51 )
+ video_cards_fglrx? ( =x11-drivers/ati-drivers-12.8 )"
+DEPEND="${RDEPEND}
+ app-arch/p7zip"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="strip"
+QA_PREBUILT="*Hashcat-lite*.bin"
+
+src_install() {
+ dodoc docs/*
+ rm -rf *.exe docs || die
+ if use x86; then
+ rm oclHashcat-lite64.bin || die
+ rm cudaHashcat-lite64.bin || die
+ fi
+ if use amd64; then
+ rm oclHashcat-lite32.bin || die
+ rm cudaHashcat-lite32.bin || die
+ fi
+ if ! use video_cards_fglrx; then
+ rm -r kernels/4098 || die
+ rm oclHashcat-lite*.bin || die
+ fi
+ if ! use video_cards_nvidia; then
+ rm -r kernels/4318 || die
+ rm cudaHashcat-lite*.bin || die
+ fi
+
+ #I assume this is needed but I didn't check
+ pax-mark m *Hashcat-lite*.bin
+
+ insinto /opt/${PN}
+ doins -r "${S}"/*
+
+ dodir /opt/bin
+
+ cat <<-EOF > "${ED}"/opt/bin/oclhashcat-lite
+ #! /bin/sh
+ echo "oclHashcat-lite and all related files have been installed in /opt/${PN}"
+ echo "Please run one of the following binaries to use gpu accelerated hashcat:"
+ EOF
+
+ for x in oclHashcat-lite64.bin oclHashcat-lite32.bin cudaHashcat-lite64.bin cudaHashcat-lite32.bin
+ do
+ if [ -f "${ED}"/opt/${PN}/${x} ]
+ then
+ case "${x}" in
+ oclHashcat-lite64.bin)
+ echo "echo '64 bit ATI accelerated \"oclHashcat-lite64.bin\"'" >> "${ED}"/opt/bin/oclhashcat-lite
+ ;;
+ oclHashcat-lite32.bin)
+ echo "echo '32 bit ATI accelerated \"oclHashcat-lite32.bin\"'" >> "${ED}"/opt/bin/oclhashcat-lite
+ ;;
+ cudaHashcat-lite64.bin)
+ echo "echo '64 bit NVIDIA accelerated \"cudaHashcat-lite64.bin\"'" >> "${ED}"/opt/bin/oclhashcat-lite
+ ;;
+ cudaHashcat-lite32.bin)
+ echo "echo '32 bit NVIDIA accelerated \"cudaHashcat-lite32.bin\"'" >> "${ED}"/opt/bin/oclhashcat-lite
+ ;;
+ esac
+
+ fperms +x /opt/${PN}/${x}
+
+ cat <<-EOF > "${ED}"/opt/bin/${x}
+ #! /bin/sh
+ cd /opt/${PN}
+ echo "Warning: ${x} is running from /opt/${PN} so be careful of relative paths."
+ exec ./${x} "\$@"
+ EOF
+
+ fperms +x /opt/bin/${x}
+
+ fi
+ done
+
+ fperms +x /opt/bin/oclhashcat-lite
+ fowners root:video /opt/${PN}
+ einfo "oclhashcat-lite can be run as user if you are in the video group"
+}