summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-04-26 13:48:58 +0000
committerPacho Ramos <pacho@gentoo.org>2010-04-26 13:48:58 +0000
commit6a7d2ebe2795aab640669d3081ff6d91e92a63f6 (patch)
tree18f9f4dc33d7cb22f8a4fa3d06c7217753ad2dbd /app-crypt
parentx86 stable wrt bug #312545 (diff)
downloadgentoo-2-6a7d2ebe2795aab640669d3081ff6d91e92a63f6.tar.gz
gentoo-2-6a7d2ebe2795aab640669d3081ff6d91e92a63f6.tar.bz2
gentoo-2-6a7d2ebe2795aab640669d3081ff6d91e92a63f6.zip
Apply ubuntu patch to finally solve bug #281729
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/seahorse-plugins/ChangeLog12
-rw-r--r--app-crypt/seahorse-plugins/files/seahorse-plugins-2.28.1-gpgme_check_version.patch53
-rw-r--r--app-crypt/seahorse-plugins/seahorse-plugins-2.28.1-r1.ebuild87
3 files changed, 151 insertions, 1 deletions
diff --git a/app-crypt/seahorse-plugins/ChangeLog b/app-crypt/seahorse-plugins/ChangeLog
index 2049998e86c6..c9303ae7128d 100644
--- a/app-crypt/seahorse-plugins/ChangeLog
+++ b/app-crypt/seahorse-plugins/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-crypt/seahorse-plugins
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse-plugins/ChangeLog,v 1.18 2010/02/12 19:59:58 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse-plugins/ChangeLog,v 1.19 2010/04/26 13:48:58 pacho Exp $
+
+*seahorse-plugins-2.28.1-r1 (26 Apr 2010)
+
+ 26 Apr 2010; Pacho Ramos <pacho@gentoo.org>
+ +seahorse-plugins-2.28.1-r1.ebuild,
+ +files/seahorse-plugins-2.28.1-gpgme_check_version.patch:
+ Revision bump to apply ubuntu patch to call gpgme_check_version () as
+ required by current stable and newer gpgme versions (see bug #281729).
+ Thanks to Sebastien Bacher for the patch, Patrick Beckmann and Alexander
+ Bezrukov for reporting.
12 Feb 2010; Raúl Porcel <armin76@gentoo.org>
seahorse-plugins-2.26.2-r1.ebuild:
diff --git a/app-crypt/seahorse-plugins/files/seahorse-plugins-2.28.1-gpgme_check_version.patch b/app-crypt/seahorse-plugins/files/seahorse-plugins-2.28.1-gpgme_check_version.patch
new file mode 100644
index 000000000000..78a992634562
--- /dev/null
+++ b/app-crypt/seahorse-plugins/files/seahorse-plugins-2.28.1-gpgme_check_version.patch
@@ -0,0 +1,53 @@
+# Description: use gpgme_check_version () since gpgme_new () requires it now
+# Bug Gentoo: http://bugs.gentoo.org/show_bug.cgi?id=281729
+# Bug-Ubuntu: https://bugs.launchpad.net/bugs/514950
+# Bug: https://bugzilla.gnome.org/show_bug.cgi?id=607423
+Index: seahorse-plugins-2.30.0/plugins/nautilus/seahorse-tool.c
+===================================================================
+--- seahorse-plugins-2.30.0.orig/plugins/nautilus/seahorse-tool.c 2010-02-13 15:31:34.000000000 +0100
++++ seahorse-plugins-2.30.0/plugins/nautilus/seahorse-tool.c 2010-04-08 02:46:54.000000000 +0200
+@@ -170,6 +170,9 @@
+ recips = cryptui_prompt_recipients (keyset, _("Choose Recipients"), &signer);
+
+ if (recips) {
++ gpgme_check_version (NULL);
++ gerr = gpgme_engine_check_version (GPGME_PROTOCOL_OpenPGP);
++ g_return_val_if_fail (GPG_IS_OK (gerr), NULL);
+
+ gerr = gpgme_new (&ctx);
+ g_return_val_if_fail (GPG_IS_OK (gerr), NULL);
+@@ -328,6 +331,10 @@
+ id = cryptui_keyset_key_raw_keyid (keyset, signer);
+ g_free (signer);
+
++ gpgme_check_version (NULL);
++ gerr = gpgme_engine_check_version (GPGME_PROTOCOL_OpenPGP);
++ g_return_val_if_fail (GPG_IS_OK (gerr), NULL);
++
+ gerr = gpgme_new (&ctx);
+ g_return_val_if_fail (GPG_IS_OK (gerr), NULL);
+
+Index: seahorse-plugins-2.30.0/agent/seahorse-agent-cache.c
+===================================================================
+--- seahorse-plugins-2.30.0.orig/agent/seahorse-agent-cache.c 2010-01-25 03:06:50.000000000 +0100
++++ seahorse-plugins-2.30.0/agent/seahorse-agent-cache.c 2010-04-08 02:46:54.000000000 +0200
+@@ -237,6 +237,7 @@
+ g_cache =
+ g_hash_table_new_full (g_str_hash, g_str_equal, NULL, destroy_cache_item);
+
++ gpgme_check_version (NULL);
+ err = gpgme_engine_check_version (proto);
+ g_return_if_fail (GPG_IS_OK (err));
+
+Index: seahorse-plugins-2.30.0/libseahorse/seahorse-pgp-operation.c
+===================================================================
+--- seahorse-plugins-2.30.0.orig/libseahorse/seahorse-pgp-operation.c 2010-01-25 03:06:50.000000000 +0100
++++ seahorse-plugins-2.30.0/libseahorse/seahorse-pgp-operation.c 2010-04-08 02:46:54.000000000 +0200
+@@ -323,6 +323,7 @@
+ gpgme_error_t err;
+ gpgme_ctx_t ctx;
+
++ gpgme_check_version (NULL);
+ err = gpgme_engine_check_version (proto);
+ g_return_if_fail (GPG_IS_OK (err));
+
diff --git a/app-crypt/seahorse-plugins/seahorse-plugins-2.28.1-r1.ebuild b/app-crypt/seahorse-plugins/seahorse-plugins-2.28.1-r1.ebuild
new file mode 100644
index 000000000000..e4c2afd5525b
--- /dev/null
+++ b/app-crypt/seahorse-plugins/seahorse-plugins-2.28.1-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse-plugins/seahorse-plugins-2.28.1-r1.ebuild,v 1.1 2010/04/26 13:48:58 pacho Exp $
+
+EAPI="2"
+
+inherit eutils gnome2
+
+DESCRIPTION="A GNOME application for managing encryption keys"
+HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="applet debug epiphany gedit libnotify nautilus test"
+
+RDEPEND="
+ >=gnome-base/libglade-2.0
+ >=gnome-base/gconf-2.0
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.16
+ >=dev-libs/dbus-glib-0.72
+ >=app-crypt/gpgme-1.0.0
+ >=app-crypt/seahorse-2.25
+ >=gnome-base/gnome-keyring-2.25
+ >=gnome-extra/evolution-data-server-1.8
+
+ || (
+ =app-crypt/gnupg-1.4*
+ =app-crypt/gnupg-2.0* )
+
+ nautilus? ( >=gnome-base/nautilus-2.12 )
+ epiphany? (
+ >=www-client/epiphany-2.24
+ >=dev-libs/libxml2-2.6.0 )
+ gedit? ( >=app-editors/gedit-2.16 )
+ applet? ( >=gnome-base/gnome-panel-2.10 )
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=app-text/gnome-doc-utils-0.3.2
+ >=app-text/scrollkeeper-0.3
+ >=dev-util/pkgconfig-0.20
+ >=dev-util/intltool-0.35"
+
+pkg_setup() {
+ if use epiphany ; then
+ if has_version '>=www-client/epiphany-2.24.3-r10'; then
+ G2CONF="${G2CONF} --with-gecko=libxul-unstable"
+ else
+ # Now, epiphany could be using xul-1.8, xul-1.9 or ff-2
+ # Let it auto-detect.
+ :
+ fi
+ fi
+
+ G2CONF="${G2CONF}
+ --enable-agent
+ --disable-update-mime-database
+ --disable-static
+ $(use_enable applet)
+ $(use_enable debug)
+ $(use_enable epiphany)
+ $(use_enable gedit)
+ $(use_enable libnotify)
+ $(use_enable nautilus)
+ $(use_enable test tests)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Use gpgme_engine_check_version() before gpgm_new() due current gpgme, bug #281729
+ epatch "${FILESDIR}/${PN}-2.28.1-gpgme_check_version.patch"
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ find "${D}" -name "*.la" -delete || die "remove of la files failed"
+
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}/70-seahorse-agent" || die "doexe failed"
+}