summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2010-11-07 18:28:38 +0000
committerDane Smith <c1pher@gentoo.org>2010-11-07 18:28:38 +0000
commit564e78333be08a8ca59a171df594c3d1359db321 (patch)
treebe98e04ac8878ad6e13cc952e9a7315fb2b73445 /app-crypt
parentdev-lisp/cl-spatial-trees removal, p.masked from 17Sep2010, wrt bug #337963 (diff)
downloadgentoo-2-564e78333be08a8ca59a171df594c3d1359db321.tar.gz
gentoo-2-564e78333be08a8ca59a171df594c3d1359db321.tar.bz2
gentoo-2-564e78333be08a8ca59a171df594c3d1359db321.zip
Version bump for xca to 0.9.0 wrt bug 343599.
(Portage version: 2.2.0_alpha3_p8/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/xca/ChangeLog9
-rw-r--r--app-crypt/xca/files/xca-0.9.0-qt_detection.patch29
-rw-r--r--app-crypt/xca/xca-0.9.0.ebuild55
3 files changed, 92 insertions, 1 deletions
diff --git a/app-crypt/xca/ChangeLog b/app-crypt/xca/ChangeLog
index 2e378c6ff17d..91fcda47e0ad 100644
--- a/app-crypt/xca/ChangeLog
+++ b/app-crypt/xca/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/xca
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.26 2010/06/26 13:11:28 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.27 2010/11/07 18:28:38 c1pher Exp $
+
+*xca-0.9.0 (07 Nov 2010)
+
+ 07 Nov 2010; Dane Smith <c1pher@gentoo.org> +xca-0.9.0.ebuild,
+ +files/xca-0.9.0-qt_detection.patch:
+ Version bump to 0.9.0 wrt bug 343599. Added new QT patch. Fixed a number
+ of QA issues.
26 Jun 2010; <nixnut@gentoo.org> xca-0.8.1.ebuild:
ppc stable #322283
diff --git a/app-crypt/xca/files/xca-0.9.0-qt_detection.patch b/app-crypt/xca/files/xca-0.9.0-qt_detection.patch
new file mode 100644
index 000000000000..e7eaa232a6e4
--- /dev/null
+++ b/app-crypt/xca/files/xca-0.9.0-qt_detection.patch
@@ -0,0 +1,29 @@
+--- configure 2010-08-29 04:28:32.000000000 -0400
++++ configure.mine 2010-11-07 13:08:58.000000000 -0500
+@@ -101,15 +101,17 @@
+ # check for libs
+ search_lib() {
+ for dir in ${DIRS}; do
+- for dbn in $@; do
+- for suffix in so dylib obj a; do
+- for lib in lib lib64 lib32 out; do
+- if test -r "${dir}/${lib}/lib${dbn}.${suffix}"; then
+- add_lib "${dir}/${lib}" "${dbn}" "${suffix}"
+- echo "Found: lib${dbn}.${suffix} at ${dir}/${lib}"
+- return 0
+- fi
+- done
++ for subdir in "" ${subdirs}; do
++ for dbn in $@; do
++ for suffix in so dylib obj a; do
++ for lib in lib out; do
++ if test -r "${dir}/${lib}/${subdir}/lib${dbn}.${suffix}"; then
++ add_lib "${dir}/${lib}/${subdir}" "${dbn}" "${suffix}"
++ echo "Found: lib${dbn}.${suffix} at ${dir}/${lib}/${subdir}"
++ return 0
++ fi
++ done
++ done
+ done
+ done
+ done
diff --git a/app-crypt/xca/xca-0.9.0.ebuild b/app-crypt/xca/xca-0.9.0.ebuild
new file mode 100644
index 000000000000..88ca15b2c2eb
--- /dev/null
+++ b/app-crypt/xca/xca-0.9.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/xca-0.9.0.ebuild,v 1.1 2010/11/07 18:28:38 c1pher Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests and revokation lists"
+HOMEPAGE="http://www.hohnstaedt.de/xca.html"
+SRC_URI="mirror://sourceforge/xca/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/openssl-0.9.8
+ x11-libs/qt-gui:4"
+DEPEND="${RDEPEND}
+ doc? ( app-text/linuxdoc-tools )"
+
+src_prepare() {
+ # http://sourceforge.net/tracker/index.php?func=detail&aid=1800298&group_id=62274&atid=500028
+ epatch "${FILESDIR}/${P}-qt_detection.patch"
+}
+
+src_configure() {
+ local LINUXDOC
+ use doc || LINUXDOC='touch $@ && true'
+
+ QTDIR=/usr \
+ STRIP="true" \
+ LINUXDOC="${LINUXDOC}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ CFLAGS="${CXXFLAGS}" \
+ LDFLAGS="$(raw-ldflags)" \
+ prefix=/usr \
+ docdir=/usr/share/doc/${PF} \
+ ./configure || die "configure failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake destdir="${D}" mandir="share/man" install || die "emake install failed"
+
+ dodoc AUTHORS || die
+
+ insinto /etc/xca
+ doins misc/*.txt || die
+}