summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 20:34:23 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 20:34:23 +0000
commit1bb3816af235ee425be5a27bd6b6f8ee073fdca7 (patch)
tree7c690277f873491d5af72292f87ff974d171e1dd /app-crypt
parentChanged econf||die to econf (diff)
downloadgentoo-2-1bb3816af235ee425be5a27bd6b6f8ee073fdca7.tar.gz
gentoo-2-1bb3816af235ee425be5a27bd6b6f8ee073fdca7.tar.bz2
gentoo-2-1bb3816af235ee425be5a27bd6b6f8ee073fdca7.zip
Changed src_install () to src_install()
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/heimdal/heimdal-0.5.1.ebuild10
-rw-r--r--app-crypt/johntheripper/johntheripper-1.6.ebuild16
-rw-r--r--app-crypt/krb5/krb5-1.2.5-r1.ebuild18
-rw-r--r--app-crypt/krb5/krb5-1.2.5-r2.ebuild16
4 files changed, 30 insertions, 30 deletions
diff --git a/app-crypt/heimdal/heimdal-0.5.1.ebuild b/app-crypt/heimdal/heimdal-0.5.1.ebuild
index a103b4467290..b5e3f0d8ef74 100644
--- a/app-crypt/heimdal/heimdal-0.5.1.ebuild
+++ b/app-crypt/heimdal/heimdal-0.5.1.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.5.1.ebuild,v 1.1 2002/10/26 15:24:01 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.5.1.ebuild,v 1.2 2002/11/30 20:29:48 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Kerberos 5 implementation from KTH"
SRC_URI="ftp://ftp.pdc.kth.se/pub/${PN}/src/${P}.tar.gz"
HOMEPAGE="http://www.pdc.kth.se/heimdal/"
-IUSE="ssl ldap berkdb ipv6"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc sparc64"
+IUSE="ssl ldap berkdb ipv6"
DEPEND=">=app-crypt/kth-krb-1.2.1
ssl? ( dev-libs/openssl )
@@ -23,7 +22,6 @@ src_unpack() {
cd ${S}/lib/krb5
mv Makefile.in Makefile.in.bak
sed "s:LIB_crypt = @LIB_crypt@:LIB_crypt = -lssl @LIB_crypt@:g" Makefile.in.bak >Makefile.in
-
}
src_compile() {
@@ -37,8 +35,6 @@ src_compile() {
use berkdb || myconf="${myconf} --without-berkely-db"
-echo $myconf
-
./configure --host=${CHOST} \
--prefix=/usr/heimdal \
--sysconfdir=/etc \
@@ -48,7 +44,7 @@ echo $myconf
make || die
}
-src_install () {
+src_install() {
make prefix=${D}/usr/heimdal \
sysconfdir=${D}/etc \
install || die
diff --git a/app-crypt/johntheripper/johntheripper-1.6.ebuild b/app-crypt/johntheripper/johntheripper-1.6.ebuild
index e7a5db91b1ca..25d785ded1d4 100644
--- a/app-crypt/johntheripper/johntheripper-1.6.ebuild
+++ b/app-crypt/johntheripper/johntheripper-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.6.ebuild,v 1.4 2002/10/17 13:23:59 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.6.ebuild,v 1.5 2002/11/30 20:32:53 vapier Exp $
PN0="john"
S=${WORKDIR}/${PN0}-${PV}
@@ -8,11 +8,12 @@ DEBPATCH=${PN0}_${PV}-17.diff.gz
DESCRIPTION="John the Ripper is a fast password cracker."
HOMEPAGE="http://www.openwall.com/${PN0}/"
SRC_URI="${HOMEPAGE}/${PN0}-${PV}.tar.gz
- http://ftp.debian.org/debian/pool/main/j/${PN0}/${DEBPATCH}"
-IUSE="mmx"
+ http://ftp.debian.org/debian/pool/main/j/${PN0}/${DEBPATCH}"
+
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc sparc64"
+IUSE="mmx"
DEPEND=">=sys-devel/binutils-2.8.1.0.15"
@@ -26,15 +27,14 @@ src_compile() {
mv Makefile Makefile.orig
sed -e "s/-m486//" -e "s/-Wall -O2/${CFLAGS}/" \
Makefile.orig > Makefile
- if [ -z "`use mmx`" ]
- then
- emake generic
+ if [ `use mmx` ] ; then
+ emake linux-x86-mmx-elf || die
else
- emake linux-x86-mmx-elf
+ emake generic || die
fi
}
-src_install () {
+src_install() {
dodir /usr/share/${PN0} /etc
insinto /etc
doins run/john.ini debian/john-mail.msg debian/john-mail.conf
diff --git a/app-crypt/krb5/krb5-1.2.5-r1.ebuild b/app-crypt/krb5/krb5-1.2.5-r1.ebuild
index 16a0c20e2bab..91a549b510f7 100644
--- a/app-crypt/krb5/krb5-1.2.5-r1.ebuild
+++ b/app-crypt/krb5/krb5-1.2.5-r1.ebuild
@@ -1,35 +1,37 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.5-r1.ebuild,v 1.5 2002/10/04 03:57:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.5-r1.ebuild,v 1.6 2002/11/30 20:33:36 vapier Exp $
-S=${WORKDIR}/${P}/src
SRC_URI="http://www.crypto-publish.org/dist/mit-kerberos5/${P}.tar.gz"
DESCRIPTION="MIT Kerberos V (set up for pam)"
-HOMEPAGE="http://crypto-publish.org"
+HOMEPAGE="http://crypto-publish.org/"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc sparc64"
-DEPEND="virtual/glibc"
+S=${WORKDIR}/${P}/src
src_compile() {
-
patch -p0 < ${FILESDIR}/${PN}-1.2.2-gentoo.diff || die
econf \
--with-krb4 \
--enable-shared \
- --enable-dns || die
+ --enable-dns
+
mv Makefile Makefile.orig
#Don't install the ftp, telnet, r* apps; use pam instead
sed -e 's/ appl / /' Makefile.orig > Makefile
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
cd ..
dodoc README
- echo 'NOTE: ftp, telnet, r* apps not installed. Install pam-krb5!'
+}
+
+pkg_postinst() {
+ ewarn 'NOTE: ftp, telnet, r* apps not installed. Install pam-krb5!'
}
diff --git a/app-crypt/krb5/krb5-1.2.5-r2.ebuild b/app-crypt/krb5/krb5-1.2.5-r2.ebuild
index 7f02d223731e..b329c65932a0 100644
--- a/app-crypt/krb5/krb5-1.2.5-r2.ebuild
+++ b/app-crypt/krb5/krb5-1.2.5-r2.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.5-r2.ebuild,v 1.3 2002/08/16 02:36:53 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.5-r2.ebuild,v 1.4 2002/11/30 20:34:23 vapier Exp $
-S=${WORKDIR}/${P}/src
SRC_URI="http://www.crypto-publish.org/dist/mit-kerberos5/${P}.tar.gz"
DESCRIPTION="MIT Kerberos V (set up for pam)"
HOMEPAGE="http://web.mit.edu/kerberos/www/"
@@ -11,10 +10,9 @@ SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc sparc64"
-DEPEND="virtual/glibc"
+S=${WORKDIR}/${P}/src
src_compile() {
-
patch -p0 < ${FILESDIR}/${PN}-1.2.2-gentoo.diff || die
cd ${S}/lib/rpc
@@ -24,16 +22,20 @@ src_compile() {
econf \
--with-krb4 \
--enable-shared \
- --enable-dns || die
+ --enable-dns
+
mv Makefile Makefile.orig
#Don't install the ftp, telnet, r* apps; use pam instead
sed -e 's/ appl / /' Makefile.orig > Makefile
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
cd ..
dodoc README
- echo 'NOTE: ftp, telnet, r* apps not installed. Install pam-krb5!'
+}
+
+pkg_postinst() {
+ ewarn 'NOTE: ftp, telnet, r* apps not installed. Install pam-krb5!'
}