summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-04-29 16:06:38 +0000
committerRick Farina <zerochaos@gentoo.org>2013-04-29 16:06:38 +0000
commit1699dbc28727404167ffe98f314108d52b9e12f3 (patch)
treea86e384d59258c3af954e8cbd2769155778e394e /app-crypt
parentFix LICENSE, bug 446164. (diff)
downloadgentoo-2-1699dbc28727404167ffe98f314108d52b9e12f3.tar.gz
gentoo-2-1699dbc28727404167ffe98f314108d52b9e12f3.tar.bz2
gentoo-2-1699dbc28727404167ffe98f314108d52b9e12f3.zip
ebuild cleanup, fix tests, fix running as user
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/oclhashcat-plus-bin/ChangeLog6
-rw-r--r--app-crypt/oclhashcat-plus-bin/oclhashcat-plus-bin-0.14.ebuild57
2 files changed, 40 insertions, 23 deletions
diff --git a/app-crypt/oclhashcat-plus-bin/ChangeLog b/app-crypt/oclhashcat-plus-bin/ChangeLog
index 7560f4c5b300..f24683d88146 100644
--- a/app-crypt/oclhashcat-plus-bin/ChangeLog
+++ b/app-crypt/oclhashcat-plus-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/oclhashcat-plus-bin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/oclhashcat-plus-bin/ChangeLog,v 1.10 2013/04/28 02:17:02 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/oclhashcat-plus-bin/ChangeLog,v 1.11 2013/04/29 16:06:38 zerochaos Exp $
+
+ 29 Apr 2013; Rick Farina <zerochaos@gentoo.org>
+ oclhashcat-plus-bin-0.14.ebuild:
+ ebuild cleanup, fix tests, fix running as user
28 Apr 2013; Rick Farina <zerochaos@gentoo.org>
oclhashcat-plus-bin-0.14.ebuild:
diff --git a/app-crypt/oclhashcat-plus-bin/oclhashcat-plus-bin-0.14.ebuild b/app-crypt/oclhashcat-plus-bin/oclhashcat-plus-bin-0.14.ebuild
index d3ef58e639b7..71c582f19136 100644
--- a/app-crypt/oclhashcat-plus-bin/oclhashcat-plus-bin-0.14.ebuild
+++ b/app-crypt/oclhashcat-plus-bin/oclhashcat-plus-bin-0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/oclhashcat-plus-bin/oclhashcat-plus-bin-0.14.ebuild,v 1.2 2013/04/28 02:17:02 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/oclhashcat-plus-bin/oclhashcat-plus-bin-0.14.ebuild,v 1.3 2013/04/29 16:06:38 zerochaos Exp $
EAPI=5
@@ -32,41 +32,53 @@ S="${WORKDIR}/${MY_P}"
RESTRICT="strip"
QA_PREBUILT="*Hashcat-plus*.bin"
+src_prepare() {
+ use x86 && rm *Hashcat-plus64*
+ use amd64 && rm *Hashcat-plus32*
+ use virtualcl || rm vclHashcat-plus*
+
+ if ! use video_cards_fglrx; then
+ rm -r kernels/4098 || die
+ rm oclHashcat-plus*.bin || die
+ fi
+ if ! use video_cards_nvidia; then
+ rm -r kernels/4318 || die
+ rm cudaHashcat-plus*.bin || die
+ fi
+
+ #paxmark goes here so test and install works
+ pax-mark r *Hashcat-plus*.bin
+}
+
src_test() {
printf "%02x" ${PV#0.} > "${S}"/eula.accepted
if use video_cards_nvidia; then
+ addwrite /dev/nvidia0
+ addwrite /dev/nvidiactl
if [ ! -w /dev/nvidia0 ]; then
einfo "To run these tests, portage likely must be in the video group."
einfo "Please run \"gpasswd -a portage video\" if the tests will fail"
fi
- ./cudaExample0.sh || die
- ./cudaExample400.sh || die
- ./cudaExample500.sh || die
+ if use amd64; then
+ ./cudaHashcat-plus64.bin -a 3 -m 1500 nQCk49SiErOgk || die
+ elif use x86; then
+ ./cudaHashcat-plus32.bin -a 3 -m 1500 nQCk49SiErOgk || die
+ fi
fi
if use video_cards_fglrx; then
- ./oclExample0.sh || die
- ./oclExample400.sh || die
- ./oclExample500.sh || die
+ addwrite /dev/ati
+ if use amd64; then
+ ./oclHashcat-plus64.bin -a 3 -m 1500 nQCk49SiErOgk || die
+ elif use x86; then
+ ./oclHashcat-plus32.bin -a 3 -m 1500 nQCk49SiErOgk || die
+ fi
fi
- rm "${S}"/eula.accepted
+ rm eula.accepted hashcat.pot hashcat.dictstat
}
src_install() {
dodoc docs/*
rm -r "${S}"/*.exe "${S}"/*.cmd "${S}"/docs || die
- use x86 && rm *Hashcat-plus64*
- use amd64 && rm *Hashcat-plus32*
- use virtualcl || { rm vclHashcat-plus* || die; }
-
- if ! use video_cards_fglrx; then
- rm -r kernels/4098 || die
- rm oclHashcat-plus*.bin || die
- fi
- if ! use video_cards_nvidia; then
- rm -r kernels/4318 || die
- rm cudaHashcat-plus*.bin || die
- fi
- pax-mark m *Hashcat-plus*.bin
insinto /opt/${PN}
doins -r "${S}"/* || die "Copy files failed"
@@ -119,7 +131,8 @@ src_install() {
done
fperms +x /opt/bin/oclhashcat-plus
- fowners root:video /opt/${PN}
+ fowners -R root:video /opt/${PN}
+ fperms g+w /opt/${PN}
einfo "oclhashcat-plus can be run as user if you are in the video group"
}