summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-09-01 18:48:26 +0000
committerTim Harder <radhermit@gentoo.org>2013-09-01 18:48:26 +0000
commitbef3c3990b8ae5e655cd446ff53def78186aa993 (patch)
tree1665e8d247ad4910a9cff2343f5997760eac2b02 /app-crypt/p11-kit
parentDrop notes about intel[gallium] as it works fine for me and haven't seen any ... (diff)
downloadgentoo-2-bef3c3990b8ae5e655cd446ff53def78186aa993.tar.gz
gentoo-2-bef3c3990b8ae5e655cd446ff53def78186aa993.tar.bz2
gentoo-2-bef3c3990b8ae5e655cd446ff53def78186aa993.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-crypt/p11-kit')
-rw-r--r--app-crypt/p11-kit/ChangeLog7
-rw-r--r--app-crypt/p11-kit/p11-kit-0.19.4.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/app-crypt/p11-kit/ChangeLog b/app-crypt/p11-kit/ChangeLog
index 0f18ccddb078..81f4cfc42e1a 100644
--- a/app-crypt/p11-kit/ChangeLog
+++ b/app-crypt/p11-kit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/p11-kit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/ChangeLog,v 1.47 2013/07/27 20:24:41 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/ChangeLog,v 1.48 2013/09/01 18:48:26 radhermit Exp $
+
+*p11-kit-0.19.4 (01 Sep 2013)
+
+ 01 Sep 2013; Tim Harder <radhermit@gentoo.org> +p11-kit-0.19.4.ebuild:
+ Version bump.
*p11-kit-0.19.3 (27 Jul 2013)
diff --git a/app-crypt/p11-kit/p11-kit-0.19.4.ebuild b/app-crypt/p11-kit/p11-kit-0.19.4.ebuild
new file mode 100644
index 000000000000..093c11882084
--- /dev/null
+++ b/app-crypt/p11-kit/p11-kit-0.19.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/p11-kit-0.19.4.ebuild,v 1.1 2013/09/01 18:48:26 radhermit Exp $
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Provides a standard configuration setup for installing PKCS#11."
+HOMEPAGE="http://p11-glue.freedesktop.org/p11-kit.html"
+SRC_URI="http://p11-glue.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="+asn1 debug +trust"
+REQUIRED_USE="trust? ( asn1 )"
+
+RDEPEND="asn1? ( >=dev-libs/libtasn1-2.14 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable trust trust-module) \
+ $(use_enable debug) \
+ $(use_with asn1 libtasn1)
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}