summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-03-30 23:16:06 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-03-30 23:16:06 +0000
commit73d87968b7dd0a7b97d2bdfb79f22a35ca870da7 (patch)
treecaba70a94fdc096b8ce5a3b68e61421f0aa3a8e0 /app-crypt/libsecret
parentFix multi-slot for ActivCard, bug#460662, thanks to Kamil Roman (diff)
downloadgentoo-2-73d87968b7dd0a7b97d2bdfb79f22a35ca870da7.tar.gz
gentoo-2-73d87968b7dd0a7b97d2bdfb79f22a35ca870da7.tar.bz2
gentoo-2-73d87968b7dd0a7b97d2bdfb79f22a35ca870da7.zip
Policy fixups, switch to python-any-r1.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'app-crypt/libsecret')
-rw-r--r--app-crypt/libsecret/ChangeLog5
-rw-r--r--app-crypt/libsecret/libsecret-0.14.ebuild37
2 files changed, 20 insertions, 22 deletions
diff --git a/app-crypt/libsecret/ChangeLog b/app-crypt/libsecret/ChangeLog
index b395acce1b35..f47339d37eb1 100644
--- a/app-crypt/libsecret/ChangeLog
+++ b/app-crypt/libsecret/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-crypt/libsecret
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/libsecret/ChangeLog,v 1.16 2013/03/05 22:52:24 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/libsecret/ChangeLog,v 1.17 2013/03/30 23:16:06 eva Exp $
+
+ 30 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org> libsecret-0.14.ebuild:
+ Policy fixups, switch to python-any-r1.
05 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org> -libsecret-0.11.ebuild:
Clean up old revision.
diff --git a/app-crypt/libsecret/libsecret-0.14.ebuild b/app-crypt/libsecret/libsecret-0.14.ebuild
index 73b195d2c368..e125995d8ace 100644
--- a/app-crypt/libsecret/libsecret-0.14.ebuild
+++ b/app-crypt/libsecret/libsecret-0.14.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/libsecret/libsecret-0.14.ebuild,v 1.1 2013/03/05 01:26:14 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/libsecret/libsecret-0.14.ebuild,v 1.2 2013/03/30 23:16:06 eva Exp $
EAPI="5"
+PYTHON_COMPAT=( python2_{6,7} )
VALA_MIN_API_VERSION=0.18
VALA_USE_DEPEND=vapigen
-inherit eutils gnome2 python vala virtualx
+inherit eutils gnome2 python-any-r1 vala virtualx
DESCRIPTION="GObject library for accessing the freedesktop.org Secret Service API"
HOMEPAGE="https://live.gnome.org/Libsecret"
@@ -34,31 +35,13 @@ DEPEND="${COMMON_DEPEND}
test? (
dev-python/mock
introspection? (
- =dev-lang/python-2*
+ ${PYTHON_DEPS}
>=dev-libs/gjs-1.32
dev-python/pygobject:3 )
)
vala? ( $(vala_depend) )"
-pkg_setup() {
- # python is only needed for tests
- if use test && use introspection; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
src_prepare() {
- DOCS="AUTHORS ChangeLog NEWS README"
- G2CONF="${G2CONF}
- --enable-manpages
- --disable-strict
- --disable-coverage
- --disable-static
- $(use_enable crypt gcrypt)
- $(use_enable introspection)
- $(use_enable vala)"
-
# FIXME: disable failing test
sed -e '/test_get_sync);/d' \
-e '/test_get_async);/d' \
@@ -68,6 +51,18 @@ src_prepare() {
gnome2_src_prepare
}
+src_configure() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ gnome2_src_configure \
+ --enable-manpages \
+ --disable-strict \
+ --disable-coverage \
+ --disable-static \
+ $(use_enable crypt gcrypt) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
src_test() {
Xemake check
}