summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-04-22 15:31:23 +0000
committerRick Farina <zerochaos@gentoo.org>2013-04-22 15:31:23 +0000
commit8b951b42da88385c9df09735bbc15188d34b1cd4 (patch)
treefbda4061043a17491fb2b3edab2dc3817c541081 /app-crypt/hashcat-bin
parentMetadata whitespaces cleanup, add missing name for maintainer (diff)
downloadgentoo-2-8b951b42da88385c9df09735bbc15188d34b1cd4.tar.gz
gentoo-2-8b951b42da88385c9df09735bbc15188d34b1cd4.tar.bz2
gentoo-2-8b951b42da88385c9df09735bbc15188d34b1cd4.zip
version bump, avx and xop support similar to jtr ebuild
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'app-crypt/hashcat-bin')
-rw-r--r--app-crypt/hashcat-bin/ChangeLog7
-rw-r--r--app-crypt/hashcat-bin/hashcat-bin-0.44.ebuild111
2 files changed, 117 insertions, 1 deletions
diff --git a/app-crypt/hashcat-bin/ChangeLog b/app-crypt/hashcat-bin/ChangeLog
index a273be922956..a1eeeda8231a 100644
--- a/app-crypt/hashcat-bin/ChangeLog
+++ b/app-crypt/hashcat-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/hashcat-bin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/hashcat-bin/ChangeLog,v 1.8 2013/01/07 04:12:18 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/hashcat-bin/ChangeLog,v 1.9 2013/04/22 15:31:23 zerochaos Exp $
+
+*hashcat-bin-0.44 (22 Apr 2013)
+
+ 22 Apr 2013; Rick Farina <zerochaos@gentoo.org> +hashcat-bin-0.44.ebuild:
+ version bump, avx and xop support similar to jtr ebuild
*hashcat-bin-0.42 (07 Jan 2013)
diff --git a/app-crypt/hashcat-bin/hashcat-bin-0.44.ebuild b/app-crypt/hashcat-bin/hashcat-bin-0.44.ebuild
new file mode 100644
index 000000000000..6e8cea63eac0
--- /dev/null
+++ b/app-crypt/hashcat-bin/hashcat-bin-0.44.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/hashcat-bin/hashcat-bin-0.44.ebuild,v 1.1 2013/04/22 15:31:23 zerochaos Exp $
+
+EAPI=4
+
+MY_P="hashcat-${PV}"
+
+inherit eutils pax-utils
+DESCRIPTION="An multi-threaded multihash cracker"
+HOMEPAGE="http://hashcat.net/hashcat/"
+
+SRC_URI="http://hashcat.net/files/${MY_P}.7z"
+
+#license applies to this version per http://hashcat.net/forum/thread-1348.html
+LICENSE="hashcat"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~amd64-linux ~x64-macos ~x86 ~x86-linux"
+
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/p7zip"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="strip"
+QA_PREBUILT="opt/${PN}/hashcat-cli*.bin
+ opt/${PN}/hashcat-cli64.app"
+
+has_xop() {
+ echo | $(tc-getCC) ${CFLAGS} -E -dM - | grep -q "#define __XOP__ 1"
+}
+
+has_avx() {
+ echo | $(tc-getCC) ${CFLAGS} -E -dM - | grep -q "#define __AVX__ 1"
+}
+
+src_install() {
+ dodoc docs/*
+ rm -r *.exe docs || die
+ use x86 || { rm hashcat-cli32.bin || die; }
+ use amd64 || { rm hashcat-cli64.bin || die; }
+ use x64-macos || { rm hashcat-cli64.app || die; }
+ has_avx || { rm hashcat-cliAVX.bin || die; }
+ has_xop || { rm hashcat-cliXOP.bin || die; }
+
+ #I assume this is needed but I didn't check
+ pax-mark m hashcat-cli*.bin
+
+ insinto /opt/${PN}
+ doins -r "${S}"/*
+
+ dodir /opt/bin
+ if [ -f "${ED}"/opt/${PN}/hashcat-cli32.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cli32.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cli32.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cli32.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cli32.bin \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cli32.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cli64.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cli64.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cli64.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cli64.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cli64.bin \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cli64.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cliAVX.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cliAVX.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cliAVX.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cliAVX.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cliAVX.bin \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cliAVX.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cliXOP.bin ]
+ then
+ fperms +x /opt/${PN}/hashcat-cliXOP.bin
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cliXOP.bin
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cliXOP.bin is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cliXOP.bin \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cliXOP.bin
+ fi
+ if [ -f "${ED}"/opt/${PN}/hashcat-cli64.app ]
+ then
+ fperms +x /opt/${PN}/hashcat-cli64.app
+ cat <<-EOF > "${ED}"/opt/bin/hashcat-cli64.app
+ #! /bin/sh
+ cd "${EPREFIX}"/opt/${PN}
+ echo "Warning: hashcat-cli64.app is running from ${EPREFIX}/opt/${PN} so be careful of relative paths."
+ exec ./hashcat-cli64.app \$@
+ EOF
+ fperms +x /opt/bin/hashcat-cli64.app
+ fi
+}