summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-06-15 16:30:38 +0000
committerSamuli Suominen <drac@gentoo.org>2008-06-15 16:30:38 +0000
commit948ab422e21964f91eb128828344e89d9247bb62 (patch)
tree6ffeb8f395ad2ff22dd6ed717bb6c35a19476db2 /app-cdr/mode2cdmaker
parentdo not run buildconf wrt #226051 (diff)
downloadgentoo-2-948ab422e21964f91eb128828344e89d9247bb62.tar.gz
gentoo-2-948ab422e21964f91eb128828344e89d9247bb62.tar.bz2
gentoo-2-948ab422e21964f91eb128828344e89d9247bb62.zip
Fix implicit declarations and respect CC, CFLAGS, LDFLAGS. Keyword ~amd64.
(Portage version: 2.1.5.5)
Diffstat (limited to 'app-cdr/mode2cdmaker')
-rw-r--r--app-cdr/mode2cdmaker/ChangeLog8
-rw-r--r--app-cdr/mode2cdmaker/files/mode2cdmaker-1.5.1-gentoo.patch46
-rw-r--r--app-cdr/mode2cdmaker/mode2cdmaker-1.5.1.ebuild21
3 files changed, 63 insertions, 12 deletions
diff --git a/app-cdr/mode2cdmaker/ChangeLog b/app-cdr/mode2cdmaker/ChangeLog
index bd08ed82686f..ad7b34045816 100644
--- a/app-cdr/mode2cdmaker/ChangeLog
+++ b/app-cdr/mode2cdmaker/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-cdr/mode2cdmaker
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/mode2cdmaker/ChangeLog,v 1.3 2007/02/21 20:18:01 peper Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/mode2cdmaker/ChangeLog,v 1.4 2008/06/15 16:30:38 drac Exp $
+
+ 15 Jun 2008; Samuli Suominen <drac@gentoo.org>
+ +files/mode2cdmaker-1.5.1-gentoo.patch, mode2cdmaker-1.5.1.ebuild:
+ Fix implicit declarations and respect CC, CFLAGS, LDFLAGS. Keyword ~amd64.
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/app-cdr/mode2cdmaker/files/mode2cdmaker-1.5.1-gentoo.patch b/app-cdr/mode2cdmaker/files/mode2cdmaker-1.5.1-gentoo.patch
new file mode 100644
index 000000000000..502819c11df3
--- /dev/null
+++ b/app-cdr/mode2cdmaker/files/mode2cdmaker-1.5.1-gentoo.patch
@@ -0,0 +1,46 @@
+diff -ur mode2cdmaker-1.5.1.orig/Makefile.linux mode2cdmaker-1.5.1/Makefile.linux
+--- mode2cdmaker-1.5.1.orig/Makefile.linux 2003-02-01 16:27:18.000000000 +0200
++++ mode2cdmaker-1.5.1/Makefile.linux 2008-06-15 19:24:14.000000000 +0300
+@@ -4,8 +4,8 @@
+ output=mode2cdmaker
+
+ all:
+- gcc -c $(srcs)
+- gcc -o $(output) $(objs)
++ $(CC) ${CFLAGS} -DMAX_PATH=512 -c $(srcs)
++ $(CC) ${LDFLAGS} -o $(output) $(objs)
+
+ clean:
+ -rm -f $(objs) $(output)
+diff -ur mode2cdmaker-1.5.1.orig/mkvcdfs.c mode2cdmaker-1.5.1/mkvcdfs.c
+--- mode2cdmaker-1.5.1.orig/mkvcdfs.c 2003-03-14 19:57:38.000000000 +0200
++++ mode2cdmaker-1.5.1/mkvcdfs.c 2008-06-15 19:23:25.000000000 +0300
+@@ -120,6 +120,7 @@
+ #endif
+ #endif
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <fcntl.h>
+ #include <string.h>
+ #include <ctype.h>
+@@ -629,7 +630,7 @@
+ next_command[1]=(char*)malloc(256);
+ while (fgets(next_command[1],256,pf))
+ {
+- next_command[1][lstrlen(next_command[1])-1]=0;
++ next_command[1][strlen(next_command[1])-1]=0;
+ parse_params(2,next_command,idepth+1);
+ }
+ fclose(pf);
+diff -ur mode2cdmaker-1.5.1.orig/vcdisofs.c mode2cdmaker-1.5.1/vcdisofs.c
+--- mode2cdmaker-1.5.1.orig/vcdisofs.c 2003-02-02 00:02:44.000000000 +0200
++++ mode2cdmaker-1.5.1/vcdisofs.c 2008-06-15 19:19:59.000000000 +0300
+@@ -80,6 +80,8 @@
+ #include <windows.h>
+ #endif
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <time.h>
+ #include "defaults.h"
+
diff --git a/app-cdr/mode2cdmaker/mode2cdmaker-1.5.1.ebuild b/app-cdr/mode2cdmaker/mode2cdmaker-1.5.1.ebuild
index 68c74e984d5c..68b206cc2e03 100644
--- a/app-cdr/mode2cdmaker/mode2cdmaker-1.5.1.ebuild
+++ b/app-cdr/mode2cdmaker/mode2cdmaker-1.5.1.ebuild
@@ -1,14 +1,16 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/mode2cdmaker/mode2cdmaker-1.5.1.ebuild,v 1.3 2005/09/15 20:40:18 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/mode2cdmaker/mode2cdmaker-1.5.1.ebuild,v 1.4 2008/06/15 16:30:38 drac Exp $
+
+inherit eutils toolchain-funcs
DESCRIPTION="Utility to create mode-2 CDs, for example XCDs."
-HOMEPAGE="http://webs.ono.com/usr016/de_xt/mcf.html"
+HOMEPAGE="http://es.geocities.com/dextstuff/mode2cdmaker.html"
SRC_URI="http://dext.peque.org/xcd/${P}-src.zip"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
DEPEND="app-arch/unzip"
@@ -19,16 +21,15 @@ S=${WORKDIR}
src_unpack() {
unpack ${A}
cd "${S}"
- sed -e 's:gcc -c:gcc $(CFLAGS) -DMAX_PATH=512 -c:g' \
- Makefile.linux > Makefile || die "sed failed"
- sed -i -e 's:lstrlen:strlen:g' mkvcdfs.c || die "sed failed"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
}
src_compile() {
- emake || die "emake failed"
+ tc-export CC
+ emake -f Makefile.linux || die "emake failed."
}
src_install() {
- dobin mode2cdmaker || die "dobin failed"
- dodoc bugs.txt compatibility.txt readme.txt
+ dobin mode2cdmaker || die "dobin failed."
+ dodoc {bugs,compatibility,readme}.txt
}