summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2007-12-16 22:20:23 +0000
committerLars Weiler <pylon@gentoo.org>2007-12-16 22:20:23 +0000
commit976ef3f8c0da41caf30fa8eddce7bc3e379a3252 (patch)
treec34ff5b1d48832e6d66451bf947aaa05ca16575a /app-cdr/gnomebaker/gnomebaker-0.6.2.ebuild
parentadd gnome-doc-utils dependency and fix configure switch (diff)
downloadgentoo-2-976ef3f8c0da41caf30fa8eddce7bc3e379a3252.tar.gz
gentoo-2-976ef3f8c0da41caf30fa8eddce7bc3e379a3252.tar.bz2
gentoo-2-976ef3f8c0da41caf30fa8eddce7bc3e379a3252.zip
Version bump; bug #193227. Quotes.
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'app-cdr/gnomebaker/gnomebaker-0.6.2.ebuild')
-rw-r--r--app-cdr/gnomebaker/gnomebaker-0.6.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-cdr/gnomebaker/gnomebaker-0.6.2.ebuild b/app-cdr/gnomebaker/gnomebaker-0.6.2.ebuild
new file mode 100644
index 000000000000..2ec351f0f1e8
--- /dev/null
+++ b/app-cdr/gnomebaker/gnomebaker-0.6.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/gnomebaker/gnomebaker-0.6.2.ebuild,v 1.1 2007/12/16 22:20:22 pylon Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="GnomeBaker is a GTK2/Gnome cd burning application."
+HOMEPAGE="http://gnomebaker.sf.net"
+SRC_URI="mirror://sourceforge/gnomebaker/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="dvdr nls mp3 flac vorbis libnotify"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+DEPEND=">=gnome-base/libglade-2.0
+ >=gnome-base/libgnomeui-2.10
+ >=media-libs/gstreamer-0.10.0
+ dev-perl/XML-Parser
+ libnotify? ( x11-libs/libnotify )
+ app-text/scrollkeeper"
+RDEPEND="${DEPEND}
+ dvdr? ( app-cdr/dvd+rw-tools )
+ mp3? ( >=media-plugins/gst-plugins-mad-0.10.0
+ media-libs/gst-plugins-good )
+ vorbis? ( >=media-plugins/gst-plugins-vorbis-0.10.0
+ >=media-libs/libogg-1.1.2
+ media-libs/gst-plugins-good )
+ flac? ( >=media-plugins/gst-plugins-flac-0.10.0
+ media-libs/gst-plugins-good )
+ app-cdr/cdrdao
+ virtual/cdrtools"
+
+G2CONF="${G2CONF} \
+ $(use_enable libnotify)"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-genisofs.patch
+ epatch "${FILESDIR}"/${P}-fix_fstab_parsing.patch
+
+ gnome2_omf_fix
+}
+
+src_install() {
+ gnome2_src_install \
+ gnomebakerdocdir=/usr/share/doc/${P} \
+ docdir=/usr/share/gnome/help/${PN}/C \
+ gnomemenudir=/usr/share/applications
+ rm -rf "${D}"/usr/share/doc/${P}/*.make "${D}"/var
+ use nls || rm -rf "${D}"/usr/share/locale
+}