summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2015-07-05 19:27:16 +0000
committerAgostino Sarubbo <ago@gentoo.org>2015-07-05 19:27:16 +0000
commitfa8514df3751ddded75dd009ed548f2e741aa253 (patch)
treedd9e02ac665889a2b382e42900ac5331182413ac /app-benchmarks
parentMake sure a compatible version of minitest is used for tests. (diff)
downloadgentoo-2-fa8514df3751ddded75dd009ed548f2e741aa253.tar.gz
gentoo-2-fa8514df3751ddded75dd009ed548f2e741aa253.tar.bz2
gentoo-2-fa8514df3751ddded75dd009ed548f2e741aa253.zip
EAPI 5, update HOMEPAGE and SRC_URI ( fix bug #524110 ), add slot operator for openssl and replace make with emake (parallel build works for me).
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 7194459F)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/siege/ChangeLog10
-rw-r--r--app-benchmarks/siege/siege-3.1.0.ebuild50
2 files changed, 58 insertions, 2 deletions
diff --git a/app-benchmarks/siege/ChangeLog b/app-benchmarks/siege/ChangeLog
index ef0a5b0beddd..f6bd83809244 100644
--- a/app-benchmarks/siege/ChangeLog
+++ b/app-benchmarks/siege/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-benchmarks/siege
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.72 2014/08/30 10:28:54 mgorny Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.73 2015/07/05 19:27:16 ago Exp $
+
+*siege-3.1.0 (05 Jul 2015)
+
+ 05 Jul 2015; Agostino Sarubbo <ago@gentoo.org> +siege-3.1.0.ebuild:
+ EAPI 5, update HOMEPAGE and SRC_URI ( fix bug #524110 ), add slot operator for
+ openssl and replace make with emake (parallel build works for me).
30 Aug 2014; Michał Górny <mgorny@gentoo.org> -files/siege-2.60-gentoo.diff,
-files/siege-2.70-gentoo.diff, -files/siege-2.72-gentoo.diff,
diff --git a/app-benchmarks/siege/siege-3.1.0.ebuild b/app-benchmarks/siege/siege-3.1.0.ebuild
new file mode 100644
index 000000000000..a74db7979b53
--- /dev/null
+++ b/app-benchmarks/siege/siege-3.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-3.1.0.ebuild,v 1.1 2015/07/05 19:27:16 ago Exp $
+
+EAPI=5
+
+#WANT_AUTOMAKE=1.9
+
+inherit eutils bash-completion-r1 libtool autotools
+
+DESCRIPTION="A HTTP regression testing and benchmarking utility"
+HOMEPAGE="https://www.joedog.org/siege-home/"
+SRC_URI="http://download.joedog.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86 ~x64-macos"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6d:= )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+src_prepare() {
+ # bundled macros break recent libtool
+ sed -i -e 's/AC_PROG_SHELL//' configure.ac || die
+ rm *.m4 || die "failed to remove bundled macros"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use ssl && myconf="--with-ssl=${EPREFIX}/usr" || myconf="--without-ssl"
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog INSTALL MACHINES README* KNOWNBUGS \
+ doc/siegerc doc/urls.txt
+
+ newbashcomp "${FILESDIR}"/${PN}.bash-completion ${PN}
+}
+
+pkg_postinst() {
+ echo
+ elog "An example ~/.siegerc file has been installed in"
+ elog "${EPREFIX}/usr/share/doc/${PF}/"
+}