summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-06-21 14:19:17 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-06-21 14:19:17 +0000
commit0b66597ca4fe6f89c11ae96d45561b992b547142 (patch)
tree8895cdf44ab7f9b42d338029cb24cd38fe702900 /app-benchmarks/libc-bench
parentDo not call gcc directly (bug #462836). (diff)
downloadgentoo-2-0b66597ca4fe6f89c11ae96d45561b992b547142.tar.gz
gentoo-2-0b66597ca4fe6f89c11ae96d45561b992b547142.tar.bz2
gentoo-2-0b66597ca4fe6f89c11ae96d45561b992b547142.zip
Initial commit
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'app-benchmarks/libc-bench')
-rw-r--r--app-benchmarks/libc-bench/ChangeLog10
-rw-r--r--app-benchmarks/libc-bench/files/respect-flags.patch23
-rw-r--r--app-benchmarks/libc-bench/libc-bench-20110206.ebuild28
-rw-r--r--app-benchmarks/libc-bench/metadata.xml8
4 files changed, 69 insertions, 0 deletions
diff --git a/app-benchmarks/libc-bench/ChangeLog b/app-benchmarks/libc-bench/ChangeLog
new file mode 100644
index 000000000000..e4586fdb95b2
--- /dev/null
+++ b/app-benchmarks/libc-bench/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-benchmarks/libc-bench
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/libc-bench/ChangeLog,v 1.1 2013/06/21 14:19:16 blueness Exp $
+
+*libc-bench-20110206 (21 Jun 2013)
+
+ 21 Jun 2013; Anthony G. Basile <blueness@gentoo.org>
+ +libc-bench-20110206.ebuild, +files/respect-flags.patch, +metadata.xml:
+ Initial commit
+
diff --git a/app-benchmarks/libc-bench/files/respect-flags.patch b/app-benchmarks/libc-bench/files/respect-flags.patch
new file mode 100644
index 000000000000..19958fd1c91b
--- /dev/null
+++ b/app-benchmarks/libc-bench/files/respect-flags.patch
@@ -0,0 +1,23 @@
+diff -Naur libc-bench-20110206.orig//Makefile libc-bench-20110206/Makefile
+--- libc-bench-20110206.orig//Makefile 2011-01-31 02:13:00.000000000 -0500
++++ libc-bench-20110206/Makefile 2012-08-09 22:12:24.000000000 -0400
+@@ -2,8 +2,7 @@
+ SRCS = $(sort $(wildcard *.c))
+ OBJS = $(SRCS:.c=.o)
+
+-CFLAGS = -Os
+-LDFLAGS = -static
++LDFLAGS += -static
+ LIBS = -lpthread -lrt -lpthread
+
+
+@@ -12,9 +11,6 @@
+ clean:
+ rm -f $(OBJS) libc-bench
+
+-test: all
+- ./libc-bench
+-
+ libc-bench: $(OBJS)
+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+
diff --git a/app-benchmarks/libc-bench/libc-bench-20110206.ebuild b/app-benchmarks/libc-bench/libc-bench-20110206.ebuild
new file mode 100644
index 000000000000..ce84adc97005
--- /dev/null
+++ b/app-benchmarks/libc-bench/libc-bench-20110206.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/libc-bench/libc-bench-20110206.ebuild,v 1.1 2013/06/21 14:19:16 blueness Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Time and memory-efficiency tests of various C/POSIX standard library functions"
+HOMEPAGE="http://www.etalabs.net/libc-bench.html"
+SRC_URI="http://www.etalabs.net/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/respect-flags.patch
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe libc-bench
+}
diff --git a/app-benchmarks/libc-bench/metadata.xml b/app-benchmarks/libc-bench/metadata.xml
new file mode 100644
index 000000000000..1e7587374fdf
--- /dev/null
+++ b/app-benchmarks/libc-bench/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+</pkgmetadata>