summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-08-10 11:13:32 +0000
committerRoy Marples <uberlord@gentoo.org>2007-08-10 11:13:32 +0000
commit95072df2fdaeaf28df4e5995324252c69b4d5ceb (patch)
treee43b7c33a04c5f772b6407202a4730430b2fb409 /app-benchmarks/bootchart
parentAdded latest version and nls patch from Petr Pisar (bug #183472). (diff)
downloadgentoo-2-95072df2fdaeaf28df4e5995324252c69b4d5ceb.tar.gz
gentoo-2-95072df2fdaeaf28df4e5995324252c69b4d5ceb.tar.bz2
gentoo-2-95072df2fdaeaf28df4e5995324252c69b4d5ceb.zip
Remove a bashism from bootchartd as it uses /bin/sh.
Don't install baselayout-1 hooks if we have baselayout-2 installed and give different installation instructions #188278. (Portage version: 2.1.3.3)
Diffstat (limited to 'app-benchmarks/bootchart')
-rw-r--r--app-benchmarks/bootchart/ChangeLog10
-rw-r--r--app-benchmarks/bootchart/bootchart-0.9-r2.ebuild123
-rw-r--r--app-benchmarks/bootchart/files/bootchart-0.9-sh.patch12
-rw-r--r--app-benchmarks/bootchart/files/digest-bootchart-0.9-r23
4 files changed, 147 insertions, 1 deletions
diff --git a/app-benchmarks/bootchart/ChangeLog b/app-benchmarks/bootchart/ChangeLog
index 8630487e7805..9dc7d1223a94 100644
--- a/app-benchmarks/bootchart/ChangeLog
+++ b/app-benchmarks/bootchart/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-benchmarks/bootchart
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart/ChangeLog,v 1.4 2007/03/28 06:10:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart/ChangeLog,v 1.5 2007/08/10 11:13:32 uberlord Exp $
+
+*bootchart-0.9-r2 (10 Aug 2007)
+
+ 10 Aug 2007; Roy Marples <uberlord@gentoo.org>
+ +files/bootchart-0.9-sh.patch, +bootchart-0.9-r2.ebuild:
+ Remove a bashism from bootchartd as it uses /bin/sh.
+ Don't install baselayout-1 hooks if we have baselayout-2 installed
+ and give different installation instructions #188278.
28 Mar 2007; Mike Frysinger <vapier@gentoo.org> bootchart-0.9-r1.ebuild:
Fix install path for rcscript addon #172391 by Georgi Georgiev.
diff --git a/app-benchmarks/bootchart/bootchart-0.9-r2.ebuild b/app-benchmarks/bootchart/bootchart-0.9-r2.ebuild
new file mode 100644
index 000000000000..519ca9297685
--- /dev/null
+++ b/app-benchmarks/bootchart/bootchart-0.9-r2.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart/bootchart-0.9-r2.ebuild,v 1.1 2007/08/10 11:13:32 uberlord Exp $
+
+inherit multilib eutils java-pkg-opt-2 java-ant-2
+
+DESCRIPTION="Performance analysis and visualization of the system boot process"
+HOMEPAGE="http://www.bootchart.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acct debug doc java source"
+
+DEPEND="
+ java? (
+ >=virtual/jdk-1.4
+ >=dev-java/ant-core-1.4
+ dev-java/commons-cli
+ source? ( app-arch/zip )
+ )
+"
+RDEPEND="
+ java? (
+ >=virtual/jdk-1.4
+ dev-java/commons-cli
+ )
+ acct? ( sys-process/acct )
+"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}"-gentoo.patch
+ epatch "${FILESDIR}/${P}"-sh.patch
+
+ # delete the included commons-cli and use gentoo's instead
+ # The rest of lib is also bundled but a bit problematic to
+ # package https://bugs.gentoo.org/show_bug.cgi?id=162788
+ rm -rf lib/org/apache/commons/cli lib/org/apache/commons/lang
+
+ if use java ; then
+ java-ant_rewrite-classpath
+ sed -i -e 's,AUTO_RENDER="no",AUTO_RENDER="yes",g' \
+ script/bootchartd.conf
+ fi
+
+ if use acct ; then
+ sed -i -e 's,PROCESS_ACCOUNTING="no",PROCESS_ACCOUNTING="yes",g' \
+ script/bootchartd.conf
+ fi
+}
+
+src_compile() {
+ if use java ; then
+ local antflags="jar -Dcompiler.nowarn=true $(use_doc)"
+ use debug || antflags="${antflags} -Dbuild.debug=false"
+ eant ${antflags} \
+ -Dgentoo.classpath="$(java-pkg_getjars commons-cli-1):./build"
+ fi
+}
+
+src_install() {
+ dodoc README README.logger ChangeLog COPYING TODO
+
+ # No need for this with baselayout-2
+ if has_version "<sys-apps/baselayout-2"; then
+ insinto /$(get_libdir)/rcscripts/addons
+ doins "${FILESDIR}"/profiling-functions.sh
+ fi
+
+ into /
+ newsbin script/bootchartd bootchartd
+ into /usr
+
+ # This dir is normally empty, but is used to bind to the
+ # temporary dir bootchart normally makes. We do this so
+ # that our profiling script can write to a fixed location.
+ keepdir /lib/bootchart
+
+ insinto /etc
+ doins script/bootchartd.conf
+
+ if use java ; then
+ java-pkg_dojar "${PN}.jar"
+ use doc && java-pkg_dojavadoc javadoc/api
+ use source && java-pkg_dosrc src/org
+ java-pkg_dolauncher ${PN} \
+ --main org.bootchart.Main \
+ --java_args "-Djava.awt.headless=true"
+ fi
+}
+
+pkg_postinst() {
+ if has_version "<sys-apps/baselayout-2"; then
+ elog "To generate the chart, set RC_USE_BOOTCHART=\"yes\""
+ elog "in /etc/conf.d/rc and reboot"
+ else
+ elog "To generate the chart, append this to your kernel commandline"
+ elog " init=/sbin/bootchartd"
+ elog "and reboot"
+ fi
+ elog
+
+ if use java; then
+ elog "The chart will be saved as /var/log/bootchart.png"
+ else
+ elog "Post the file /var/log/bootchart.tgz here:"
+ elog " http://www.bootchart.org/download.html"
+ elog "to render the chart"
+ fi
+
+ elog
+ elog "For best results: "
+ elog " Enable BSD process accounting v3 in the kernel"
+ elog " This will produce more accurate process trees"
+ elog " Set AUTO_RENDER_FORMAT to svg in /etc/bootchartd.conf"
+ elog " and view /var/log/bootchart.svgz with batik or"
+ elog " Adobe SVG viewer. This will give you additional"
+ elog " information about the processes in tooltips"
+}
diff --git a/app-benchmarks/bootchart/files/bootchart-0.9-sh.patch b/app-benchmarks/bootchart/files/bootchart-0.9-sh.patch
new file mode 100644
index 000000000000..a923f5d52128
--- /dev/null
+++ b/app-benchmarks/bootchart/files/bootchart-0.9-sh.patch
@@ -0,0 +1,12 @@
+diff -ur a/script/bootchartd b/script/bootchartd
+--- a/script/bootchartd 2005-11-13 17:40:01.000000000 +0000
++++ b/script/bootchartd 2007-08-10 11:40:47.000000000 +0100
+@@ -101,7 +101,7 @@
+ # Write the time (in jiffies).
+ read uptime < /proc/uptime
+ uptime=${uptime%% [0-9]*}
+- uptime=${uptime/./}
++ uptime=${uptime%%.*}${uptime##*.}
+ echo $uptime
+
+ # Log the command output
diff --git a/app-benchmarks/bootchart/files/digest-bootchart-0.9-r2 b/app-benchmarks/bootchart/files/digest-bootchart-0.9-r2
new file mode 100644
index 000000000000..8488ebb31c32
--- /dev/null
+++ b/app-benchmarks/bootchart/files/digest-bootchart-0.9-r2
@@ -0,0 +1,3 @@
+MD5 4be91177d19069e21beeb106f2f77dff bootchart-0.9.tar.bz2 222558
+RMD160 c271bf634117c9bcd530055927abffead134b73a bootchart-0.9.tar.bz2 222558
+SHA256 7738399ecfcfb2242e9f99a316b13a5f59e89052de05074dbf705ccf4edc327d bootchart-0.9.tar.bz2 222558