summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-01-25 08:45:36 +0000
committerTim Harder <radhermit@gentoo.org>2014-01-25 08:45:36 +0000
commit2250b839c8488d0147fadd055214d8e59bba2ecb (patch)
tree90bd052cd3db005e23b71b307bc4e7e19a16500a /app-backup
parentRemove old. (diff)
downloadgentoo-2-2250b839c8488d0147fadd055214d8e59bba2ecb.tar.gz
gentoo-2-2250b839c8488d0147fadd055214d8e59bba2ecb.tar.bz2
gentoo-2-2250b839c8488d0147fadd055214d8e59bba2ecb.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/duplicity/ChangeLog9
-rw-r--r--app-backup/duplicity/duplicity-0.6.23.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/app-backup/duplicity/ChangeLog b/app-backup/duplicity/ChangeLog
index c2f9dd11bc55..2153869cda01 100644
--- a/app-backup/duplicity/ChangeLog
+++ b/app-backup/duplicity/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-backup/duplicity
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/ChangeLog,v 1.89 2013/11/24 18:45:05 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/ChangeLog,v 1.90 2014/01/25 08:45:36 radhermit Exp $
+
+*duplicity-0.6.23 (25 Jan 2014)
+
+ 25 Jan 2014; Tim Harder <radhermit@gentoo.org> +duplicity-0.6.23.ebuild:
+ Version bump.
24 Nov 2013; Agostino Sarubbo <ago@gentoo.org> duplicity-0.6.22.ebuild:
Stable for x86, wrt bug #481890
diff --git a/app-backup/duplicity/duplicity-0.6.23.ebuild b/app-backup/duplicity/duplicity-0.6.23.ebuild
new file mode 100644
index 000000000000..1bc607e8dcc6
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.6.23.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/duplicity-0.6.23.ebuild,v 1.1 2014/01/25 08:45:36 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="http://code.launchpad.net/${PN}/0.6-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3"
+
+DEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+"
+RDEPEND="${DEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ sed -i "s/'COPYING',//" setup.py || die "Couldn't remove unnecessary COPYING file."
+}
+
+pkg_postinst() {
+ einfo "Duplicity has many optional dependencies to support various backends."
+ einfo "Currently it's up to you to install them as necessary."
+}