summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-10-09 11:25:34 +0000
committerHans de Graaff <graaff@gentoo.org>2010-10-09 11:25:34 +0000
commit0cfd77732668c988041fd35484bcc6cb498abb6f (patch)
tree85e68467d336b94a67916ae8a7cc48acfe88b22e /app-backup/flexbackup
parentppc64 stable wrt #324077 (diff)
downloadgentoo-2-0cfd77732668c988041fd35484bcc6cb498abb6f.tar.gz
gentoo-2-0cfd77732668c988041fd35484bcc6cb498abb6f.tar.bz2
gentoo-2-0cfd77732668c988041fd35484bcc6cb498abb6f.zip
Update patch for perl 5.12 warnings as suggested by Paul Colquhoun in bug 333909.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-backup/flexbackup')
-rw-r--r--app-backup/flexbackup/ChangeLog10
-rw-r--r--app-backup/flexbackup/files/flexbackup-1.2.1-perl-5.12-deprecation-warning2.patch21
-rw-r--r--app-backup/flexbackup/flexbackup-1.2.1-r10.ebuild82
3 files changed, 112 insertions, 1 deletions
diff --git a/app-backup/flexbackup/ChangeLog b/app-backup/flexbackup/ChangeLog
index 112694b74f95..689d31e20a46 100644
--- a/app-backup/flexbackup/ChangeLog
+++ b/app-backup/flexbackup/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-backup/flexbackup
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/flexbackup/ChangeLog,v 1.31 2010/08/14 08:44:41 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/flexbackup/ChangeLog,v 1.32 2010/10/09 11:25:30 graaff Exp $
+
+*flexbackup-1.2.1-r10 (09 Oct 2010)
+
+ 09 Oct 2010; Hans de Graaff <graaff@gentoo.org>
+ +flexbackup-1.2.1-r10.ebuild,
+ +files/flexbackup-1.2.1-perl-5.12-deprecation-warning2.patch:
+ Update patch for perl 5.12 warnings as suggested by Paul Colquhoun in bug
+ 333909.
*flexbackup-1.2.1-r9 (14 Aug 2010)
diff --git a/app-backup/flexbackup/files/flexbackup-1.2.1-perl-5.12-deprecation-warning2.patch b/app-backup/flexbackup/files/flexbackup-1.2.1-perl-5.12-deprecation-warning2.patch
new file mode 100644
index 000000000000..80f8a6fcbc60
--- /dev/null
+++ b/app-backup/flexbackup/files/flexbackup-1.2.1-perl-5.12-deprecation-warning2.patch
@@ -0,0 +1,21 @@
+--- flexbackup.~1~ 2010-10-09 13:19:27.633694860 +0200
++++ flexbackup 2010-10-09 13:21:52.396818511 +0200
+@@ -133,6 +133,9 @@
+ # tar has a limit of this many chars in its volume label
+ $::tar_max_label = 99;
+
++# Define the prune hash to avoid warnings with perl 5.12
++use vars qw( %prune );
++
+ # Get commandline flags
+ %::opt = ();
+ if (! &::GetOptions(\%::opt,
+@@ -1050,7 +1053,7 @@
+ } else {
+ $prunekey = $dir;
+ }
+- if (defined(%{$::prune{$prunekey}})) {
++ if (defined($prune{$prunekey})) {
+ &log("| NOTE: \$prune is ignored for type=dump");
+ }
+
diff --git a/app-backup/flexbackup/flexbackup-1.2.1-r10.ebuild b/app-backup/flexbackup/flexbackup-1.2.1-r10.ebuild
new file mode 100644
index 000000000000..92cb226ecc76
--- /dev/null
+++ b/app-backup/flexbackup/flexbackup-1.2.1-r10.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/flexbackup/flexbackup-1.2.1-r10.ebuild,v 1.1 2010/10/09 11:25:34 graaff Exp $
+
+inherit eutils versionator
+
+DESCRIPTION="Flexible backup script using perl"
+HOMEPAGE="http://flexbackup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND="app-arch/mt-st"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Patch from upstream adds optional lzma compression mode.
+ epatch "${FILESDIR}"/${P}-lzma.patch
+
+ # Fix bug #116510: cannot back up remote machines after patch CAN-2005-2965
+ epatch "${FILESDIR}"/${P}-secure-tempfile.patch
+
+ # Fix bug #96334: incorrectly determines bash 3.x to be bash 1.x
+ epatch "${FILESDIR}"/${P}-bash.patch
+
+ # Fix bug #171205: specifies wrong command line option for mbuffer / other small enhancements
+ epatch "${FILESDIR}"/${P}-mbuffer-switch.patch
+
+ # Fix bug #173672: remote host buffer test is broken
+ epatch "${FILESDIR}"/${P}-remote-bufftest.patch
+
+ # Fix bug #178126: subtle subtree pruning issue / other small issues
+ epatch "${FILESDIR}"/${P}-prune.patch
+
+ # Fix bug #184560: fails to back up targets with spaces in their names in some modes
+ epatch "${FILESDIR}"/${P}-spaces-in-filenames.patch
+
+ # Fix bug #190357: fails on very large files with afio back end
+ epatch "${FILESDIR}"/${P}-afio-large-files.patch
+
+ # Fix bug #235416: prevent normal status message during conf file read from going to stderr
+ epatch "${FILESDIR}"/${P}-quieten.patch
+
+ # Fix bug #331673: perl 5.12 deprecation warnings.
+ epatch "${FILESDIR}"/${P}-perl-5.12-deprecation-warning2.patch
+
+ sed -i \
+ -e '/^\$type = /s:afio:tar:' \
+ -e "/^\$buffer = /s:'buffer':'false':" \
+ flexbackup.conf \
+ || die "Failed to set modified configuration defaults."
+
+ MY_PV=$(replace_all_version_separators '_')
+ sed -i \
+ -e "/^[[:blank:]]*my \$ver = /s:${MY_PV}:&-${PR}:" \
+ flexbackup \
+ || die "Failed to apply ebuild revision to internal version string."
+}
+
+src_install() {
+ dodir /etc /usr/bin /usr/share/man/man{1,5}
+ emake install \
+ PREFIX="${D}"/usr \
+ CONFFILE="${D}"/etc/flexbackup.conf \
+ || die "emake install failed"
+
+ dodoc CHANGES CREDITS README TODO
+ dohtml faq.html
+}
+
+pkg_postinst() {
+ elog "Please edit your /etc/flexbackup.conf file to suit your"
+ elog "needs. If you are using devfs, the tape device should"
+ elog "be set to /dev/tapes/tape0/mtn. If you need to use any"
+ elog "archiver other than tar, please emerge it separately."
+}