summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-01-24 03:08:18 +0000
committerTim Harder <radhermit@gentoo.org>2013-01-24 03:08:18 +0000
commitecda0a82b3e35571be5f3ccbff7a250724ab4986 (patch)
tree081484d7d78a9aee5e27d277d00c8c4ae76dd4a3 /app-backup/duplicity
parentMask broken dev-libs/libnl (bug #453736). (diff)
downloadgentoo-2-ecda0a82b3e35571be5f3ccbff7a250724ab4986.tar.gz
gentoo-2-ecda0a82b3e35571be5f3ccbff7a250724ab4986.tar.bz2
gentoo-2-ecda0a82b3e35571be5f3ccbff7a250724ab4986.zip
Version bump, migrate to distutils-r1.
(Portage version: 2.2.0_alpha155/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-backup/duplicity')
-rw-r--r--app-backup/duplicity/ChangeLog7
-rw-r--r--app-backup/duplicity/duplicity-0.6.21.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/app-backup/duplicity/ChangeLog b/app-backup/duplicity/ChangeLog
index 16d389b5ef73..88bbff209fa8 100644
--- a/app-backup/duplicity/ChangeLog
+++ b/app-backup/duplicity/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-backup/duplicity
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/ChangeLog,v 1.79 2013/01/22 17:28:36 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/ChangeLog,v 1.80 2013/01/24 03:08:18 radhermit Exp $
+
+*duplicity-0.6.21 (24 Jan 2013)
+
+ 24 Jan 2013; Tim Harder <radhermit@gentoo.org> +duplicity-0.6.21.ebuild:
+ Version bump, migrate to distutils-r1.
22 Jan 2013; Agostino Sarubbo <ago@gentoo.org> duplicity-0.6.20.ebuild:
Stable for x86, wrt bug #451634
diff --git a/app-backup/duplicity/duplicity-0.6.21.ebuild b/app-backup/duplicity/duplicity-0.6.21.ebuild
new file mode 100644
index 000000000000..6d2bf853cd47
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.6.21.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/duplicity-0.6.21.ebuild,v 1.1 2013/01/24 03:08:18 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="http://code.launchpad.net/${PN}/0.6-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3"
+
+DEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+"
+RDEPEND="${DEPEND}
+ dev-python/paramiko
+ >=dev-python/pexpect-2.1[${PYTHON_USEDEP}]
+ >=dev-python/py-gnupg-0.3.2
+ s3? ( dev-python/boto )
+"
+
+python_prepare_all() {
+ sed -i "s/'COPYING',//" setup.py || die "Couldn't remove unnecessary COPYING file."
+}