summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-31 13:11:26 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-31 13:11:26 +0000
commitfa2f71a25d7b5e699e619370db2ca6a0bb07e9c2 (patch)
treec536f73697ac4d0e540083d5126f10a9980fc8a2 /app-arch
parentinitial import (diff)
downloadgentoo-2-fa2f71a25d7b5e699e619370db2ca6a0bb07e9c2.tar.gz
gentoo-2-fa2f71a25d7b5e699e619370db2ca6a0bb07e9c2.tar.bz2
gentoo-2-fa2f71a25d7b5e699e619370db2ca6a0bb07e9c2.zip
handle openbsd CHOSTs as well
(Portage version: 2.1_pre3)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unzip/unzip-5.52-r1.ebuild3
-rw-r--r--app-arch/unzip/unzip-5.52.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/app-arch/unzip/unzip-5.52-r1.ebuild b/app-arch/unzip/unzip-5.52-r1.ebuild
index 38aa53ee72ff..ec0a8d78c493 100644
--- a/app-arch/unzip/unzip-5.52-r1.ebuild
+++ b/app-arch/unzip/unzip-5.52-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52-r1.ebuild,v 1.2 2005/12/31 12:53:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52-r1.ebuild,v 1.3 2005/12/31 13:11:26 vapier Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -36,6 +36,7 @@ src_compile() {
i?86*-linux*) TARGET=linux_asm ;;
*-linux*) TARGET=linux_noasm ;;
*-freebsd*) TARGET=freebsd ;;
+ *-openbsd*) TARGET=openbsd ;;
*-darwin*) TARGET=macosx ;;
*) die "Unknown target, you suck" ;;
esac
diff --git a/app-arch/unzip/unzip-5.52.ebuild b/app-arch/unzip/unzip-5.52.ebuild
index d91c1581a65a..b1771edfe6eb 100644
--- a/app-arch/unzip/unzip-5.52.ebuild
+++ b/app-arch/unzip/unzip-5.52.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52.ebuild,v 1.11 2005/12/31 12:53:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52.ebuild,v 1.12 2005/12/31 13:11:26 vapier Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -35,6 +35,7 @@ src_compile() {
i?86*-linux*) TARGET=linux_asm ;;
*-linux*) TARGET=linux_noasm ;;
*-freebsd*) TARGET=freebsd ;;
+ *-openbsd*) TARGET=openbsd ;;
*-darwin*) TARGET=macosx ;;
*) die "Unknown target, you suck" ;;
esac