summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-10-29 17:23:04 +0000
committerRoy Marples <uberlord@gentoo.org>2007-10-29 17:23:04 +0000
commit9cf53d67946c3af6194b02600248179a12dc8f70 (patch)
tree2d18e00a4865a991de4d1fc584920b00112e3046 /app-arch
parentSparc stable --- Bug #197346 --- has been good for quite some time. (diff)
downloadgentoo-2-9cf53d67946c3af6194b02600248179a12dc8f70.tar.gz
gentoo-2-9cf53d67946c3af6194b02600248179a12dc8f70.tar.bz2
gentoo-2-9cf53d67946c3af6194b02600248179a12dc8f70.zip
Bump and enable bsdcpio.
(Portage version: 2.1.3.16)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/libarchive/ChangeLog7
-rw-r--r--app-arch/libarchive/files/digest-libarchive-2.3.53
-rw-r--r--app-arch/libarchive/libarchive-2.3.5.ebuild83
3 files changed, 92 insertions, 1 deletions
diff --git a/app-arch/libarchive/ChangeLog b/app-arch/libarchive/ChangeLog
index b470f74f9bc0..181156417308 100644
--- a/app-arch/libarchive/ChangeLog
+++ b/app-arch/libarchive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/libarchive
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/ChangeLog,v 1.4 2007/10/10 09:41:44 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/ChangeLog,v 1.5 2007/10/29 17:23:03 uberlord Exp $
+
+*libarchive-2.3.5 (29 Oct 2007)
+
+ 29 Oct 2007; Roy Marples <uberlord@gentoo.org> +libarchive-2.3.5.ebuild:
+ Bump and enable bsdcpio.
*libarchive-2.3.4 (10 Oct 2007)
diff --git a/app-arch/libarchive/files/digest-libarchive-2.3.5 b/app-arch/libarchive/files/digest-libarchive-2.3.5
new file mode 100644
index 000000000000..e87677d28b29
--- /dev/null
+++ b/app-arch/libarchive/files/digest-libarchive-2.3.5
@@ -0,0 +1,3 @@
+MD5 954ed005e64c368d2ce890581b52b6fb libarchive-2.3.5.tar.gz 698478
+RMD160 0547786b802698b1f2a241c5dcb4bafcddda5477 libarchive-2.3.5.tar.gz 698478
+SHA256 a04cc5664cac8e4b4a0848901073ef21b03fca3ab63fb9d7d09993fc0791f055 libarchive-2.3.5.tar.gz 698478
diff --git a/app-arch/libarchive/libarchive-2.3.5.ebuild b/app-arch/libarchive/libarchive-2.3.5.ebuild
new file mode 100644
index 000000000000..a6ee235af702
--- /dev/null
+++ b/app-arch/libarchive/libarchive-2.3.5.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/libarchive-2.3.5.ebuild,v 1.1 2007/10/29 17:23:03 uberlord Exp $
+
+inherit eutils autotools toolchain-funcs flag-o-matic
+
+MY_P=${P/_beta/b}
+
+DESCRIPTION="BSD tar command"
+HOMEPAGE="http://people.freebsd.org/~kientzle/libarchive/"
+SRC_URI="http://people.freebsd.org/~kientzle/libarchive/src/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="build static acl xattr"
+
+RDEPEND="!dev-libs/libarchive
+ kernel_linux? (
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )
+ )
+ !static? ( !build? (
+ app-arch/bzip2
+ sys-libs/zlib ) )"
+DEPEND="${RDEPEND}
+ kernel_linux? ( sys-fs/e2fsprogs
+ virtual/os-headers )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-2.1.5-acl.patch
+
+ eautoreconf
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf=
+
+ if use static || use build ; then
+ myconf="${myconf} --enable-static-bsdtar"
+ else
+ myconf="${myconf} --disable-static-bsdtar"
+ fi
+
+ # Upstream doesn't seem to care to fix the problems
+ # and I don't want to continue running after them.
+ #append-flags -fno-strict-aliasing
+
+ econf \
+ --bindir=/bin \
+ --enable-bsdcpio \
+ $(use_enable acl) \
+ $(use_enable xattr) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ # Create tar symlink for FreeBSD
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ dosym bsdtar /bin/tar
+ dosym bsdtar.1 /usr/share/man/man1/tar.1
+ # We may wish to switch to symlink bsdcpio to cpio too one day
+ fi
+
+ if use build; then
+ rm -rf "${D}"/usr
+ rm -rf "${D}"/lib/*.so*
+ return 0
+ fi
+
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ gen_usr_ldscript libarchive.so
+}