summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-03-12 16:32:14 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-03-12 16:32:14 +0000
commit48ad19aa062d57a431b1de6136b1dd960c2dd0b8 (patch)
treecaf9f06128f5079941186b4214607662d7d57984 /app-arch
parentRemoved newer rdp patch from 9999 as it has been patched upstream. Fixes bug ... (diff)
downloadgentoo-2-48ad19aa062d57a431b1de6136b1dd960c2dd0b8.tar.gz
gentoo-2-48ad19aa062d57a431b1de6136b1dd960c2dd0b8.tar.bz2
gentoo-2-48ad19aa062d57a431b1de6136b1dd960c2dd0b8.zip
New ebuild for app-arch/mate-file-archiver, Engrampa archive manager for MATE; imported from the mate-overlay, reviewed and adjusted.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/mate-file-archiver/ChangeLog10
-rw-r--r--app-arch/mate-file-archiver/mate-file-archiver-1.6.1.ebuild89
-rw-r--r--app-arch/mate-file-archiver/metadata.xml13
3 files changed, 112 insertions, 0 deletions
diff --git a/app-arch/mate-file-archiver/ChangeLog b/app-arch/mate-file-archiver/ChangeLog
new file mode 100644
index 000000000000..3508be618b67
--- /dev/null
+++ b/app-arch/mate-file-archiver/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-arch/mate-file-archiver
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/mate-file-archiver/ChangeLog,v 1.1 2014/03/12 16:32:14 tomwij Exp $
+
+*mate-file-archiver-1.6.1 (12 Mar 2014)
+
+ 12 Mar 2014; Tom Wijsman <TomWij@gentoo.org> +mate-file-archiver-1.6.1.ebuild,
+ +metadata.xml:
+ New ebuild for app-arch/mate-file-archiver, Engrampa archive manager for MATE;
+ imported from the mate-overlay, reviewed and adjusted.
diff --git a/app-arch/mate-file-archiver/mate-file-archiver-1.6.1.ebuild b/app-arch/mate-file-archiver/mate-file-archiver-1.6.1.ebuild
new file mode 100644
index 000000000000..2f5d4fc4af67
--- /dev/null
+++ b/app-arch/mate-file-archiver/mate-file-archiver-1.6.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/mate-file-archiver/mate-file-archiver-1.6.1.ebuild,v 1.1 2014/03/12 16:32:14 tomwij Exp $
+
+EAPI="5"
+
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="Engrampa archive manager for MATE"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="caja"
+
+RDEPEND=">=x11-libs/gtk+-2.21.4:2
+ >=dev-libs/glib-2.25.5:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango:0
+ virtual/libintl:0
+ caja? ( >=mate-base/mate-file-manager-1.6:0 )"
+
+DEPEND="${RDEPEND}
+ >=app-text/mate-doc-utils-1.6:0
+ >=dev-util/intltool-0.35:*
+ >=mate-base/mate-common-1.6:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_prepare() {
+ # Fix some instalation paths.
+ sed -e 's|PACKAGE|PACKAGE_NAME|' -i \
+ src/commands/Makefile.am src/sh/Makefile.am || die
+
+ sed -e 's|$(pkgdatadir)|$(datadir)/$(PACKAGE_NAME)|' -i \
+ data/icons/16x16/actions/Makefile.am \
+ data/icons/24x24/actions/Makefile.am || die
+
+ eautoreconf
+
+ gnome2_src_prepare
+
+ # Drop DEPRECATED flags as configure option doesn't do it, bug #385453
+ sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' \
+ copy-n-paste/Makefile.am copy-n-paste/Makefile.in || die
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-run-in-place \
+ --disable-packagekit \
+ --disable-deprecations \
+ --with-gtk=2.0 \
+ $(use_enable caja caja-actions)
+}
+
+DOCS="AUTHORS HACKING MAINTAINERS NEWS README TODO"
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog ""
+ elog "${PN} is a frontend for several archiving utilities. If you want a"
+ elog "particular achive format supported install the relevant package."
+ elog
+ elog "For example:"
+ elog " 7-zip : emerge app-arch/p7zip"
+ elog " ace : emerge app-arch/unace"
+ elog " arj : emerge app-arch/arj"
+ elog " cpio : emerge app-arch/cpio"
+ elog " deb : emerge app-arch/dpkg"
+ elog " iso : emerge app-cdr/cdrtools"
+ elog " jar,zip : emerge app-arch/zip or emerge app-arch/unzip"
+ elog " lha : emerge app-arch/lha"
+ elog " lzma : emerge app-arch/xz-utils"
+ elog " lzop : emerge app-arch/lzop"
+ elog " rar : emerge app-arch/unrar"
+ elog " rpm : emerge app-arch/rpm"
+ elog " unstuff : emerge app-arch/stuffit"
+ elog " zoo : emerge app-arch/zoo"
+}
diff --git a/app-arch/mate-file-archiver/metadata.xml b/app-arch/mate-file-archiver/metadata.xml
new file mode 100644
index 000000000000..91262c10f902
--- /dev/null
+++ b/app-arch/mate-file-archiver/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>TomWij@gentoo.org</email>
+ <name>Tom Wijsman</name>
+ </maintainer>
+ <use>
+ <flag name="caja">Enable engrampa to integrate with
+ <pkg>mate-base/mate-file-manager</pkg> by providing entries in its
+ context menu</flag>
+ </use>
+</pkgmetadata>