summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-10-28 10:21:19 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-10-28 10:21:19 +0000
commit09caf5c7a712881d6a93d016226afd8f328ab547 (patch)
tree7a4e6e764e72bafd482e663096a7263f671b9252 /app-arch/xz-utils
parentMasked app-arch/xz-utils alpha releases for testing. (diff)
downloadgentoo-2-09caf5c7a712881d6a93d016226afd8f328ab547.tar.gz
gentoo-2-09caf5c7a712881d6a93d016226afd8f328ab547.tar.bz2
gentoo-2-09caf5c7a712881d6a93d016226afd8f328ab547.zip
Added alpha release (bug #484068)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'app-arch/xz-utils')
-rw-r--r--app-arch/xz-utils/ChangeLog8
-rw-r--r--app-arch/xz-utils/xz-utils-5.1.3_alpha.ebuild73
2 files changed, 80 insertions, 1 deletions
diff --git a/app-arch/xz-utils/ChangeLog b/app-arch/xz-utils/ChangeLog
index 13fdd5878533..260cf39fe335 100644
--- a/app-arch/xz-utils/ChangeLog
+++ b/app-arch/xz-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/xz-utils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/ChangeLog,v 1.65 2013/10/19 02:28:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/ChangeLog,v 1.66 2013/10/28 10:21:19 polynomial-c Exp $
+
+*xz-utils-5.1.3_alpha (28 Oct 2013)
+
+ 28 Oct 2013; Lars Wendler <polynomial-c@gentoo.org>
+ +xz-utils-5.1.3_alpha.ebuild:
+ Added alpha release as requested in bug #484068 by Christoph Junghans.
19 Oct 2013; Mike Frysinger <vapier@gentoo.org> xz-utils-5.0.5-r1.ebuild,
xz-utils-9999.ebuild:
diff --git a/app-arch/xz-utils/xz-utils-5.1.3_alpha.ebuild b/app-arch/xz-utils/xz-utils-5.1.3_alpha.ebuild
new file mode 100644
index 000000000000..7c52c8e4ef8e
--- /dev/null
+++ b/app-arch/xz-utils/xz-utils-5.1.3_alpha.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xz-utils/xz-utils-5.1.3_alpha.ebuild,v 1.1 2013/10/28 10:21:19 polynomial-c Exp $
+
+# Remember: we cannot leverage autotools in this ebuild in order
+# to avoid circular deps with autotools
+
+EAPI="4"
+
+inherit eutils multilib toolchain-funcs libtool multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="http://git.tukaani.org/xz.git"
+ inherit git-2 autotools
+ SRC_URI=""
+ EXTRA_DEPEND="sys-devel/gettext dev-vcs/cvs >=sys-devel/libtool-2" #272880 286068
+else
+ MY_P="${PN/-utils}-${PV/_}"
+ SRC_URI="http://tukaani.org/xz/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ S=${WORKDIR}/${MY_P}
+ EXTRA_DEPEND=
+fi
+
+DESCRIPTION="utils for managing LZMA compressed files"
+HOMEPAGE="http://tukaani.org/xz/"
+
+# See top-level COPYING file as it outlines the various pieces and their licenses.
+LICENSE="public-domain LGPL-2.1+ GPL-2+"
+SLOT="0"
+IUSE="nls static-libs +threads"
+
+RDEPEND="!<app-arch/lzma-4.63
+ !app-arch/lzma-utils
+ !<app-arch/p7zip-4.57"
+DEPEND="${RDEPEND}
+ ${EXTRA_DEPEND}"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ eautopoint
+ eautoreconf
+ else
+ elibtoolize # to allow building shared libs on Solaris/x64
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable nls) \
+ $(use_enable threads) \
+ $(use_enable static-libs static) \
+ $(multilib_is_native_abi || echo --disable-{xz,xzdec,lzmadec,lzmainfo,lzma-links,scripts})
+}
+
+multilib_src_install() {
+ default
+ multilib_is_native_abi && gen_usr_ldscript -a lzma
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --all
+ rm "${ED}"/usr/share/doc/xz/COPYING* || die
+ mv "${ED}"/usr/share/doc/{xz,${PF}} || die
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/liblzma$(get_libname 0)
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/liblzma$(get_libname 0)
+}