summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-13 08:11:00 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-13 08:11:00 +0000
commit0a9770fb3e9527fc284ef2a06bbdb0dc4c5c4859 (patch)
tree6e681b3adf19ce914dadad8d780ddc8792c3aaf6 /app-arch/unzip/unzip-5.52.ebuild
parentm68k (diff)
downloadgentoo-2-0a9770fb3e9527fc284ef2a06bbdb0dc4c5c4859.tar.gz
gentoo-2-0a9770fb3e9527fc284ef2a06bbdb0dc4c5c4859.tar.bz2
gentoo-2-0a9770fb3e9527fc284ef2a06bbdb0dc4c5c4859.zip
Version bump #84914 by Kenyon Ralph.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-arch/unzip/unzip-5.52.ebuild')
-rw-r--r--app-arch/unzip/unzip-5.52.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-arch/unzip/unzip-5.52.ebuild b/app-arch/unzip/unzip-5.52.ebuild
new file mode 100644
index 000000000000..27983c7ec996
--- /dev/null
+++ b/app-arch/unzip/unzip-5.52.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52.ebuild,v 1.1 2005/03/13 08:11:00 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Unzipper for pkzip-compressed files"
+HOMEPAGE="ftp://ftp.info-zip.org/pub/infozip/UnZip.html"
+SRC_URI="ftp://ftp.info-zip.org/pub/infozip/src/${PN}${PV/.}.tar.gz"
+
+LICENSE="Info-ZIP"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:-O3:${CFLAGS}:" \
+ -e "s:CC=gcc :CC=$(tc-getCC) :" \
+ -e "s:LD=gcc :LD=$(tc-getCC) :" \
+ -e "s:-O :${CFLAGS} :" \
+ unix/Makefile \
+ || die "sed unix/Makefile failed"
+}
+
+src_compile() {
+ use x86 \
+ && TARGET=linux \
+ || TARGET=linux_noasm
+ emake -f unix/Makefile ${TARGET} || die "emake failed"
+}
+
+src_install() {
+ dobin unzip funzip unzipsfx unix/zipgrep || die "dobin failed"
+ dosym unzip /usr/bin/zipinfo
+ doman man/*.1
+ dodoc BUGS History* README ToDo WHERE
+}