summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-02-24 03:54:35 +0000
committerTod Neidt <tod@gentoo.org>2002-02-24 03:54:35 +0000
commitec0ada41a03c264c9cb60eb97158f384bd981d81 (patch)
tree90a32658cef83bb2913275a1ddb3e6a5e5530bc7 /app-arch/unlzx
parentAdded proper catalog support (diff)
downloadgentoo-2-ec0ada41a03c264c9cb60eb97158f384bd981d81.tar.gz
gentoo-2-ec0ada41a03c264c9cb60eb97158f384bd981d81.tar.bz2
gentoo-2-ec0ada41a03c264c9cb60eb97158f384bd981d81.zip
Initial commit. unlzx decompresses Amiga LZX archives. Version 1.1 supports pipes :)
Note: there is no version # in the tarball name. Suggestions on how to handle this welcome.
Diffstat (limited to 'app-arch/unlzx')
-rw-r--r--app-arch/unlzx/ChangeLog13
-rw-r--r--app-arch/unlzx/files/digest-unlzx-1.12
-rw-r--r--app-arch/unlzx/unlzx-1.1.ebuild38
3 files changed, 53 insertions, 0 deletions
diff --git a/app-arch/unlzx/ChangeLog b/app-arch/unlzx/ChangeLog
new file mode 100644
index 000000000000..a8f81858da4a
--- /dev/null
+++ b/app-arch/unlzx/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unlzx/ChangeLog,v 1.1 2002/02/24 03:54:35 tod Exp $
+
+*unlzx-1.1 (23 Feb 2002)
+
+ 23 Feb 2002; T.Neidt <tod@gentoo.org> ChangeLog, unlzx-1.1.ebuild, digest-unlzx-1.1 :
+
+ Initial commit. Unlzx decompresses Amiga LZX archives.
+ Version 1.1 supports pipes.
+ Thanks to Per Wigren for the contribution.
+ Note: there is no version in the tarball name.
+ Suggestion on how to handle this welcome.
diff --git a/app-arch/unlzx/files/digest-unlzx-1.1 b/app-arch/unlzx/files/digest-unlzx-1.1
new file mode 100644
index 000000000000..2341baff7de7
--- /dev/null
+++ b/app-arch/unlzx/files/digest-unlzx-1.1
@@ -0,0 +1,2 @@
+MD5 aba223c26019d84fad0a1eed109bc628 unlzx.c.gz 9680
+MD5 750e746bdc53d61d00b5f4fb0b4da5b6 unlzx.c.gz.readme 642
diff --git a/app-arch/unlzx/unlzx-1.1.ebuild b/app-arch/unlzx/unlzx-1.1.ebuild
new file mode 100644
index 000000000000..d306573bd686
--- /dev/null
+++ b/app-arch/unlzx/unlzx-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Per Wigren <wigren@home.se>
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unlzx/unlzx-1.1.ebuild,v 1.1 2002/02/24 03:54:35 tod Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Unarchiver for Amiga LZX archives"
+
+#This site is listed as the master site in NetBSD makefile
+SRC_URI="ftp://us.aminet.net/pub/aminet/misc/unix/${PN}.c.gz ftp://us.aminet.net/pub/aminet/misc/unix/${PN}.c.gz.readme"
+
+#For lack of anything better
+HOMEPAGE="ftp://us.aminet.net/pub/aminet/misc/unix/${PN}.c.gz.readme"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+
+ mkdir ${S}
+ gzip -dc ${DISTDIR}/${PN}.c.gz > ${S}/unlzx.c
+ cp ${DISTDIR}/${PN}.c.gz.readme ${S}/${PN}.c.gz.readme
+
+}
+
+src_compile() {
+
+ gcc ${CFLAGS} -o unlzx unlzx.c
+
+}
+
+src_install () {
+
+ dobin unlzx
+
+ dodoc unlzx.c.gz.readme
+
+}