summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-07-06 04:21:44 +0000
committerMike Frysinger <vapier@gentoo.org>2012-07-06 04:21:44 +0000
commit0f6ea85b39d9739a0afd3b191260d8278fdfa774 (patch)
tree6b0960c1dfdc13108a66447b73c92214ad7b2c5e /app-arch/sharutils
parentFix building with glibc-2.16 #424974 by Stevan Bajić. (diff)
downloadgentoo-2-0f6ea85b39d9739a0afd3b191260d8278fdfa774.tar.gz
gentoo-2-0f6ea85b39d9739a0afd3b191260d8278fdfa774.tar.bz2
gentoo-2-0f6ea85b39d9739a0afd3b191260d8278fdfa774.zip
Fix building with glibc-2.16 #424994 by Stevan Bajić.
(Portage version: 2.2.0_alpha115/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/sharutils')
-rw-r--r--app-arch/sharutils/ChangeLog6
-rw-r--r--app-arch/sharutils/files/sharutils-4.11.1-no-gets.patch24
-rw-r--r--app-arch/sharutils/sharutils-4.11.1.ebuild6
3 files changed, 34 insertions, 2 deletions
diff --git a/app-arch/sharutils/ChangeLog b/app-arch/sharutils/ChangeLog
index 56d696a71f60..9eeb87af6269 100644
--- a/app-arch/sharutils/ChangeLog
+++ b/app-arch/sharutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/sharutils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/sharutils/ChangeLog,v 1.85 2012/02/13 09:58:36 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/sharutils/ChangeLog,v 1.86 2012/07/06 04:21:44 vapier Exp $
+
+ 06 Jul 2012; Mike Frysinger <vapier@gentoo.org>
+ +files/sharutils-4.11.1-no-gets.patch, sharutils-4.11.1.ebuild:
+ Fix building with glibc-2.16 #424994 by Stevan Bajić.
13 Feb 2012; Kacper Kowalik <xarthisius@gentoo.org> sharutils-4.11.1.ebuild:
ppc64 stable wrt #396763
diff --git a/app-arch/sharutils/files/sharutils-4.11.1-no-gets.patch b/app-arch/sharutils/files/sharutils-4.11.1-no-gets.patch
new file mode 100644
index 000000000000..82f44b8ac771
--- /dev/null
+++ b/app-arch/sharutils/files/sharutils-4.11.1-no-gets.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/424994
+
+hack until sharutils pulls a newer gnulib version
+
+From 66712c23388e93e5c518ebc8515140fa0c807348 Mon Sep 17 00:00:00 2001
+From: Eric Blake <eblake@redhat.com>
+Date: Thu, 29 Mar 2012 13:30:41 -0600
+Subject: [PATCH] stdio: don't assume gets any more
+
+Gnulib intentionally does not have a gets module, and now that C11
+and glibc have dropped it, we should be more proactive about warning
+any user on a platform that still has a declaration of this dangerous
+interface.
+
+--- a/lib/stdio.in.h
++++ b/lib/stdio.in.h
+@@ -125,7 +125,6 @@
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ #undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@
diff --git a/app-arch/sharutils/sharutils-4.11.1.ebuild b/app-arch/sharutils/sharutils-4.11.1.ebuild
index 6d18b2085600..204f956640e2 100644
--- a/app-arch/sharutils/sharutils-4.11.1.ebuild
+++ b/app-arch/sharutils/sharutils-4.11.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/sharutils/sharutils-4.11.1.ebuild,v 1.8 2012/02/13 09:58:36 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/sharutils/sharutils-4.11.1.ebuild,v 1.9 2012/07/06 04:21:44 vapier Exp $
EAPI="2"
@@ -22,6 +22,10 @@ RDEPEND=""
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-gets.patch #424994
+}
+
src_configure() {
strip-linguas -u po
econf $(use_enable nls)