summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2006-08-06 14:44:34 +0000
committerSeemant Kulleen <seemant@gentoo.org>2006-08-06 14:44:34 +0000
commitc7a32bcfab60420b7534cbb56ca03b895a4a7049 (patch)
treeb5f8f4f4539d235cf9a11a8c42b61bea1860e1e5 /app-arch/ipkg-utils
parentStable on alpha and amd64. (diff)
downloadgentoo-2-c7a32bcfab60420b7534cbb56ca03b895a4a7049.tar.gz
gentoo-2-c7a32bcfab60420b7534cbb56ca03b895a4a7049.tar.bz2
gentoo-2-c7a32bcfab60420b7534cbb56ca03b895a4a7049.zip
Some cleanups from James in bug #142980. Also, explicitly setting RDEPEND
(Portage version: 2.1.1_pre4-r3)
Diffstat (limited to 'app-arch/ipkg-utils')
-rw-r--r--app-arch/ipkg-utils/ChangeLog6
-rw-r--r--app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild21
-rw-r--r--app-arch/ipkg-utils/ipkg-utils-1.7.ebuild21
3 files changed, 37 insertions, 11 deletions
diff --git a/app-arch/ipkg-utils/ChangeLog b/app-arch/ipkg-utils/ChangeLog
index f222cd49df54..0d31f75d16cc 100644
--- a/app-arch/ipkg-utils/ChangeLog
+++ b/app-arch/ipkg-utils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/ipkg-utils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ChangeLog,v 1.7 2006/07/12 12:05:30 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ChangeLog,v 1.8 2006/08/06 14:44:34 seemant Exp $
+
+ 06 Aug 2006; Seemant Kulleen <seemant@gentoo.org> ipkg-utils-1.7.ebuild,
+ ipkg-utils-1.7.050831.ebuild:
+ Some cleanups from James in bug #142980. Also, explicitly setting RDEPEND
*ipkg-utils-1.7.050831 (12 Jul 2006)
diff --git a/app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild b/app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild
index dfa3208f6b71..e1a1b40618f7 100644
--- a/app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild
+++ b/app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild,v 1.1 2006/07/12 12:05:30 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild,v 1.2 2006/08/06 14:44:34 seemant Exp $
inherit distutils eutils toolchain-funcs versionator
@@ -10,17 +10,28 @@ DESCRIPTION="Tools for working with the ipkg binary package format"
HOMEPAGE="http://www.openembedded.org/"
SRC_URI="http://handhelds.org/download/packages/ipkg-utils/${MY_P}.tar.gz"
LICENSE="GPL-2"
-IUSE=""
+IUSE="minimal"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~x86"
S=${WORKDIR}/${MY_P}
-DEPEND="dev-lang/python"
+RDEPEND="dev-lang/python
+ !minimal? (
+ app-crypt/gnupg
+ net-misc/curl
+ )"
+
+DEPEND="${RDEPEND}"
src_unpack() {
unpack ${A}; cd ${S}
- epatch ${FILESDIR}/${PN}-1.7-build_fixes.patch
+ sed '/python setup.py build/d' -i Makefile
+
+ if use minimal; then
+ einfo "ipkg-upload is not installed when the \`minimal' USE flag is set. If you"
+ einfo "need ipkg-upload then rebuild this package without the \`minimal' USE flag."
+ fi
}
src_compile() {
@@ -30,7 +41,7 @@ src_compile() {
src_install() {
distutils_src_install
- make DESTDIR=${D} install || die
+ use minimal && rm ${D}/usr/bin/ipkg-upload
}
pkg_postinst() {
diff --git a/app-arch/ipkg-utils/ipkg-utils-1.7.ebuild b/app-arch/ipkg-utils/ipkg-utils-1.7.ebuild
index a5cd0bad8183..5653d32f7752 100644
--- a/app-arch/ipkg-utils/ipkg-utils-1.7.ebuild
+++ b/app-arch/ipkg-utils/ipkg-utils-1.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ipkg-utils-1.7.ebuild,v 1.6 2006/07/01 16:06:06 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ipkg-utils-1.7.ebuild,v 1.7 2006/08/06 14:44:34 seemant Exp $
inherit distutils eutils toolchain-funcs
@@ -8,16 +8,27 @@ DESCRIPTION="Tools for working with the ipkg binary package format"
HOMEPAGE="http://www.openembedded.org/"
SRC_URI="http://handhelds.org/download/packages/ipkg-utils/${P}.tar.gz"
LICENSE="GPL-2"
-IUSE=""
+IUSE="minimal"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~x86"
-DEPEND="dev-lang/python"
+RDEPEND="dev-lang/python
+ !minimal? (
+ app-crypt/gnupg
+ net-misc/curl
+ )"
+
+DEPEND="${RDEPEND}"
src_unpack() {
unpack ${A}; cd ${S}
- epatch ${FILESDIR}/${P}-build_fixes.patch
+ sed '/python setup.py build/d' -i Makefile
+
+ if use minimal; then
+ einfo "ipkg-upload is not installed when the \`minimal' USE flag is set. If you"
+ einfo "need ipkg-upload then rebuild this package without the \`minimal' USE flag."
+ fi
}
src_compile() {
@@ -27,5 +38,5 @@ src_compile() {
src_install() {
distutils_src_install
- make DESTDIR=${D} install || die
+ use minimal && rm ${D}/usr/bin/ipkg-upload
}