summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-02-20 20:01:23 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-02-20 20:01:23 +0000
commit6a079263b03697238777c9534a0987ccccbf3fc0 (patch)
tree679474169652e0c308dfef9df1677258befafdfd /app-arch/gzip
parentAdded ~ppc wrt bug 207343 (diff)
downloadgentoo-2-6a079263b03697238777c9534a0987ccccbf3fc0.tar.gz
gentoo-2-6a079263b03697238777c9534a0987ccccbf3fc0.tar.bz2
gentoo-2-6a079263b03697238777c9534a0987ccccbf3fc0.zip
fix PATH in gunzip. bug #210871
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-arch/gzip')
-rw-r--r--app-arch/gzip/ChangeLog9
-rw-r--r--app-arch/gzip/gzip-1.3.12-r1.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/app-arch/gzip/ChangeLog b/app-arch/gzip/ChangeLog
index 4a4bb48db360..e780d536a582 100644
--- a/app-arch/gzip/ChangeLog
+++ b/app-arch/gzip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/gzip
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/ChangeLog,v 1.94 2007/07/20 16:34:15 uberlord Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/ChangeLog,v 1.95 2008/02/20 20:01:23 cardoe Exp $
+
+*gzip-1.3.12-r1 (20 Feb 2008)
+
+ 20 Feb 2008; Doug Klima <cardoe@gentoo.org> +gzip-1.3.12-r1.ebuild:
+ fix PATH in gunzip. bug #210871
20 Jul 2007; Roy Marples <uberlord@gentoo.org> gzip-1.3.12.ebuild:
Keyworded ~sparc-fbsd.
diff --git a/app-arch/gzip/gzip-1.3.12-r1.ebuild b/app-arch/gzip/gzip-1.3.12-r1.ebuild
new file mode 100644
index 000000000000..2e1da2d906af
--- /dev/null
+++ b/app-arch/gzip/gzip-1.3.12-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.12-r1.ebuild,v 1.1 2008/02/20 20:01:23 cardoe Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Standard GNU compressor"
+HOMEPAGE="http://www.gnu.org/software/gzip/"
+SRC_URI="ftp://alpha.gnu.org/gnu/gzip/${P}.tar.gz
+ mirror://gnu/gzip/${P}.tar.gz
+ mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls static pic"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+PROVIDE="virtual/gzip"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #epatch "${FILESDIR}"/${PN}-1.3.5-rsync.patch
+ epatch "${FILESDIR}"/gnulib-futimens-rename.patch
+ epatch "${FILESDIR}"/${PN}-1.3.8-install-symlinks.patch
+ sed -i 's:\<futimens\>:gl_futimens:' gzip.c
+}
+
+src_compile() {
+ use static && append-flags -static
+ # avoid text relocation in gzip
+ use pic && export DEFS="NO_ASM"
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog NEWS README THANKS TODO
+ docinto txt
+ dodoc algorithm.doc gzip.doc
+
+ # keep most things in /usr, just the fun stuff in /
+ dodir /bin
+ mv "${D}"/usr/bin/{gunzip,gzip,uncompress,zcat} "${D}"/bin/ || die
+ sed -e 's:/usr::' -i "${D}"/bin/gunzip || die
+}