summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-05-23 08:01:26 +0000
committerPeter Volkov <pva@gentoo.org>2011-05-23 08:01:26 +0000
commit1f05b5ccc2b5f055d1f7ad95c5d439f12c79e46e (patch)
tree99009ed77ae4ec7b7ed5375074d7fd8e3220ab4e /app-arch/dump
parentFix libutp related build issue, bug #368187 thank thomasg for this fix. Drop ... (diff)
downloadgentoo-2-1f05b5ccc2b5f055d1f7ad95c5d439f12c79e46e.tar.gz
gentoo-2-1f05b5ccc2b5f055d1f7ad95c5d439f12c79e46e.tar.bz2
gentoo-2-1f05b5ccc2b5f055d1f7ad95c5d439f12c79e46e.zip
Version bump. Fixes build with USE=static. Fixes dodoc called on a directory, #367885 thank Diego Elio Pettenò for report.
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/dump')
-rw-r--r--app-arch/dump/ChangeLog13
-rw-r--r--app-arch/dump/dump-0.4.43.ebuild64
-rw-r--r--app-arch/dump/files/dump-0.4b43-pkg_config4blkid.patch27
-rw-r--r--app-arch/dump/files/dump-0.4b43-pkg_config4crypto.patch50
-rw-r--r--app-arch/dump/files/dump-0.4b43-pkg_config4ext2fs.patch40
5 files changed, 192 insertions, 2 deletions
diff --git a/app-arch/dump/ChangeLog b/app-arch/dump/ChangeLog
index 3087c2d8da7c..ba7021689340 100644
--- a/app-arch/dump/ChangeLog
+++ b/app-arch/dump/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-arch/dump
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/ChangeLog,v 1.60 2009/09/30 03:14:08 vapier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/ChangeLog,v 1.61 2011/05/23 08:01:26 pva Exp $
+
+*dump-0.4.43 (23 May 2011)
+
+ 23 May 2011; Peter Volkov <pva@gentoo.org>
+ +files/dump-0.4b43-pkg_config4blkid.patch,
+ +files/dump-0.4b43-pkg_config4crypto.patch,
+ +files/dump-0.4b43-pkg_config4ext2fs.patch, +dump-0.4.43.ebuild:
+ Version bump. Fixes build with USE=static. Fixes dodoc called on a directory,
+ #367885 thank Diego Elio Pettenò for report.
*dump-0.4.42 (30 Sep 2009)
diff --git a/app-arch/dump/dump-0.4.43.ebuild b/app-arch/dump/dump-0.4.43.ebuild
new file mode 100644
index 000000000000..9bc31df3cef1
--- /dev/null
+++ b/app-arch/dump/dump-0.4.43.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/dump-0.4.43.ebuild,v 1.1 2011/05/23 08:01:26 pva Exp $
+
+EAPI="4"
+inherit eutils autotools
+
+MY_P=${P/4./4b}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Dump/restore ext2fs backup utilities"
+HOMEPAGE="http://dump.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dump/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug ermt readline selinux static"
+
+RDEPEND=">=sys-fs/e2fsprogs-1.27
+ >=app-arch/bzip2-1.0.2
+ >=sys-libs/zlib-1.1.4
+ ermt? ( dev-libs/openssl )
+ readline? ( sys-libs/readline
+ sys-libs/ncurses
+ static? ( sys-libs/ncurses[static-libs] ) )"
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+src_prepare() {
+ # https://sourceforge.net/tracker/?func=detail&aid=3306159&group_id=1306&atid=301306
+ epatch "${FILESDIR}/dump-0.4b43-pkg_config4blkid.patch"
+ epatch "${FILESDIR}/dump-0.4b43-pkg_config4ext2fs.patch"
+ epatch "${FILESDIR}/dump-0.4b43-pkg_config4crypto.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-dumpdatespath=/etc/dumpdates \
+ --with-{bin,man}owner=root \
+ --with-{bin,man}grp=root \
+ --enable-largefile \
+ $(use_enable selinux transselinux) \
+ $(use_enable ermt) \
+ $(use_enable static) \
+ $(use_enable readline) \
+ $(use_enable debug)
+}
+
+src_install() {
+ # built on old autotools, no DESTDIR support
+ einstall MANDIR="${D}"/usr/share/man/man8
+ mv "${ED}"/usr/sbin/{,dump-}rmt || die
+ mv "${ED}"/usr/share/man/man8/{,dump-}rmt.8 || die
+ use ermt && newsbin rmt/ermt dump-ermt
+
+ dodoc CHANGES KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
+ dodoc -r examples/*
+}
+
+pkg_postinst() {
+ ewarn "app-arch/dump installs 'rmt' as 'dump-rmt'."
+ ewarn "This is to avoid conflicts with app-arch/tar 'rmt'."
+}
diff --git a/app-arch/dump/files/dump-0.4b43-pkg_config4blkid.patch b/app-arch/dump/files/dump-0.4b43-pkg_config4blkid.patch
new file mode 100644
index 000000000000..ad109189ea31
--- /dev/null
+++ b/app-arch/dump/files/dump-0.4b43-pkg_config4blkid.patch
@@ -0,0 +1,27 @@
+=== modified file 'configure.in'
+--- configure.in 2011-05-20 04:40:59 +0000
++++ configure.in 2011-05-20 05:12:18 +0000
+@@ -465,11 +465,17 @@
+ dnl Check for blkid headers libraries
+ dnl
+ AC_CHECK_HEADER(blkid/blkid.h, [blkid_h=yes], [blkid_h=no], [-])
+-AC_CHECK_LIB(blkid, blkid_get_devname, [blkid_lib=yes], [blkid_lib=no], [-luuid])
+-if test "$blkid_h" = yes -a "$blkid_lib" = yes; then
+- AC_DEFINE([HAVE_BLKID],1,[Define this if you have the blkid library.])
+- BLKID="-lblkid -luuid"
+-fi
++PKG_CHECK_EXISTS([blkid],
++ [
++ if test -n $STATIC ; then
++ BLKID=`$PKG_CONFIG --libs --static blkid`
++ else
++ BLKID=`$PKG_CONFIG --libs blkid`
++ fi
++ if test "$blkid_h" = yes ; then
++ AC_DEFINE([HAVE_BLKID],1,[Define this if you have the blkid library.])
++ fi
++ ],[BLKID=""])
+ AC_SUBST(BLKID)
+
+ dnl
+
diff --git a/app-arch/dump/files/dump-0.4b43-pkg_config4crypto.patch b/app-arch/dump/files/dump-0.4b43-pkg_config4crypto.patch
new file mode 100644
index 000000000000..d126cf150039
--- /dev/null
+++ b/app-arch/dump/files/dump-0.4b43-pkg_config4crypto.patch
@@ -0,0 +1,50 @@
+=== modified file 'configure.in'
+--- configure.in 2011-05-20 09:47:25 +0000
++++ configure.in 2011-05-20 09:51:37 +0000
+@@ -113,7 +113,6 @@
+ if test "$enableval" = "no"
+ then
+ ERMT=""
+- CRYPTO=""
+ echo "Not compiling ermt"
+ else
+ if test "$RMTDIR" = ""
+@@ -121,16 +120,13 @@
+ AC_MSG_ERROR(ermt requires --enable-rmt)
+ fi
+ ERMT="ermt"
+- CRYPTO="-lcrypto"
+ echo "Compiling ermt"
+ fi
+ ,
+ ERMT=""
+-CRYPTO=""
+ echo "Not compiling ermt by default"
+ )
+ AC_SUBST(ERMT)
+-AC_SUBST(CRYPTO)
+
+ dnl
+ dnl Handle --enable-kerberos
+@@ -600,10 +596,19 @@
+ if test "$ERMT" != ""; then
+ AC_CHECK_HEADER(openssl/evp.h, [evp_h=yes], [evp_h=no])
+ AC_CHECK_LIB(crypto, EVP_CIPHER_CTX_set_padding, [crypto_lib=yes], [crypto_lib=no])
+- if test "$evp_h" = no -o "$crypto_lib" = no; then
++ PKG_CHECK_EXISTS([libcrypto],
++ [
++ if test -n $STATIC ; then
++ CRYPTO=`$PKG_CONFIG --libs --static libcrypto`
++ else
++ CRYPTO=`$PKG_CONFIG --libs libcrypto`
++ fi
++ ],[CRYPTO=""])
++ if test "$evp_h" = no -o "x$CRYPTO" = "x"; then
+ AC_MSG_ERROR(You need to install the OpenSSL library (version 0.9.7a or later), or configure without --enable-ermt)
+ fi
+ fi
++AC_SUBST(CRYPTO)
+
+ dnl
+ dnl Check for types
+
diff --git a/app-arch/dump/files/dump-0.4b43-pkg_config4ext2fs.patch b/app-arch/dump/files/dump-0.4b43-pkg_config4ext2fs.patch
new file mode 100644
index 000000000000..11ccab9ca20d
--- /dev/null
+++ b/app-arch/dump/files/dump-0.4b43-pkg_config4ext2fs.patch
@@ -0,0 +1,40 @@
+=== modified file 'MCONFIG.in'
+--- MCONFIG.in 2011-05-20 04:40:59 +0000
++++ MCONFIG.in 2011-05-20 06:57:11 +0000
+@@ -32,7 +32,7 @@
+ GINC= -I$(top_builddir) -I$(top_srcdir)/compat/include
+ # indicate where the ext2fs library can be found (this is not needed if you
+ # have run `make install-libs' in the e2fsprogs source directory).
+-#GINC+= -I/usr/src/e2fsprogs-0.5c/lib
++GINC+= @EXT2FS_CFLAGS@
+
+ #
+ # Global libraries
+@@ -40,7 +40,7 @@
+ # indicate where the ext2fs library can be found (this is not needed if you
+ # have run `make install-libs' in the e2fsprogs source directory).
+ #GLIBDIR= -L/usr/src/e2fsprogs-0.5c/lib
+-GLIBS= $(GLIBDIR) -L../compat/lib -lcompat -lext2fs -lcom_err
++GLIBS= $(GLIBDIR) -L../compat/lib -lcompat @EXT2FS_LIBS@
+
+ #
+ # Definitions (don't change them unless you know what you are doing)
+
+=== modified file 'configure.in'
+--- configure.in 2011-05-20 05:16:23 +0000
++++ configure.in 2011-05-20 07:01:17 +0000
+@@ -411,8 +411,11 @@
+ dnl Check for Ext2fs headers and libraries
+ dnl
+ AC_CHECK_HEADER(ext2fs/ext2fs.h, [ext2fs_h=yes], [ext2fs_h=no], [-])
+-AC_CHECK_LIB(ext2fs, ext2fs_open, [ext2fs_lib=yes], [ext2fs_lib=no], [-lcom_err])
+-if test "$ext2fs_h" = no -o "$ext2fs_lib" = no; then
++PKG_CHECK_MODULES(EXT2FS, [ext2fs])
++if test -n "$STATIC" ; then
++ EXT2FS_LIBS=`$PKG_CONFIG --libs --static ext2fs`
++fi
++if test "$ext2fs_h" = no -o "x$EXT2FS_LIBS" = "x"; then
+ AC_MSG_ERROR(You need to install the Ext2fs libraries from the E2fsprogs distribution first - hint: make install-libs)
+ fi
+
+