summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-07-21 13:18:21 +0000
committerJeroen Roovers <jer@gentoo.org>2012-07-21 13:18:21 +0000
commit82974b598485613df8513efdc0afaa188d252474 (patch)
tree7d97a6fea23b6197f824a191d7b4ab942e56d1a2 /app-arch/dpkg
parentFix namespacing of introspection annotations, bug #426984 by Flo Gravo and Ra... (diff)
downloadgentoo-2-82974b598485613df8513efdc0afaa188d252474.tar.gz
gentoo-2-82974b598485613df8513efdc0afaa188d252474.tar.bz2
gentoo-2-82974b598485613df8513efdc0afaa188d252474.zip
Version bump.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/dpkg')
-rw-r--r--app-arch/dpkg/ChangeLog10
-rw-r--r--app-arch/dpkg/dpkg-1.16.0.3.ebuild93
-rw-r--r--app-arch/dpkg/dpkg-1.16.1.1.ebuild92
-rw-r--r--app-arch/dpkg/dpkg-1.16.1.2.ebuild92
-rw-r--r--app-arch/dpkg/dpkg-1.16.8.ebuild (renamed from app-arch/dpkg/dpkg-1.16.1.ebuild)37
-rw-r--r--app-arch/dpkg/files/dpkg-1.15.5.6-bootstrap.patch23
-rw-r--r--app-arch/dpkg/files/dpkg-1.16.1-bootstrap.patch23
7 files changed, 27 insertions, 343 deletions
diff --git a/app-arch/dpkg/ChangeLog b/app-arch/dpkg/ChangeLog
index fc163fb97b8f..2c63e551fe19 100644
--- a/app-arch/dpkg/ChangeLog
+++ b/app-arch/dpkg/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-arch/dpkg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.194 2012/07/08 15:33:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.195 2012/07/21 13:18:20 jer Exp $
+
+*dpkg-1.16.8 (21 Jul 2012)
+
+ 21 Jul 2012; Jeroen Roovers <jer@gentoo.org>
+ -files/dpkg-1.15.5.6-bootstrap.patch, -dpkg-1.16.0.3.ebuild,
+ -dpkg-1.16.1.ebuild, -dpkg-1.16.1.1.ebuild, -dpkg-1.16.1.2.ebuild,
+ -files/dpkg-1.16.1-bootstrap.patch, +dpkg-1.16.8.ebuild:
+ Version bump.
08 Jul 2012; Raúl Porcel <armin76@gentoo.org> dpkg-1.16.2.ebuild:
alpha/arm/ia64/m68k/s390/sh/sparc stable wrt #413887
diff --git a/app-arch/dpkg/dpkg-1.16.0.3.ebuild b/app-arch/dpkg/dpkg-1.16.0.3.ebuild
deleted file mode 100644
index 2ea6f5bc0af4..000000000000
--- a/app-arch/dpkg/dpkg-1.16.0.3.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.16.0.3.ebuild,v 1.9 2012/05/03 01:58:53 jdhore Exp $
-
-EAPI=3
-
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="bzip2 dselect nls test unicode zlib"
-
-LANGS="
- ast bs ca cs da de dz el eo es et eu fr gl hu id it ja km ko ku lt mr nb ne
- nl nn pa pl pt_BR pt ro ru sk sv th tl vi zh_CN zh_TW
-"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-RDEPEND=">=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/flex
- nls? ( app-text/po4a )
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.15.5.6-bootstrap.patch
-
- # don't mess with linker optimisation, respect user's flags (don't break!)
- sed -i -e '/DPKG_LINKER_OPTIMISATIONS/d' configure.ac || die
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- local myconf
- if use nls; then
- myconf="--enable-nls $(use_with dselect)"
- else
- if use dselect; then
- elog "Building dselect requires USE=nls - disabling USE=dselect..."
- fi
- myconf="--disable-nls --without-dselect"
- fi
- econf \
- ${myconf} \
- $(use_with bzip2 bz2) \
- $(use_enable unicode) \
- $(use_with zlib) \
- --disable-compiler-warnings \
- --without-selinux \
- --without-start-stop-daemon
-}
-
-src_install() {
- strip-linguas ${LANGS}
- if [ -z "${LINGUAS}" ] ; then
- LINGUAS=none
- fi
-
- emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
- rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
- dodoc ChangeLog THANKS TODO
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/dpkg-1.16.1.1.ebuild b/app-arch/dpkg/dpkg-1.16.1.1.ebuild
deleted file mode 100644
index 1c90cdfac66c..000000000000
--- a/app-arch/dpkg/dpkg-1.16.1.1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.16.1.1.ebuild,v 1.4 2012/05/03 01:58:53 jdhore Exp $
-
-EAPI=3
-
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="bzip2 dselect nls test unicode zlib"
-
-LANGS="
- ast bs ca cs da de dz el eo es et eu fr gl hu id it ja km ko ku lt mr nb ne
- nl nn pa pl pt_BR pt ro ru sk sv th tl vi zh_CN zh_TW
-"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-RDEPEND=">=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- sys-devel/flex
- virtual/pkgconfig
- nls? ( app-text/po4a )
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )"
-
-src_prepare() {
- # don't mess with linker optimisation, respect user's flags (don't break!)
- sed -i -e '/DPKG_LINKER_OPTIMISATIONS/d' configure.ac || die
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- epatch "${FILESDIR}"/${PN}-1.16.1-bootstrap.patch
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- local myconf
- if use nls; then
- myconf="--enable-nls $(use_with dselect)"
- else
- if use dselect; then
- elog "Building dselect requires USE=nls - disabling USE=dselect..."
- fi
- myconf="--disable-nls --without-dselect"
- fi
- econf \
- ${myconf} \
- $(use_with bzip2 bz2) \
- $(use_enable unicode) \
- $(use_with zlib) \
- --disable-compiler-warnings \
- --without-selinux \
- --without-start-stop-daemon
-}
-
-src_install() {
- strip-linguas ${LANGS}
- if [ -z "${LINGUAS}" ] ; then
- LINGUAS=none
- fi
-
- emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
- rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
- dodoc ChangeLog THANKS TODO
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/dpkg-1.16.1.2.ebuild b/app-arch/dpkg/dpkg-1.16.1.2.ebuild
deleted file mode 100644
index c5a8e3c18a4e..000000000000
--- a/app-arch/dpkg/dpkg-1.16.1.2.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.16.1.2.ebuild,v 1.2 2012/05/03 01:58:53 jdhore Exp $
-
-EAPI=3
-
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="bzip2 dselect nls test unicode zlib"
-
-LANGS="
- ast bs ca cs da de dz el eo es et eu fr gl hu id it ja km ko ku lt mr nb ne
- nl nn pa pl pt_BR pt ro ru sk sv th tl vi zh_CN zh_TW
-"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-RDEPEND=">=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- sys-devel/flex
- virtual/pkgconfig
- nls? ( app-text/po4a )
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )"
-
-src_prepare() {
- # don't mess with linker optimisation, respect user's flags (don't break!)
- sed -i -e '/DPKG_LINKER_OPTIMISATIONS/d' configure.ac || die
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- epatch "${FILESDIR}"/${PN}-1.16.1-bootstrap.patch
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- local myconf
- if use nls; then
- myconf="--enable-nls $(use_with dselect)"
- else
- if use dselect; then
- elog "Building dselect requires USE=nls - disabling USE=dselect..."
- fi
- myconf="--disable-nls --without-dselect"
- fi
- econf \
- ${myconf} \
- $(use_with bzip2 bz2) \
- $(use_enable unicode) \
- $(use_with zlib) \
- --disable-compiler-warnings \
- --without-selinux \
- --without-start-stop-daemon
-}
-
-src_install() {
- strip-linguas ${LANGS}
- if [ -z "${LINGUAS}" ] ; then
- LINGUAS=none
- fi
-
- emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
- rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
- dodoc ChangeLog THANKS TODO
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/dpkg-1.16.1.ebuild b/app-arch/dpkg/dpkg-1.16.8.ebuild
index b64db4843fcc..2f23af098639 100644
--- a/app-arch/dpkg/dpkg-1.16.1.ebuild
+++ b/app-arch/dpkg/dpkg-1.16.8.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.16.1.ebuild,v 1.4 2012/05/03 01:58:53 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.16.8.ebuild,v 1.1 2012/07/21 13:18:20 jer Exp $
-EAPI=3
+EAPI=4
inherit eutils multilib autotools toolchain-funcs
DESCRIPTION="Package maintenance system for Debian"
HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
@@ -30,18 +30,20 @@ RDEPEND=">=dev-lang/perl-5.6.0
zlib? ( >=sys-libs/zlib-1.1.4 )
bzip2? ( app-arch/bzip2 )"
DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/flex
+ app-arch/xz-utils
nls? ( app-text/po4a )
+ sys-devel/flex
+ virtual/pkgconfig
test? (
dev-perl/DateTime-Format-DateParse
dev-perl/IO-String
dev-perl/Test-Pod
)"
+REQUIRED_USE="dselect? ( nls )"
src_prepare() {
- # don't mess with linker optimisation, respect user's flags (don't break!)
- sed -i -e '/DPKG_LINKER_OPTIMISATIONS/d' configure.ac || die
+ # do not expect Debian's gzip --rsyncable extension
+ epatch "${FILESDIR}"/${PN}-1.16.4.2-gzip-rsyncable.patch
# Force the use of the running bash for get-version (this file is never
# installed, so no need to worry about hardcoding a temporary bash)
@@ -53,29 +55,26 @@ src_prepare() {
-e '/850_Dpkg_Compression.t/d' \
|| die "sed failed"
- epatch "${FILESDIR}"/${PN}-1.16.1-bootstrap.patch
+ # test fails (bug #414095)
+ sed -i utils/Makefile.am \
+ -e '/^test_cases/d;/100_update_alternatives/d' || die
+
eautoreconf
}
src_configure() {
tc-export CC
- local myconf
- if use nls; then
- myconf="--enable-nls $(use_with dselect)"
- else
- if use dselect; then
- elog "Building dselect requires USE=nls - disabling USE=dselect..."
- fi
- myconf="--disable-nls --without-dselect"
- fi
econf \
${myconf} \
- $(use_with bzip2 bz2) \
+ $(use_enable dselect) \
$(use_enable unicode) \
+ $(use_with bzip2 bz2) \
$(use_with zlib) \
--disable-compiler-warnings \
+ --disable-compiler-optimisations \
+ --disable-linker-optimisations \
--without-selinux \
- --without-start-stop-daemon
+ --disable-start-stop-daemon
}
src_install() {
diff --git a/app-arch/dpkg/files/dpkg-1.15.5.6-bootstrap.patch b/app-arch/dpkg/files/dpkg-1.15.5.6-bootstrap.patch
deleted file mode 100644
index dd5cbf1f8292..000000000000
--- a/app-arch/dpkg/files/dpkg-1.15.5.6-bootstrap.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/m4/dpkg-arch.m4 2010-01-08 18:23:06.000000000 +0100
-+++ b/m4/dpkg-arch.m4 2010-02-05 08:13:09.000000000 +0100
-@@ -5,7 +5,7 @@
- AC_DEFUN([_DPKG_ARCHITECTURE], [
- AC_REQUIRE([AC_CANONICAL_HOST])dnl
- $2=$(cd $srcdir/scripts; \
-- PERL5LIB=$(pwd) ./dpkg-architecture.pl -t$host -q$1 2>/dev/null)
-+ pkgdatadir=.. PERL5LIB=$(pwd) ./dpkg-architecture.pl -t$host -q$1 2>/dev/null)
- ])# _DPKG_ARCHITECURE
-
- # DPKG_CPU_TYPE
---- a/scripts/Dpkg/Arch.pm 2010-01-08 09:00:34.000000000 +0100
-+++ b/scripts/Dpkg/Arch.pm 2010-02-05 08:49:42.000000000 +0100
-@@ -47,8 +47,7 @@
- return $build_arch if defined $build_arch;
-
- my $build_arch = `dpkg --print-architecture`;
-- # FIXME: Handle bootstrapping
-- syserr("dpkg --print-architecture failed") if $? >> 8;
-+ if ($? >> 8) { $build_arch = get_raw_host_arch(); }
-
- chomp $build_arch;
- return $build_arch;
diff --git a/app-arch/dpkg/files/dpkg-1.16.1-bootstrap.patch b/app-arch/dpkg/files/dpkg-1.16.1-bootstrap.patch
deleted file mode 100644
index 71e224b2d733..000000000000
--- a/app-arch/dpkg/files/dpkg-1.16.1-bootstrap.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/m4/dpkg-arch.m4 2011-10-12 07:56:03.000000000 +0200
-+++ b/m4/dpkg-arch.m4 2011-10-18 23:36:24.311829478 +0200
-@@ -9,7 +9,7 @@
- AC_REQUIRE([DPKG_PROG_PERL])dnl
- AC_REQUIRE([AC_CANONICAL_HOST])dnl
- $2=$(cd $srcdir/scripts; \
-- PERL5LIB=$(pwd) $PERL dpkg-architecture.pl -t$host -q$1 2>/dev/null)
-+ pkgdatadir=.. PERL5LIB=$(pwd) $PERL dpkg-architecture.pl -t$host -q$1 2>/dev/null)
- ])# _DPKG_ARCHITECURE
-
- # DPKG_CPU_TYPE
---- a/scripts/Dpkg/Arch.pm 2011-10-14 06:58:09.000000000 +0200
-+++ b/scripts/Dpkg/Arch.pm 2011-10-18 23:38:13.714474150 +0200
-@@ -50,8 +50,7 @@
- return $build_arch if defined $build_arch;
-
- my $build_arch = `dpkg --print-architecture`;
-- # FIXME: Handle bootstrapping
-- syserr("dpkg --print-architecture failed") if $? >> 8;
-+ if ($? >> 8) { $build_arch = get_raw_host_arch(); }
-
- chomp $build_arch;
- return $build_arch;