summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2006-12-17 15:55:29 +0000
committerChristian Birchinger <joker@gentoo.org>2006-12-17 15:55:29 +0000
commit4be5674e954fc0e6d161dc70b684927aa2a0a81b (patch)
tree32faba848ffbbd639ff363563f0cbea160c0c344 /app-admin
parentRemove old version (diff)
downloadgentoo-2-4be5674e954fc0e6d161dc70b684927aa2a0a81b.tar.gz
gentoo-2-4be5674e954fc0e6d161dc70b684927aa2a0a81b.tar.bz2
gentoo-2-4be5674e954fc0e6d161dc70b684927aa2a0a81b.zip
Added a patch for the missing optarg in recent glibcs
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ccze/ChangeLog8
-rw-r--r--app-admin/ccze/ccze-0.2.1-r2.ebuild41
-rw-r--r--app-admin/ccze/files/ccze-segfault.patch30
-rw-r--r--app-admin/ccze/files/digest-ccze-0.2.1-r23
4 files changed, 81 insertions, 1 deletions
diff --git a/app-admin/ccze/ChangeLog b/app-admin/ccze/ChangeLog
index 3cc84f18a77e..9702d442f9c8 100644
--- a/app-admin/ccze/ChangeLog
+++ b/app-admin/ccze/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/ccze
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ccze/ChangeLog,v 1.17 2006/12/17 15:35:32 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ccze/ChangeLog,v 1.18 2006/12/17 15:55:29 joker Exp $
+
+*ccze-0.2.1-r2 (17 Dec 2006)
+
+ 17 Dec 2006; Christian Birchinger <joker@gentoo.org>
+ +files/ccze-segfault.patch, +ccze-0.2.1-r2.ebuild:
+ Added a patch for the missing optarg in recent glibcs
17 Dec 2006; Christian Birchinger <joker@gentoo.org> -ccze-0.2.1.ebuild:
Remove old version
diff --git a/app-admin/ccze/ccze-0.2.1-r2.ebuild b/app-admin/ccze/ccze-0.2.1-r2.ebuild
new file mode 100644
index 000000000000..91b4867b8f8e
--- /dev/null
+++ b/app-admin/ccze/ccze-0.2.1-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ccze/ccze-0.2.1-r2.ebuild,v 1.1 2006/12/17 15:55:29 joker Exp $
+
+inherit fixheadtails autotools eutils
+
+DESCRIPTION="A flexible and fast logfile colorizer"
+HOMEPAGE="http://bonehunter.rulez.org/software/ccze/"
+SRC_URI="ftp://bonehunter.rulez.org/pub/ccze/stable/${P}.tar.gz"
+
+RESTRICT="test"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-libs/libpcre"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}"/ccze-fbsd.patch || die "epatch ccze-fbsd.patch failed"
+ epatch "${FILESDIR}"/ccze-segfault.patch || die "epatch ccze-segfault.patch"
+
+ # GCC 4.x fixes
+ sed -e 's/-Wswitch -Wmulticharacter/-Wswitch/' \
+ -i src/Makefile.in
+ sed -e '/AC_CHECK_TYPE(error_t, int)/d' \
+ -i configure.ac
+
+ eautoreconf
+
+ ht_fix_file Rules.mk.in
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog ChangeLog-0.1 NEWS THANKS README FAQ
+}
diff --git a/app-admin/ccze/files/ccze-segfault.patch b/app-admin/ccze/files/ccze-segfault.patch
new file mode 100644
index 000000000000..fa30d2f515c1
--- /dev/null
+++ b/app-admin/ccze/files/ccze-segfault.patch
@@ -0,0 +1,30 @@
+diff -ruN ccze-0.2.1.orig/src/ccze.c ccze-0.2.1/src/ccze.c
+--- ccze-0.2.1.orig/src/ccze.c 2003-05-13 20:09:30.000000000 +0200
++++ ccze-0.2.1/src/ccze.c 2006-12-12 20:36:09.000000000 +0100
+@@ -209,7 +209,7 @@
+ }
+ break;
+ case 'a':
+- plugin = strtok (optarg, "=");
++ plugin = strtok (arg, "=");
+ value = strtok (NULL, "\n");
+ ccze_plugin_argv_set (plugin, value);
+ break;
+@@ -249,7 +249,7 @@
+ ccze_config.remfac = 1;
+ break;
+ case 'm':
+- subopts = optarg;
++ subopts = arg;
+ while (*subopts != '\0')
+ {
+ switch (getsubopt (&subopts, m_subopts, &value))
+@@ -273,7 +273,7 @@
+ }
+ break;
+ case 'o':
+- subopts = optarg;
++ subopts = arg;
+ while (*subopts != '\0')
+ {
+ switch (getsubopt (&subopts, o_subopts, &value))
diff --git a/app-admin/ccze/files/digest-ccze-0.2.1-r2 b/app-admin/ccze/files/digest-ccze-0.2.1-r2
new file mode 100644
index 000000000000..6bfb802e7ad1
--- /dev/null
+++ b/app-admin/ccze/files/digest-ccze-0.2.1-r2
@@ -0,0 +1,3 @@
+MD5 221966bce7c5f011eca38157241a0432 ccze-0.2.1.tar.gz 139795
+RMD160 22d89140ea0518c6a33c07464620a2a1fb212b94 ccze-0.2.1.tar.gz 139795
+SHA256 8263a11183fd356a033b6572958d5a6bb56bfd2dba801ed0bff276cfae528aa3 ccze-0.2.1.tar.gz 139795