summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-09-18 17:23:49 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-09-18 17:23:49 +0000
commit2d46cb71a7dd29afa74562ae73463d61c3e37e8b (patch)
tree5bc5ebe9aa47bd1dcfd404262f23074087e2b1d1 /app-admin
parentalpha/ia64/s390/sh/sparc stable wrt #355085 (diff)
downloadgentoo-2-2d46cb71a7dd29afa74562ae73463d61c3e37e8b.tar.gz
gentoo-2-2d46cb71a7dd29afa74562ae73463d61c3e37e8b.tar.bz2
gentoo-2-2d46cb71a7dd29afa74562ae73463d61c3e37e8b.zip
update ebuilds to use bash-completion-r1 eclass
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/equo/ChangeLog6
-rw-r--r--app-admin/equo/equo-1.0_rc38.ebuild7
-rw-r--r--app-admin/equo/equo-1.0_rc43.ebuild7
-rw-r--r--app-admin/equo/equo-1.0_rc53.ebuild5
4 files changed, 13 insertions, 12 deletions
diff --git a/app-admin/equo/ChangeLog b/app-admin/equo/ChangeLog
index f14403e7ae47..8e74a322b41b 100644
--- a/app-admin/equo/ChangeLog
+++ b/app-admin/equo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/equo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.12 2011/09/18 10:48:38 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.13 2011/09/18 17:23:49 lxnay Exp $
+
+ 18 Sep 2011; Fabio Erculiani <lxnay@gentoo.org> equo-1.0_rc38.ebuild,
+ equo-1.0_rc43.ebuild, equo-1.0_rc53.ebuild:
+ update ebuilds to use bash-completion-r1 eclass
*equo-1.0_rc53 (18 Sep 2011)
diff --git a/app-admin/equo/equo-1.0_rc38.ebuild b/app-admin/equo/equo-1.0_rc38.ebuild
index 6b0aff0ae138..09a9e65da856 100644
--- a/app-admin/equo/equo-1.0_rc38.ebuild
+++ b/app-admin/equo/equo-1.0_rc38.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-1.0_rc38.ebuild,v 1.1 2011/08/12 09:30:46 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-1.0_rc38.ebuild,v 1.2 2011/09/18 17:23:49 lxnay Exp $
EAPI="3"
PYTHON_DEPEND="2"
-inherit eutils python bash-completion
+inherit eutils python bash-completion-r1
DESCRIPTION="Entropy Package Manager text-based client"
HOMEPAGE="http://www.sabayon.org"
@@ -26,12 +26,11 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" LIBDIR="usr/lib" equo-install || die "make install failed"
- dobashcompletion "${S}/misc/equo-completion.bash" equo
+ newbashcomp "${S}/misc/equo-completion.bash" equo
}
pkg_postinst() {
python_mod_optimize "/usr/lib/entropy/client"
- bash-completion_pkg_postinst
echo
elog "If you would like to allow users in the 'entropy' group"
elog "to update available package repositories, please consider"
diff --git a/app-admin/equo/equo-1.0_rc43.ebuild b/app-admin/equo/equo-1.0_rc43.ebuild
index 814c80534071..7ca615b0540d 100644
--- a/app-admin/equo/equo-1.0_rc43.ebuild
+++ b/app-admin/equo/equo-1.0_rc43.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-1.0_rc43.ebuild,v 1.1 2011/08/23 10:06:40 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-1.0_rc43.ebuild,v 1.2 2011/09/18 17:23:49 lxnay Exp $
EAPI="3"
PYTHON_DEPEND="2"
-inherit eutils python bash-completion
+inherit eutils python bash-completion-r1
DESCRIPTION="Entropy Package Manager text-based client"
HOMEPAGE="http://www.sabayon.org"
@@ -26,12 +26,11 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" LIBDIR="usr/lib" equo-install || die "make install failed"
- dobashcompletion "${S}/misc/equo-completion.bash" equo
+ newbashcomp "${S}/misc/equo-completion.bash" equo
}
pkg_postinst() {
python_mod_optimize "/usr/lib/entropy/client"
- bash-completion_pkg_postinst
echo
elog "If you would like to allow users in the 'entropy' group"
elog "to update available package repositories, please consider"
diff --git a/app-admin/equo/equo-1.0_rc53.ebuild b/app-admin/equo/equo-1.0_rc53.ebuild
index 95a01527157c..d4bcad8dbc44 100644
--- a/app-admin/equo/equo-1.0_rc53.ebuild
+++ b/app-admin/equo/equo-1.0_rc53.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-1.0_rc53.ebuild,v 1.1 2011/09/18 10:48:38 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-1.0_rc53.ebuild,v 1.2 2011/09/18 17:23:49 lxnay Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -26,12 +26,11 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" LIBDIR="usr/lib" equo-install || die "make install failed"
- dobashcompletion "${S}/misc/equo-completion.bash" equo
+ newbashcomp "${S}/misc/equo-completion.bash" equo
}
pkg_postinst() {
python_mod_optimize "/usr/lib/entropy/client"
- bash-completion_pkg_postinst
echo
elog "If you would like to allow users in the 'entropy' group"
elog "to update available package repositories, please consider"